12 Replies Latest reply on Feb 26, 2013 7:07 AM by er.abhishekdwevedi

    ADT package command

    community help Level 1

      This question was posted in response to the following article: http://help.adobe.com/en_US/air/build/WS901d38e593cd1bac1e63e3d128cdca935b-8000.html

        • 1. Re:  ADT package command

          I package an iOS app with a native extension  for gyroscope(http://code.google.com/p/air-native-extension-euler-gyroscope/)

          in this way  

          ipa-test-interpreter  ALL OK

          ipa-test  iPhone 4s crash.


          Another question.

          I monitor my app  with Stats and

          framerate is 60/60

          MS is 20/30

          memory 4.000 more or less


          but gyroscope does not uptade values properly.

          is it possible that "interpreter" mode reduces native extension performance ?


          thanks in advance



          • 2. Re:  ADT package command
            jrunrandy Adobe Employee

            I don't know for sure, but wouldn't be surprised if "interpreter" reduced performance all around.


            I don't know why ipa-test doesn't work. Does ipa-ad-hoc work?


            Maybe post your entire adt command and others might be able to give feedback.


            Best regards,

            Randy Nielsen

            Senior Content and Community Manager

            Adobe Systems Incorporated

            • 3. Re:  ADT package command
              marcaia Level 1


              I've not checked with ipa-ad-hoc yet.



              meanwhile, i link to my ANT script to compile ipa




              I use FDT 4.5.3.

              Folders structure are


              - src

              - libs

                   . EulerGyroscope.swc

                   . EulerGyroscope.ane

              - bin

                   - development

                        - ios

                             . GyroscopeDemo-app.xml

                             . GyroscopeDemo-dev.ipa

                             . GyroscopeDemo.swf

                             - ant

                                  . dev_build.properties

                                  . dev-build.xml

                                  . iOS.properties


              Message was edited by: marcaia I solved problem about ipa-test. I used EulerGyroscope.swc as Runtime shared Code. I added new folder named "extensions" and moved EulerGyroscope.ane inside. in compiler arguments i defined -extdir extensions now it works :)

              • 4. Re:  ADT package command

                HI, i saw your post and read that you succesfully used gyroscope with euler on flash, i've been posting in forums because i'm not able to run either the Adobe or Euler gyroscope ANE's in flash CS6. As i posted at the Adobe Gyroscope page i succesfully used Arduino, Kinect, Vibration and Notificaction ANE's, compiling for Desktop&iOS accordingly, but the gyroscope ANE fails silently when i open the app on the iOS device.


                Do you have any piece of an advice for me?, i've tried a lot of configurations/approachs and none of them works.



                • 5. Re:  ADT package command
                  neh@adobe Level 3



                  Do you mean your app crashes when you use gyroscope ane or it simply fails to work?

                  I guess you are using the Native Extensions tab in Flash Builder to link the ANE to the project. Do you get any warnings or errors at the time of packaging? Which targets did you try?

                  Also, in your application, have you used

                  if(Gyroscope.isSupported) ?


                  Maybe, you can try printing the value of Gyroscope.isSupported in a text field.

                  • 6. Re:  ADT package command

                    I spent the whole day today trying to make the gyroscope work. I already used the in-app nat. ext. from milkman, so I knew the steps. But when I opened my test project with the gyroscope nat. ext., the screen stayed black and the app closed after a few seconds.


                    Then, some minutes ago I found out that while I always generated my ipa files with the "ipa-app-store" option (because I always want to see the real performance) the gyro only worked when I used "ipa-test-interpreter". ipa-ad-hoc didn't work either.


                    Yay, it worked. But why doesn't it work with the ipa-app-store option? How will I test the real performance if I can't use the app store option? How will I know that when I generate the distribution ipa with the ipa-app-store option, it will work when Apple reviews my app?

                    • 7. Re:  ADT package command
                      marcaia Level 1

                      Hi leandroeidi

                      I had the same problem with -target In my case ipa-test did not work, while ipa-test-interpreter worked.


                      I use an IDE that does not support native extensions, so I have to compile with ANT.


                      I solved problem about ipa-test using the swc as Runtime shared Code.

                      I added new folder named "extensions" and moved EulerGyroscope.ane inside. in compiler arguments i defined -extdir extensions 


                      Configure Native extension in Flash Builder is easier, because you can use the Native Extensions tab, as suggested by neh@adobe

                      • 8. Re:  ADT package command
                        leandroeidi Level 1

                        I tried that, but it didn't work, either. At least not with ipa-app-store.


                        I wish someone who went through this came and said "yeah, when testing, only ipa-test-interpreter worked, but when creating the distribution version, I used ipa-app-store, Apple approved my App, and I saw it working when downloaded from App Store". Until that happens, or someone finds a way to test using ipa-app-store, I won't use it in my projects. It would be terrible to use my time making an app, and finding out that it won't work only when submitting  to Apple.


                        And I never used Flash Builder, I only work with Flash Professional.

                        • 9. Re:  ADT package command
                          theguaz Level 1

                          Ok, i've read all the answers and i tried again and it did not worked, my app crashes on start after initialization on my ipad/iphone4.

                          Then in order to see what may be wrong, i tried to start a remote debug session, and i discovered another problem, my app cannot connect with debugger via wifi.

                          I tried Quick Publishing and Ad-Hoc, none worked.

                          I tried including SDK and not inlcuding SDK.

                          I also tried with another 3rd party gyroscope ane.


                          My questions after reading all of your answers now are:


                          - can be possible that my demo of flashCS6 is buggy, i say this because of the remote debug thing. Should i use F.Builder whenever i want to code a simple app?, what if i really like the flash ide for it?


                          - Why Vibration & Notificaction worked using the new FlashCS6 IDE targeting iOS, and also non Adobe ANE's like arduino&kinect on desktop AIR. i followed the code examples on each case and all worked but gyroscope not.

                          My test class looks like the code below, look how closely is to adobe code:


                          package  com.theguaz{


                              import flash.events.*;

                              import flash.display.*;


                              import com.adobe.nativeExtensions.Gyroscope;

                              import com.adobe.nativeExtensions.GyroscopeEvent;

                              import com.adobe.nativeExtensions.GyroscopeIntervalValue;


                              public class test extends MovieClip{


                                  public function test() {

                                      addEventListener(Event.ADDED_TO_STAGE, setupUI);



                                  private function setupUI(event:Event) : void{

                                      stage.quality = StageQuality.LOW;

                                      stage.scaleMode = StageScaleMode.NO_SCALE;

                                      stage.align = StageAlign.TOP_LEFT;

                                      removeEventListener(Event.ADDED_TO_STAGE, setupUI);




                                  private function setGyro():void{

                                      var gyro:Gyroscope;

                                      if(Gyroscope.isSupported) {

                                          gyro = new Gyroscope();






                                  private function onChange(e:GyroscopeEvent):void {

                                      gyro_txt.text = String("From gyro: " + e.x + " " + e.y + " " + " " + e.z);






                          thank's to all of you for helping me with this.


                          • 10. Re:  ADT package command

                            I'm trying to codesign and timestamp an apk from an airi file. unfortunatley, i am only able to create an air file from this with a timestamp


                            so now i have a well signed and timestamped air file. how do i get an apk file from this? i am able to convert it without a timestamp, but then agin google play tells me my apk file needs a certificate ( i have a valid one purchased at globalsign.com) that is valid until 2033.


                            So i am able to create an apk file without timestamp but codesigned ( not helpful) or an air file codesigned and timestamped (not helpful either), but NOT what i need - an apk file codesigned AND timestamped.


                            For my understanding i would say this is waht needs to be done:


                            Create a native package from an AIR or AIRI file:


                            adt -package

                            -target packageType





                            so what i do is


                            ./adt -package -target apk  -storetype pkcs12 -keystore aircertificate.p12  -tsa http://timestamp.globalsign.com/scripts/timestamp.dll myappname.apk myappname.airi


                            and what it says is:


                            -tsa option not supported


                            it doesn't say that when i use adt -sign, but signing only allows me to create an air file.


                            trying to simple convert my signed and timestamp air file to an apk file WITHOUT codesigning options like this


                            ./adt -package -target apk myappname.apk myappname.air


                            shows that:


                            Signing options required to package APK


                            help please!!!


                            best regards



                            • 11. Re:  ADT package command
                              bonsai123 Level 1

                              after much clicking around i’ve got it working solution is simple. for ipa-ad-hoc or ipa-app-store (translated code) the Gyroscope.swc should be removed from exports. the ane should of course still be referenced in the application descriptor file. in FDT this is done by setting the swc to “Use as Runtime Shared Code” under project properties > FDT Build Path > Build Order. i imagine there’s a similar option in Flash Builder and Flash CS5 or 6. as i understand it, this is how all ANE’s work.

                              i saw this information in the description of a variant of the Adobe Gyroscope developed by Christoph Ketzler found here..

                              http://code.google.com/p/air-native-extension-euler-gyroscope/downloads/detail?name=EulerG yroscope-2012-03-18-RELEASE.zip&can=2&q=

                              • 12. Re:  ADT package command

                                Hi Team,


                                I have created an iPad App.


                                adt.bat -package -target ipa-app-store  :  makes an .ipa which installs on my iPad, but fails to run it brings up splash screen and halts


                                adt.bat -package -target ipa-test : makes an .ipa which installs on my iPad, but fails to run  it brings up splash screen and halts


                                adt.bat -package -target ipa-test-interpreter : makes an .ipa which installs on my iPad and successfully runs


                                After issue, i create a simple app using just one label , still the same issue


                                I am using correct distribution provision and certificates .


                                help appreciated..!!