31 Replies Latest reply: Jun 18, 2014 12:50 AM by gideonv RSS

    Extra bold text?

    DannyH.

      Hi,

       

      I create a WebHelp with RH 9. It is a new project which was created in RH 9.

       

      The text contains words in bold (like this). Some short lines (style Normal like the text) are also bold. These lines are not headlines, but they should be highlighted in bold (see below).

      To add bold I use the bold button of RH. When I generate the WebHelp and open it in Firefox (currently version 11), then words within a text and the short bold line look different ?! The single word appears extra bold and the line appears normal bold.

       

      The genereated HTML looks like:

      for a word: <span style="font-weight: bold;"><b>word in bold</b></span>

      for the short line: <p style="font-weight: bold;">line in bold</p>

       

      When I switch to the HTML view in RH it looks like:

      for a word: <span style="font-weight: bold;">word in bold</span>

      for the short line: <p style="font-weight: bold;">line in bold</p>

       

      Why does the generation procedure handle bold things different? And why does it add the <b> tag for words within a longer text? I don't want to create a special style sheet for bold words when there is a button to make a word bold.

       

      Can someone explain that?

       

      Regards

      DannyH

        • 1. Re: Extra bold text?
          Willam van Weelden CommunityMVP

          Hi,

           

           

           

          I just did a quick test on RH9 and Robo inserts the span as wel as the for the span and the paragraph in my case. Is there a special routine you use for making bold paragraphs? I fiddled with several settings, but I could not get the result you describe.

           

           

           

          Greet,

           

           

           

          Willam

          • 2. Re: Extra bold text?
            DannyH. Community Member

            Hi Willam,

             

            yes, RH9 inserts span. This is correct. Now generate a WebHelp and open this in a browser like Firefox 11. The single word within a text appears super bold and the bold paragraph appears normal bold. Right click into the text shown in the browser and display the HTML code. Now you see <span><b>word</b></span> (= super bold) and <span>paragraph</span> (normal bold).

             

            Regards

            DannyH

            • 3. Re: Extra bold text?
              Willam van Weelden CommunityMVP

              Mmmh, I tested on two different RoboHelp installations. On one installation, I don't get the result you describe. On the other installation I do get the HTML code you describe, but I don't see any difference in bold text in the output. I must be going nuts...

               

              Could your CSS be interfering somehow by adding a 'font-weight: bolder;' to the <b> element? I will test some more to see what makes the difference.

               

              Greet,

               

              Willam

              • 4. Re: Extra bold text?
                robopenguin Community Member

                Hi,

                 

                We are seeing the same issue in RH 9.0.1.232 on Windows 7.

                 

                The text <span style="font-weight: bold;">Text</span> becomes <span style="font-weight: bold;"><b>Text</b></span> when webhelp is generated.

                 

                Whether this appears as "super-bold" in a browser seems to vary depending on the user. When viewing the topic in Firefox 12, the bold text looked fine to me, but a colleague who viewed the same topic on her PC (also in FF12) saw the text as "super-bold."

                 

                I wonder if this means that it is something to do with some local browser settings or display settings on the PC used to view the topic?

                 

                Any idea why RH is inserting the <b> tags in generated files?

                 

                Cheers,

                Dave

                • 5. Re: Extra bold text?
                  robopenguin Community Member

                  Sorry, to clarify, I didn't mean that each user's perception of the boldness of the text varied. The boldness of the text actually did look different on two separate PCs running FF12.

                   

                  Dave

                  • 6. Re: Extra bold text?
                    Peter Grainge CommunityMVP

                    I've seen the code your describe and, as Willam, has stated, it will not affect appearance.

                    1. What font are you using?
                    2. Are the two PCs running at different screen resolutions?

                     

                    It might help to see screenshots. Use the camera icon you will see when replying to insert the images.

                     


                    See www.grainge.org for RoboHelp and Authoring tips

                     

                    @petergrainge

                    • 7. Re: Extra bold text?
                      robopenguin Community Member

                      Hi Peter,

                       

                      I think I figured this out. This seems to be a Firefox issue whereby the <b> tag in conjunction with some additional bold formatting on the text (via a style or span tag) is interpreted by Firefox as "bolder". We are using Arial 10pt for the style in the css, so Firefox looks for a font that is bolder than Arial Bold and renders the text as Arial Black.

                       

                      This is apparently caused by Direct2D/DirectWrite hardware acceleration in Firefox. Disabling hardware acceleration resolved the issue for my collegue. You can do that from the Advanced tab in the Firefox Options dialog box. Interestingly, I have hardware acceleration enabled and I don't see the issue at all, so go figure!

                       

                      Detailed discussion of the issue can be found at:

                      https://bugzilla.mozilla.org/show_bug.cgi?id=548975

                      https://bugzilla.mozilla.org/show_bug.cgi?id=550128

                       

                      For reference, here is a screenshot of the topic in Firefox 12 from my colleague's laptop with hardware acceleration enabled.

                      1920 x 1080 laptop.png

                      Here is a screenshot of the topic in Firefox 12 with hardware acceleration turned off.

                      1920 x 1080 laptop hw_disabled.png

                       

                      I'm not sure what the HTML/CSS specifications say about how the double bold formatting markup should be interpreted by browsers. Mozilla doesn't seem to consider this a bug.

                       

                      However, I do wonder what the reasoning is behind RH inserting those <b> tags. If the HTML specs do say that <span style="font-weight: bold;"><b>Text</b> should be interpreted as bolder text, then RH's addition of the <b> tag is changing the markup to something that was not intended by the author.

                       

                      Cheers,

                      Dave

                      • 8. Re: Extra bold text?
                        Peter Grainge CommunityMVP

                        Your images are the same size but note that the words at the end of the line starting "Pinnacle" are different. That suggests the issue is to do with the zoom level the two machines are set at. Check that out.

                         


                        See www.grainge.org for RoboHelp and Authoring tips

                         

                        @petergrainge

                        • 9. Re: Extra bold text?
                          DannyH. Community Member

                          Hi,

                           

                          this is interesting. I disabled hardware acceleration and the text appears as it should. All bold things have the same appearance - that is what I want.

                           

                          Screenshot (disabled hardware acceleration):

                          Clipboard01.jpg

                           

                          Screenshot (enabled hardware acceleration):

                          Clipboard02.jpg

                           

                          Both have same zoom in Firefox 12, in version 11 it looked the same.

                           

                          Telling the customers to disable hardware acceleration when using Firefox before reading the online help is not a good solution. The best would be that RH stops generating <span><b>...</b></span> things and this happens after I started the Web Help generation. I cannot influence this.

                           

                          Regards

                          DannyH

                          • 10. Re: Extra bold text?
                            Peter Grainge CommunityMVP

                            I don't know if that is a bug but I can only suggest reporting it as such.

                             

                            Can you identify a style difference between the first bold line and the second as that is where it is most obvious?

                             


                            See www.grainge.org for RoboHelp and Authoring tips

                             

                            @petergrainge

                            • 11. Re: Extra bold text?
                              Willam van Weelden CommunityMVP

                              Apart from reporting is as a bug, as a workaround, you can use a script or a search and replace to remove all the tags from your output. It’s more work for you, but you customers won’t have to do anything.

                               

                               

                               

                              Greet,

                               

                               

                               

                              Willam

                              • 12. Re: Extra bold text?
                                DannyH. Community Member

                                There are the following differences for the example pictures above:

                                 

                                The source html file (before generation) contains:

                                <p style="font-weight: bold;">Aufbau der Online-Hilfe</p>

                                <?rh-list_start class="ListBullet" level="1" ?>

                                <p class="ListBullet" style="margin-left: 40px;"><span style="font-weight: bold;">Inhaltsverzeichnis</span><br />

                                Im linken Bereich erhalten Sie einen strukturierten Überblick über die einzelnen Hilfethemen.</p>

                                 

                                And the result html file after WebHelp generation contains:

                                <p style="font-weight: bold;">Aufbau der Online-Hilfe</p>

                                <p class="ListBullet" style=" margin-left: 40px;"><span style="font-family:'Microsoft Sans Serif'" >•</span><span style='word-spacing:normal; font:6.0pt "Times New Roman"'><font size="1" style="font-size:6pt;">           </font></span><span style="font-weight: bold;"><b>Inhaltsverzeichnis</b></span><br />

                                Im linken Bereich erhalten Sie einen strukturierten Überblick über die einzelnen Hilfethemen.</p>

                                • 13. Re: Extra bold text?
                                  Peter Grainge CommunityMVP

                                  Create a project with one topic that contains just the above content and uses the same CSS. Check your output from it does create the problem you describe.

                                   

                                  See the Contact page on my site and send the project as instructed there. Do make sure you include a link to this thread and please do not email the project direct.

                                   


                                  See www.grainge.org for RoboHelp and Authoring tips

                                   

                                  @petergrainge

                                  • 14. Re: Extra bold text?
                                    Peter Grainge CommunityMVP

                                    I see similar differences in the source and output and have toggled the hardware acceleration before launching the help. I can see no diiference but a quick Google suggests it is only going to impact certain machines anyway.

                                     

                                    Have you established the code you refer to is linked with the problem by editing an output topic to remove it?

                                     

                                    Otherwise, my thinking is you are going to have to live with this.

                                     


                                    See www.grainge.org for RoboHelp and Authoring tips

                                     

                                    @petergrainge

                                    • 15. Re: Extra bold text?
                                      DannyH. Community Member

                                      If those additional <b> tags in the output would not be there, everything would be ok. And those tags are definitely added by RH. I do nothing else than writing the content in RH and when finished I press the button for webhelp generation. I think, I write a bug report.

                                       

                                      Of course I could delete all <b> tags from the output files  - hoping that there are no other <b> tags that are necessary somewhere. This workaround takes time: I have ca. 50 files, 6 languages and 3 variations for each language.

                                       

                                      Which machines are mentioned by google? I'm working with Windows 7. Last year I was working with Windows XP and there I did not have this problem.

                                      • 16. Re: Extra bold text?
                                        Peter Grainge CommunityMVP

                                        I am not arguing that you are doing anything with the code or denying that RoboHelp is adding the <b> tag. You are saying "If those additional <b> tags in the output would not be there, everything would be ok." My point was to edit those tags out of the output file to see if all is then OK. From what I am reading you are saying they are the cause but I am not clear whether that is theory on your part or that you have proved it.

                                         

                                        Enter "Direct2D/DirectWrite hardware acceleration" into Google and see the first link. That suggests to me the setting will only affect machines with certain hardware.

                                         


                                        See www.grainge.org for RoboHelp and Authoring tips

                                         

                                        @petergrainge

                                        • 17. Re: Extra bold text?
                                          DannyH. Community Member

                                          Ah, now I understand - this is sometimes difficult when communicating in a foreign language.

                                           

                                          I have checked this. When I delete the <b> tags from the output files then everything looks great.

                                          • 18. Re: Extra bold text?
                                            Peter Grainge CommunityMVP

                                            You are doing better than I would in whatever your first language is.

                                             

                                            In Design View I created two paragraphs to start with and applied Bold to the first sentence and a single word, the to the whole second paragraph.

                                             

                                            Where there are closing span tags, in the output you will get the extra <b> tags that are causing your problem. You will note there is no closing span tag in the second paragraph and no <b> tag gets written in the output.

                                             

                                            <p><span style="font-weight: bold;">This is some sample text.</span> This

                                            is some sample text. This is some sample text. This is some sample text.

                                            This is some sample text. This is some sample text. This is some sample

                                            text. This is some sample text. This is some sample text. This is some

                                            sample text. This is some sample <span style="font-weight: bold;">text</span>.</p>

                                            <p style="font-weight: bold;">This is some sample text. This is some sample

                                            text. This is some sample text. This is some sample text. This is some

                                            sample text. This is some sample text. This is some sample text. This

                                            is some sample text. This is some sample text. This is some sample text.

                                            This is some sample text.</p>

                                             

                                             

                                            Then I hit Enter and clicked the bold icon to return to normal weight and got this crazy HTML.

                                             

                                            <p style="font-weight: bold;"><span style="font-weight: normal;">Sample

                                            text added later.</span></p>

                                             

                                            I have reported this as a bug.

                                             

                                            Meantime try this. In Tools > Options there is an option Convert RoboHelp edited topics to HTML. Tick that and see if it makes a difference. It will apply to all projects.

                                             

                                            Does that help?

                                             


                                            See www.grainge.org for RoboHelp and Authoring tips

                                             

                                            @petergrainge

                                            • 19. Re: Extra bold text?
                                              DannyH. Community Member

                                              I remember that I have already seen this font-weight thing in my files. This is crazy.

                                               

                                              Activating the Convert RoboHelp edited topics to HTML option does not change anything. Anyway, it was a good idea.

                                              • 20. Re: Extra bold text?
                                                Peter Grainge CommunityMVP

                                                In that case the only option I see for now is Willam's script suggestion.

                                                 

                                                Sorry.

                                                 


                                                See www.grainge.org for RoboHelp and Authoring tips

                                                 

                                                @petergrainge

                                                • 21. Re: Extra bold text?
                                                  DannyH. Community Member

                                                  I also think that this is the only option for the moment. Anyway, I add this to the bug list.

                                                   

                                                  Thank you for your detailed analysis.

                                                  • 22. Re: Extra bold text?
                                                    robopenguin Community Member

                                                    Another option might be to use a character style for bold text. That would probably be more work that using a script on the output files though.

                                                     

                                                    Dave

                                                    • 23. Re: Extra bold text?
                                                      The Real Mike73 Community Member

                                                      I added this to my CSS and it fixed it right up:

                                                       

                                                      b{

                                                      font-weight:bold;

                                                      }

                                                      • 24. Re: Extra bold text?
                                                        Peter Grainge CommunityMVP

                                                        Interesting, so Danny wasn't the only one with this problem.

                                                         

                                                        Thanks for posting a solution Mike.

                                                         


                                                        See www.grainge.org for RoboHelp and Authoring tips

                                                         

                                                        @petergrainge

                                                        • 25. Re: Extra bold text?
                                                          The Real Mike73 Community Member

                                                          P.S. I'm using RH 8, so it must be a change in FF, but it's also annoying that RH adds the extra tags.

                                                           

                                                          If my solution above doesn't work for you, try this:

                                                           

                                                          b{

                                                          font-weight:bold !important;

                                                          }

                                                          • 26. Re: Extra bold text?
                                                            Peter Grainge CommunityMVP

                                                            Please anyone affected by this bug, submit a bug report.

                                                             

                                                            The more people who report a bug or request a feature, the more likely it is to be actioned. Please follow this link.

                                                             

                                                            http://www.Adobe.com/cfusion/mmform/index.cfm?name=wishform&product=38

                                                             


                                                            See www.grainge.org for RoboHelp and Authoring tips

                                                             

                                                            @petergrainge

                                                            • 27. Re: Extra bold text?
                                                              DannyH. Community Member

                                                                   b {

                                                                        font-weight:bold;

                                                                   }

                                                               

                                                              This workaround is working for me. Great!

                                                               

                                                              But please submit a bug report and help to get this solved directly in RH and not by workarounds. I already added a bug report, but one doesn't attract much attention.

                                                              • 28. Re: Extra bold text?
                                                                Authorgirl Community Member

                                                                I have this issue too so am using the workaround for now and have submitted a bug report.

                                                                • 29. Re: Extra bold text?
                                                                  Praful_Jain Community Member

                                                                  hi,

                                                                  Please try the RoboHelp 10, this issue has been fixed in the new release of RoboHelp 10.

                                                                  thanks

                                                                  Praful Jain

                                                                  • 30. Re: Extra bold text?
                                                                    DannyH. Community Member

                                                                    Hi Praful Jain,

                                                                    thanks for this information. I am not allowed to buy new versions every year. I have to live with RH9 at least for the next 2 years.

                                                                    Regards DannyH

                                                                    • 31. Re: Extra bold text?
                                                                      gideonv

                                                                      I seem to have the same problem with RH9 and my solution is to replace the <span style="font-weight: bold;"> and </span> tags with <b> and </b> because it did not happen everywhere and I did not mind handling the issue manually.