4 Replies Latest reply: May 24, 2012 5:52 PM by RodWard RSS

    Captivate 5.5 email/reporting issues

    SeanCole

      I'm using Captivate 5.5 on my office Windows XP machine.

       

      We want users to send their supervisor an email after taking a quiz, but not have the email automatically populate with the generic quiz results. 

       

      So we checked off the "Enable reporting for this project" option and put an emailIcon.swf widget on the results page.  When published as a flash file w/the HTML wrapper and viewed in IE, a "Navigation to the webpage was canceled" window pops up when clicking the icon.  This DID NOT occur when using the quiz reporting email option.  Why does the one send email option fail when the other does not?

        • 1. Re: Captivate 5.5 email/reporting issues
          www.cpguru.com Community Member

          It must have something to do with how the mail to function is called.

           

          The "Navigation to the webpage was canceled" in IE is commonly seen - especially if is IE8. Sometimes running IE8 as an administrator will fix the problem (although this is not a viable solution for all)  is not "Run as Administrator". I bet that if you try it in FireFox, Chrome or Safari you will not see this problem.

           

          As far as I know there is no real solution to this issue.

           


          www.cpguru.com - Adobe Captivate Widgets, Tutorials, Tips and Tricks and much more..

          • 2. Re: Captivate 5.5 email/reporting issues
            SeanCole Community Member

            I figured that the various send email functions (reporting/button/click box/widget) were called/coded differently, probably at different times by different programmers. 

             

            You were right - this issue does not occur when viewing the file in Firefox.  

             

            I would think this almost warrants a 'bug report' - in as much as the all send email functions are part of a file output as flash, run from the same location, from the same browser (IE8), there shouldn't be a security issue from one vs another.

            • 3. Re: Captivate 5.5 email/reporting issues
              Captiv8r CommunityMVP

              Hi there

               

               

              SeanCole wrote:

               

              I figured that the various send email functions (reporting/button/click box/widget) were called/coded differently, probably at different times by different programmers. 

               

              You were right - this issue does not occur when viewing the file in Firefox.  

               

              I would think this almost warrants a 'bug report' - in as much as the all send email functions are part of a file output as flash, run from the same location, from the same browser (IE8), there shouldn't be a security issue from one vs another.

               

              So here's where it gets fun with all the different browsers and browser combinations. You can view the same Flash file in IE and in FireFox. It's totally possible that these two browsers are using vastly different versions of the Flash Player. I opened both on my own computer here. Take a look at the screen shot below:

               

              You may need to click the image to view at full size.

               

              tmp1.PNG

               

              Cheers... Rick

               

              Helpful and Handy Links

              Captivate Wish Form/Bug Reporting Form

              Adobe Certified Captivate Training

              SorcerStone Blog

              Captivate eBooks

              • 4. Re: Captivate 5.5 email/reporting issues
                RodWard CommunityMVP

                Why "almost warrants a bug report"?  Go for it!

                 

                Log the bug and join your voice to the many others that have wanted this issue resolved.  Email reporting has been a continuous pain in the proverbial for a long time now.