Hey, I think that ticket is perhaps not the best one to discuss function name changes, as it covers a bunch of stuff, some of which is not actually correct any more: the whole getFunctionList() side of things has been fixed (or wasn't a problem, or something).
For my 2p, I prefer it as-is: getApplicationMetadata() is closer to how my brain understands the functionality: it's "getting the application metadata", rather than "application: get metadata".
That said, given there's a sessionGetMetadata(), there's clearly a cockup in the naming somewhere: it should either be getApplicationMetadata() and getSessionMetadata(), or it should be applicationGetMetadata() and sessionGetMetadata(). So one of them ought to be changed.
Also, despite getApplicationMetadata() sounding better to me, there's a precedent set in CF for functions to be named as [thing] + [action] (eg: structFind(), imageRead() etc). So to stay as uniform as possible with the rest of the language, getApplicationMetadata() should be changed to applicationGetMetadata(). We're leaking over into PHP-land if we just have a random approach at naming things. No-one wants that.
Whichever way one spins it: there's been a balls-up :-(
Thanks for the follow-up. Perhaps I should've created separate tickets for all that stuff. But yeah, the core of it is if getApplicationMetadata should remain as is, or become applicationGetMetadata. The rest of the stuff I've mentioned (getFunctionList() and the docs) has also been a moving target. Once we get the function name nailed down, then I suppose that would then be the time to create the ticket for that other stuff. Ah well =P
I also hear what you're saying and do recall you prefer action+thing. And no problem w/ that. It's primarily the getApplicationMetadata vs sessionGetMetadata that has me going, so I figured I'd see what others thought.
The other stuff (applicationStop, sessionInvalidate, sessionRotate) is of lesser importance consistency-wise, but just felt (IMO of course) it'd be nicer to have them all grouped (application___() and session___()). Interestingly, the ApplicationGetMetadata AND GetApplicationMetadata docs are both currently online (note how "GetApplicationMetadata" has "PRERELEASE - 02/17/2012" at the very very top - hard to read.. in the black stripe).
Good discussion. We'll see what happens.
Aaron Neff wrote:
Which do people prefer? "GetApplicationMetadata" or "ApplicationGetMetadata"
Just noting, for others, that there are currently 2 more simultaneous discussions on this same topic:
1) This forum thread
2) Ticket #3207841 - https://bugbase.adobe.com/index.cfm?event=bug&id=3207841
3) Ticket #3208541 - https://bugbase.adobe.com/index.cfm?event=bug&id=3208541
The latter ticket contains 3 screenshots indicating confusion and indicating that it is not too late to fix applicationGetMetadata(). If the similarity in those 2 ticket#s wasn't confusing enough =P