3 Replies Latest reply: Jun 17, 2012 11:52 PM by busyspin RSS

    Trouble Upgrading to Adobe Air 3.3.0.3650 from 1.5.3.9130

    busyspin Community Member

      Hi,

       

      I have been unable to upgrade Adobe Air from 1.5.3.9130 to 3.3.0.3650 (the latest).  My OS is Windows XP.  I have pasted some errors from the msi installer log and the air log.  I am not sure what is happening.  Can anyone tell me what is going on?

       

      From MSI Log:

       

      MSI (s) (4C:F0) [21:42:02:656]: SOURCEMGMT: Now checking product {A2BCA9F1-566C-4805-97D1-7FDC93386723}

      MSI (s) (4C:F0) [21:42:02:656]: SOURCEMGMT: Media is enabled for product.

      MSI (s) (4C:F0) [21:42:02:656]: SOURCEMGMT: Attempting to use LastUsedSource from source list.

      MSI (s) (4C:F0) [21:42:02:656]: SOURCEMGMT: Trying source c:\docume~1\lara\locals~1\temp\airbc5.tmp\.

      MSI (s) (4C:F0) [21:42:02:656]: Note: 1: 2203 2: c:\docume~1\lara\locals~1\temp\airbc5.tmp\setup.msi 3: -2147287037

      MSI (s) (4C:F0) [21:42:02:656]: SOURCEMGMT: Source is invalid due to missing/inaccessible package.

      MSI (s) (4C:F0) [21:42:02:656]: Note: 1: 1706 2: -2147483647 3: setup.msi

      MSI (s) (4C:F0) [21:42:02:656]: Note: 1: 1706 2:  3: setup.msi

      MSI (s) (4C:F0) [21:42:02:656]: SOURCEMGMT: Failed to resolve source

      MSI (s) (4C:F0) [21:42:02:656]: Note: 1: 1714 2: Adobe AIR 3: 1612

      MSI (s) (4C:F0) [21:42:02:656]: Note: 1: 2205 2:  3: Error

      MSI (s) (4C:F0) [21:42:02:656]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1714

      MSI (s) (4C:F0) [21:42:02:656]: Note: 1: 2205 2:  3: Error

      MSI (s) (4C:F0) [21:42:02:656]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709

      MSI (s) (4C:F0) [21:42:02:656]: Product: Adobe AIR -- Error 1714. The older version of Adobe AIR cannot be removed.  Contact your technical support group.  System Error 1612.

       

       

      MSI (s) (4C:F0) [21:42:02:656]: Note: 1: 2205 2:  3: Error

      MSI (s) (4C:F0) [21:42:02:656]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 16

      Error 1714. The older version of Adobe AIR cannot be removed.  Contact your technical support group.  System Error 1612.

       

       

      Air Log:

       

      [2012-06-17:21:41:46] Runtime Installer begin with version 3.3.0.3650 on Windows XP x86

      [2012-06-17:21:41:46] Commandline is:

      [2012-06-17:21:41:46] Installed runtime (1.5.3.9130) located at c:\Program Files\Common Files\Adobe AIR

      [2012-06-17:21:41:54] Starting runtime update. Updating runtime from version 1.5.3.9130 to version 3.3.0.3650

      [2012-06-17:21:41:54] Installing msi at c:\docume~1\lara\locals~1\temp\airb41.tmp\setup.msi with guid {65CB4C08-C47B-4A7E-A6A4-50C06ADA5FC6}

      [2012-06-17:21:42:07] Error occurred during msi install operation; beginning rollback: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="1603" errorID=0]

      [2012-06-17:21:42:07] Rolling back install of c:\docume~1\lara\locals~1\temp\airb41.tmp\setup.msi

      [2012-06-17:21:42:07] Rollback complete

      [2012-06-17:21:42:07] Exiting due to error: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="1603" errorID=0]

      [2012-06-17:21:42:09] Runtime Installer end with exit code 7

      [2012-06-17:21:56:28] Runtime Installer begin with version 3.3.0.3650 on Windows XP x86

      [2012-06-17:21:56:28] Commandline is:

      [2012-06-17:21:56:28] Installed runtime (1.5.3.9130) located at c:\Program Files\Common Files\Adobe AIR