19 Replies Latest reply: Jan 2, 2013 2:37 PM by Lady Zylo RSS

    FF12 & Flash 11: Videos don't play

    Lurker-rekruL

      Youtube videos work, as do most Flash games, but videos on sites like Hulu or Comedy Central don't play. I don't even get sound, the video just never starts playing. The ads at the start of the Hulu videos play, but not the videos themselves.

       

      I've tried using a blank profile with no extensions or changes to the config, and I've tried adding the line to the Flash CFG file that disables protected mode. No change.

       

      They play in IE8, but I hate using IE. I want to use Firefox, but this problem is really starting to annoy me!

        • 1. Re: FF12 & Flash 11: Videos don't play
          Lurker-rekruL Community Member

          I have now tried uninstalling Flash 11 completely and reverting to the last availavle version of Flash 10. Hulu still doesn't work. I've used a blank profile, followed all the instructions for cleaning the system of leftover Flash files and nothing works.

           

          Flash works on sites like YouTube, but not on sites like Hulu or Comedy Central.

          • 2. Re: FF12 & Flash 11: Videos don't play
            libflashplayer.so Adobe Employee

            i just saw a post in bugzilla.  would you happen to have the real player installed?  would you mind to disable or uninstall it and restart firefox to see if this resolves your issue?  thanks...

            • 3. Re: FF12 & Flash 11: Videos don't play
              Lurker-rekruL Community Member

              No, I've never installed any version of Real Player on this system. Nor have I installed Real Alternative. I was planning to, but then I discovered that Media Player Classic - Home Cinema can play RM files by itself.

              • 4. Re: FF12 & Flash 11: Videos don't play
                libflashplayer.so Adobe Employee

                could you provide links to the videos you are attempting to play?  are they paid content that use DRM? or possibly content that is blocked by geolocation?

                • 5. Re: FF12 & Flash 11: Videos don't play
                  Zefred

                  don' you get an error message like

                   

                  task queue failed at step 5: playlist could not be loaded http Error #2032  ?

                   

                  http://forums.adobe.com/thread/1021856?tstart=0

                   

                  When I desactivate the module

                  (tools - modules complementaires - select shockwave flash and desactivate)

                  shockwave flash 11.3.300.257 - version 10 Jun

                  everything is fine... for the videos ...

                  unfortunatelly  cannot play or watch any other site that uses Flash

                  • 6. Re: FF12 & Flash 11: Videos don't play
                    Lurker-rekruL Community Member

                    libflashplayer.so wrote:

                     

                    could you provide links to the videos you are attempting to play?  are they paid content that use DRM? or possibly content that is blocked by geolocation?

                     

                    http://www.hulu.com/watch/44956

                    http://www.comedycentral.com/video-clips/bxp4yo/cc-studios-hot-sluts-hot-sluts--ep-1

                     

                    Those are two examples, however you can try any video on Hulu or Comedy Central and they won't play for me. I'm in the US, so geo-restrictions aren't the problem. The same vidoes play using Internet Explorer. The ad at the start of Hulu videos always plays. The intro logo for Comedy Central always plays, but the videos themselves do NOT play.

                     

                    Using Firefox 12, I have tried a couple different versions of Flash 11, Flash 10 (last available version), I have completely uninstalled each one before installing the next. I have tried adding the line to turn protected mode off to the config file. I have uninstalled Shockwave. I have tried them all with a fresh, blank profile in Firefox. Nothing will make the above videos play.

                     

                    Also note that this affects any video on any site that streams the content directly to the player rather than saving it to the browser's cache. So YouTube videos work, Flash games work, Hulu Videos do NOT  work.

                    • 7. Re: FF12 & Flash 11: Videos don't play
                      libflashplayer.so Adobe Employee

                      thanks, i'm going to see if someone on the video qe team can help you directly.  stay tuned...

                      • 8. Re: FF12 & Flash 11: Videos don't play
                        Ryan Morales

                        Hi Lurker,

                         

                        Could you try these steps and see if it helps?

                         

                        1) go to the following directory depending on what OS you are using.

                        Win: C:\Documents and Settings\<username>\Application Data\Adobe\

                        Mac: /Users/<username>/Library/Caches/Adobe/

                        2) delete the Flash Player directory

                        3) clear the browser cache (http://support.mozilla.org/en-US/kb/clear-cache-delete-temporary-files-fix-issues)

                        4) try playing the stream at Hulu or Comedy Central again

                         

                        Thanks,

                        Ryan

                        • 9. Re: FF12 & Flash 11: Videos don't play
                          Lurker-rekruL Community Member

                          Thanks, but someone on the Firefox forum already helped me figure it out.

                           

                          It seems that the Mozilla team added a new feature where plugins run in a 'sandbox' mode so that if they crash, they don't crash the browser. In my case, this was preventing the videos on certain sites, like Hulu and Comedy Central, from working.

                           

                          The solution was to go into "about:config", then change "dom.ipc.plugins.enabled" from "True" to "False".

                           

                          Firefox is supposed to allow you to set this individually for each plugin by adding a new entry with the DLL name, but that didn't work for me.

                           

                          I haven't yet tried updating Flash to the latest version to see if it still works with that setting turned off.

                           

                          It should be noted that this didn't keep all Flash content from being displayed, only videos where the content is streamed directly to the player rather than being saved to the browser's cache. You know, the sites where they're paranoid that someone might save a copy of the video.

                          • 10. Re: FF12 & Flash 11: Videos don't play
                            libflashplayer.so Adobe Employee

                            streaming video should play regardless of the firefox setting, but i'm glad you are able to continue watching videos.  when you do get a chance to upgrade and reset your settings, we would be interested to see if your issue pesists.  thanks again for the update...

                            • 11. Re: FF12 & Flash 11: Videos don't play
                              JEFC32

                              I try that and i still can't see videos or play games on facebook. What can i do?

                              • 12. Re: FF12 & Flash 11: Videos don't play
                                libflashplayer.so Adobe Employee

                                @JEFC32 please start your own thread.  your issue seems unrelated to the original post.  thanks...

                                • 13. Re: FF12 & Flash 11: Videos don't play
                                  Lurker-rekruL Community Member

                                  libflashplayer.so wrote:

                                   

                                  streaming video should play regardless of the firefox setting, but i'm glad you are able to continue watching videos.  when you do get a chance to upgrade and reset your settings, we would be interested to see if your issue pesists.  thanks again for the update...

                                   

                                  I upgraded to the latest Flash version, 11.3.300.257, and the videos still play. That one Firefox setting seems to be the deal-breaker. When it's on, Hulu and Comedy Central videos won't play. With it off, they play fine.

                                   

                                  Now, if I could just find a way to trick Hulu so that I didn't have to temporarily move/delete my Hosts file, which blocks 99% of advertising servers, every time I want to watch something on there.

                                  • 14. Re: FF12 & Flash 11: Videos don't play
                                    kelric6

                                    I too have the same problem, however, about: confi and the rest of what you mentioned goes right over my head.  Would you mind doing a step by step help guide as to what to do to solve the problem?

                                    • 15. Re: FF12 & Flash 11: Videos don't play
                                      Lurker-rekruL Community Member

                                      kelric6 wrote:

                                       

                                      I too have the same problem, however, about: confi and the rest of what you mentioned goes right over my head.  Would you mind doing a step by step help guide as to what to do to solve the problem?

                                       

                                      Sure, although I can't promise that this will fix your problem, all I can say is that it fixed it for me. In any case, you can't hurt anything and it can easily be undone.

                                       

                                      First, type:

                                       

                                      about:config

                                       

                                      Exactly as shown into Firefox's address bar. That's the box at the top where you can directly enter web site addresses. NOT the Google search box. Like this;

                                      Firefox1.png

                                      When you press Enter, Firefox will probably give you a warning. Click the button;

                                      Firefox2.png

                                      You will then see a screen full of various settings. Type the word:

                                       

                                      plugins

                                       

                                      Into the Search box to filter the list and only show those entries with the word "plugins" in them. Then look for the line that says "dom.ipc.plugins.enabled", like this;

                                      Firefox3.png

                                      Double-click on that line with the mouse to change the value from "True" to "False". The line will change to bold print to make that setting stand out from the ones that you haven't changed. Like this;

                                      Firefox4.png

                                      Once you've made the change, try going to a site that gave you problems and see if it works now.

                                       

                                      If you decide that you want to change that setting back, just follow the same directions to toggle it back on. (ecah time you double-click one of the True/False settings, it changes to the other setting)

                                       

                                      Sorry about the small size of the images, the forum only lets you post images that are 450x600 or smaller. Click each one for a slightly larger version.

                                      • 16. Re: FF12 & Flash 11: Videos don't play
                                        kelric6 Community Member

                                        Thani you so much for the help.  I just learned something new today, haha

                                         

                                        The steps helped, but it sadly did not solve the problem I have
                                        I suppose I'll have to do more research and make a new thread for my problem.  However, ty very much for the help!

                                        • 17. Re: FF12 & Flash 11: Videos don't play
                                          Lurker-rekruL Community Member

                                          Sorry it didn't help.

                                           

                                          What version of Firefox and Flash do you have? Also, does Flash work at all? For example, does it work on sites like YouTube? What happens when you try to view a problem video? Does it give you an error, or does the video just not play?

                                           

                                          If you have the NoScript extension for Firefox installed, that can cause major problems in trying to watch videos. If you have it installed, try disabling it by going to Firefox's Tools menu and selecting Add-ons, then clicking on Extensions and finally clicking the Disable button for NoScript. You'll have to restart Firefox for it to take effect. Also if you've ever had NoScript installed, look in about:config for a setting called "noscript.forbidPlugins" and if it's there, try disabling it (double-click it).

                                           

                                          Disabling Javascript also causes problems. Apparently having Real Player installed can also cause problems, if the browser plugin is enabled.

                                           

                                          Hulu will refuse to play videos if it can't show you the ads. This can be caused by extensions like AbBlock, or by using a "Hosts" file in WIndows to block ads. In case you've never heard of a "Hosts" file, it's a text file in Windows that was meant to speed up finding IP addresses for sites. The idea was that you could put commonly used sites in it and include their IP addresses and then Windows wouldn't have to connect to the net to look them up. It can also help in the case that a site is up, but for whatever reason, looking up its IP address on the net is failing. On the downside, once a site is listed in the Hosts file, Windows won't even try to look it up on the net, so if the IP address for a site changes, Windows will still try to use the old one. This can be used to block ads by setting all the advertising sites to the internal IP address of your system, 127.0.0.1, which means that your web browser won't be able to reach any of the servers that the ads are on. This typically kills 99.99% of the annoying ads on the net, like those Flash ads that open on top of pages, or the ones that fade out the entire page you're viewing and replace it with an ad. The disadvantage is that sometimes they add sites to the list that you actually want to visit and you have to manually edit the Hosts file to remove them. Or sites like Hulu complain that the ads are blocked. For those sites, the easiest solution is to temporarily move the Hosts file so that Windows doesn't use it. Thankfully, this only requires restarting the web browser, not Windows. Here's the one that I use;

                                           

                                          http://winhelp2002.mvps.org/hosts.htm

                                           

                                          Using this Will stop Hulu from working though. Unless you specifically edit out the ad sites that Hulu uses (I don't know them off-hand) or you temporarily move/rename the file so that Windows can't find it when you want to use Hulu. It's great at stopping ads though. Anyway, I thought you might be interested to know about this.

                                           

                                          When disabling individual add-ons doesn't work, the next step is usually to try Firefox with a blank profile. Assuming you're using Windows, close Firefox, then go to the Start Menu, select Run and type in;

                                           

                                          Firefox -p

                                           

                                          This will open the Profile Manager. Click the button to create a new profile. You can name it whatever you want. This will create a new user profile with all of Firefox's settings reset to the defaults, but the plugins will still be active. Try to view one of the problem sites. If it works, then some change you've made to Firefox is causing the problem. If not, then the problem runs deeper. To go back to using your normal profile with all your settings, do the same thing again (Firefox -p), but instead of creating a new profile, just select the default one and you'll be back to where you started. (When you switch profiles with the Profile Manager, that profile stays in effect until you change it) You can also create a Start Menu or Desktop shortcut with that command so that you have a convenient way of accessing the Profile Manager when you want to.

                                           

                                          If none of the above helps, maybe one of these links will;

                                           

                                          http://forums.adobe.com/thread/1018071

                                           

                                          http://forums.mozillazine.org/viewtopic.php?f=38&t=2485979

                                          http://forums.mozillazine.org/viewtopic.php?f=38&t=2485553

                                          http://forums.mozillazine.org/viewtopic.php?f=38&t=2485319

                                           

                                          The first Mozilla forum link is the thread that I started there.

                                           

                                          Some people have success by disabling Flash's protected mode (first link, at the bottom). Others got it working by downgrading Flash to an earlier version such as 11.02.xxxx.

                                           

                                          Hopefully, something here will help. I know how frustrating it is to have something not work and nobody can tell you why.

                                          • 18. Re: FF12 & Flash 11: Videos don't play
                                            patronanejo

                                            I have what seems to be a similar problem, except it's intermittent.

                                             

                                            I'm wondering--how exactly did the steps described by Lurker-rekruL help without actually solving the problem?

                                            • 19. Re: FF12 & Flash 11: Videos don't play
                                              Lady Zylo

                                              A couple of things that I have learned doing some of this research on my own is that there are a few different problems with Flash 11.

                                              Removing Real Player and then restarting the computer fixed my problem, but I have also seen antivirus programs block it from being able to play.

                                              If all else fails and you really don't want to use IE (internet explorer) then you can use Chrome, and Chrome doens't seem to have the same problem with hulu and it loads much faster than Internet Explorer. So I would start with the antivirus software blocking hulu videos, then move on to removing real player, and then if those don't work and you don't want to continue to stress over it, Google Chrome seems to be working fine with hulu.

                                              I hope this helps someone out there.

                                              good luck with it,

                                              ladyzylo