9 Replies Latest reply: Jul 12, 2012 4:46 PM by the swedish advisor RSS

    Upgrading from LR4 to 4.1

    the swedish advisor

      I'm trying to download the new Lightroom 4.1 update, but get the message in Chrome on a PC "Insufficient Permission"  I have installed legal copy and am using Lightroom 4.0 so what does this mean, why won't the new update install?  Thanks

        • 1. Re: Upgrading from LR4 to 4.1
          Mylenium MVP

          You are not telling us anything about your computer. This has nothing to do with LR, this is a generic system problem. Either you have no write permissions to the folder you are trying to download to or are generalyl running with insufficient user privileges.

           

          Mylenium

          • 2. Re: Upgrading from LR4 to 4.1
            the swedish advisor Community Member

            Sorry, my bad...I'm running Vista Home Premium as ADMIN, and have successfully upgraded LR 3 on many occassions in the past, so nothing has changed at this end.  I've never seen the report, "Insufficient Permission," before on this system, so that's why I could only think it has something to do with Adobe's download.   When does it check to see if LR 4.0 is installed for the upgrade path?  I mean, I've never seen this problem before on any computer I've used, and I've succesfully downloaded updates for LR from Adobe in the past.  So I'm wondering, where does one fix Permission issues in Vista, or is there something I can check or uncheck regarding this download?   It seems to me that LR doesn't see my current installation of LR4 so it won't proceed.    Thanks

            • 3. Re: Upgrading from LR4 to 4.1
              Mylenium MVP

              Have you tunred off your security tools and UAC? If the updater doesn't even "see" your current install, then something is blocking the caps.db and/or the pertinent Registry entrries, because that's what it goes looking for. If it's not a security tool, you may indeed have a permission problem eitehr on the relevant files or the registry. Anyway, you can only find that out the hard way using tools like Sysinternals System Monitor. The otehr, probably simpler way would be to uninstall and then reinstall....

               

              Mylenium

              • 4. Re: Upgrading from LR4 to 4.1
                the swedish advisor Community Member

                Thanks for this help...one more question, do you mean I should uninstall and then reinstall LightRoom 4, which I have on a disc?  Dean

                • 5. Re: Upgrading from LR4 to 4.1
                  the swedish advisor Community Member

                  Mylenium,

                  I am not much of a techie when it concerns Registry issues.  No where does Adobe ask me to turn off security tools and "UAC" (I have no idea what UAC means).  

                   

                  As soon as Chrome's Download Manager finishes downloading LR 4.1, it shows the error message "Insufficient Permissions.  Try saving to a different folder"  which I've tried four times to four different folders...and LR 4.1 downloads 730 MB of data, which must be the entire program.   In each attempt to download, the new file is named "Unconfirmed *****(five different digits) crdownload" and won't open. 

                   

                  I uninstalled and reinstalled LR4.0, to no avail.  I've never needed permissions in the past on this computer to download updates to all LR past versions.  Why do you think I'm having to download the entire LR version just to get the update 4.1?  Everything says / shows that I have administrator priveleges in the OS Windows Explorer point of view.

                   

                  Any help here would be appreciated---or should I try using online Chat next?

                  • 6. Re: Upgrading from LR4 to 4.1
                    the swedish advisor Community Member

                    Mylenium,  I've posted a response to your reply, but haven't heard back from you regarding my question.  Are you finished with me?  Please advise.

                    • 7. Re: Upgrading from LR4 to 4.1
                      Jeff A Wright Adobe Employee

                      UAC stands for User Account Control settings.  You can adjust this under the User Account setting in your Control Panels.  As for the insufficient permissions do you receive this when you double click on the downloaded exe or when trying to download the install files themselves?

                       

                      I might recommend creating a new adminstrator account to see if you still receiving the Insufficient privelages under that account.  You can create the new adminsitrator account in the User Account control panel as well.

                      • 8. Re: Upgrading from LR4 to 4.1
                        LittleJohnT

                        I am not the original poster, but I started having this problem in Vista as well. It affects me whether I am trying to download the file, or even if I download it and move it over to that machine. It seems to be related to an update or something. Recently I was able to download a bunch of stuff OK.

                         

                        I just got this machine setup form scratch, downloaded and installed some things to test with fine. I don't normally use Vista, so I tried to download the LR4 trial to install and test and see how it worked. I can copy it over fine, but it can't unzip files, and I cannot download a copy from the internet using IE or chrome.

                         

                        John

                        • 9. Re: Upgrading from LR4 to 4.1
                          the swedish advisor Community Member

                          I tried for the 5th time to download and install LR4.1 and on 7/11/12 it installed without any issues, so Thanks for all the help