9 Replies Latest reply on Jul 6, 2012 9:56 AM by TOP FOTO

    Sony m2ts files had sound but now they don't


      I was working for a long time on a PC with Pinnacle Studio 14.   This worked fine with m2ts files from my Sony HDR-SR8 although the output always disappointed me, it seemed soft or it seemed to have lines in it depending on what settings I tried.   I wanted to advance my video editing skills, knowledge and ability so I went with Avid Studio.  This would not work properly on my PC and was left to rot on the hard drive.  So I decided to get through the learning hump and go for Premiere (and later the intention of learning After Effects too).  

      Premiere Pro CS6 trial worked with the very same m2ts files that I used in Pinnacle.   I made a few simple home movie projects and mostly I was thrilled with the perfect output quality that encouraged me to go on using it.  At some point I decided to get rid of the other software that I was no longer using to free up hard disk space.  I removed Pinnacle Studio 14 and Avid Studio and another few unrelated bits of software that I considered unused and redundant.   Now Premiere won’t play the sound from the m2ts files.  The same ones that I used before in Premiere won’t play sound now.  The only real clue I have is opening an old project that I was working on.  I get this error message:
      “This project contained a sequence that could not be opened.  No sequence preview preset file or codec could be associated with this sequence type.”
      Thinking that some codecs were removed I re-installed Pinnacle and Avid.  No luck.  Thinking that they were installed first ahead of Premiere I removed everything, reinstalled pinnacle, then avid, then premiere.  No luck.  I’ve tried loads of combinations.  I downloaded and installed CCCP codecs again.  I installed the Premiere update 6.0.1.  No luck.  I've removed all Adobe products, run the Adobe cleaning tool, did restarts etc etc etc.


      So the facts is Premiere did work properly on this pc.  So whatever is wrong is something small like a codec missing or a missing registry entry.



        • 1. Re: Sony m2ts files had sound but now they don't
          Harm Millaard Level 7

          That seems like a logical conclusion. The question remains however, which codec is missing? What does MediaInfo tell you about the codec in use?

          • 2. Re: Sony m2ts files had sound but now they don't
            TOP FOTO Level 1

            Hi Harm.  Feeling like a total noob here.  I downloaded MediaInfo from the web just now, I hope that's what you meant since I'm entering a new anorak world here   Here's the read from it:




            ID                                       : 0 (0x0)

            Complete name                            : S:\Video Cam Files\04-07-2012(2)\20120701111507.m2ts

            Format                                   : BDAV

            Format/Info                              : Blu-ray Video

            File size                                : 9.94 MiB

            Duration                                 : 5s 130ms

            Overall bit rate mode                    : Variable

            Overall bit rate                         : 16.2 Mbps

            Maximum Overall bit rate                 : 18.0 Mbps



            ID                                       : 4113 (0x1011)

            Menu ID                                  : 1 (0x1)

            Format                                   : AVC

            Format/Info                              : Advanced Video Codec

            Format profile                           : Main@L4.0

            Format settings, CABAC                   : Yes

            Format settings, ReFrames                : 2 frames

            Format settings, GOP                     : M=2, N=13

            Codec ID                                 : 27

            Duration                                 : 5s 120ms

            Bit rate mode                            : Variable

            Bit rate                                 : 15.1 Mbps

            Maximum bit rate                         : 16.0 Mbps

            Width                                    : 1 440 pixels

            Height                                   : 1 080 pixels

            Display aspect ratio                     : 16:9

            Frame rate                               : 25.000 fps

            Color space                              : YUV

            Chroma subsampling                       : 4:2:0

            Bit depth                                : 8 bits

            Scan type                                : Interlaced

            Scan order                               : Top Field First

            Bits/(Pixel*Frame)                       : 0.389

            Stream size                              : 9.23 MiB (93%)



            ID                                       : 4352 (0x1100)

            Menu ID                                  : 1 (0x1)

            Format                                   : AC-3

            Format/Info                              : Audio Coding 3

            Mode extension                           : CM (complete main)

            Format settings, Endianness              : Big

            Codec ID                                 : 129

            Duration                                 : 5s 216ms

            Bit rate mode                            : Constant

            Bit rate                                 : 448 Kbps

            Channel(s)                               : 6 channels

            Channel positions                        : Front: L C R, Side: L R, LFE

            Sampling rate                            : 48.0 KHz

            Bit depth                                : 16 bits

            Compression mode                         : Lossy

            Delay relative to video                  : -80ms

            Stream size                              : 285 KiB (3%)

            • 3. Re: Sony m2ts files had sound but now they don't
              Harm Millaard Level 7

              Well, the source material was HDV, but the material you are using was encoded to BRD format, using 5.1 audio and it not suitable for editing. I would try to get the original footage from the copyright owner.

              • 4. Re: Sony m2ts files had sound but now they don't
                TOP FOTO Level 1

                It is the original footage from my Sony HDR-SR8 camera.  And the (not so) funny thing is that I have all of the Sony software installed to!.  I guess that media info app is misleading. :/


                http://esupport.sony.com/US/perl/model-home.pl?mdl=HDRSR8&LOC=3&session_id=756b556d028a8c7 903635c697aa2fec6#/howtoTab

                • 5. Re: Sony m2ts files had sound but now they don't
                  Jeff Bellune Level 6

                  MediaInfo is accurate -- the source footage from the camera is AVCHD that looks like it's in a M2TS wrapper.  The camera records to an internal HDD, so maybe Sony decided on the BD file format because of that.


                  Check Premiere Pro's preferences for your audio channel mapping settings, check to see that your sequence has at least one 5.1 audio track, and also check Windows audio settings that your sound card is set to downmix multichannel audio to stereo audio (unless you have a 5.1 speaker set up).



                  • 6. Re: Sony m2ts files had sound but now they don't
                    Jim_Simon Level 9

                    I had a similar situation occur recently.  What fixed it for me was two things.  I had to reactivate Premiere Pro, and I had to clear the cache entirely.  The first allowed the codecs to 'reregister", and the second forced PP to create the cache files.

                    • 7. Re: Sony m2ts files had sound but now they don't
                      TOP FOTO Level 1

                      Ok Jim. 
                      I re-installed AVS4YOU since that was on the list of what I removed.   I'm going to clean the cache again (sigh).   Un-install it again (sigh).   But I'm doubtful since I've done all of that I rekkon a few times by now :/

                      • 8. Re: Sony m2ts files had sound but now they don't
                        Jim_Simon Level 9

                        Un-install it again (sigh).


                        You don't necessarily have to uninstall.  (I didn't.)  Just deactivate, shut down PP, reboot, restart PP and reactivate.

                        • 9. Re: Sony m2ts files had sound but now they don't
                          TOP FOTO Level 1

                          Hi Jeff.

                          I messed about with Premiere's audio settings, including adding a 5.1 channel.  Normally when I add a clip it would ask to update the sequence to the new settings and it was all done automagically.  I stuck with this process because I was only using one type of file anyway.

                          Remember the same files play just fine in other applications, windows media player, pinnacle studio 14 HD, Avid Studio (works now) and Sony's Vegas, so messing about with the Windows settings doesn't really add up.   Also previoulsy when it worked, when I dragged a clip into the Sequence area there would be a Video and Audio pair, now it'd just video.   Also in the Clip view window only the Video icon is enabled, the audio icon is disabled.  So premiere just doesn't ackowledge there is sound there.