1 26 27 28 29 30 Previous Next 1,716 Replies Latest reply: Dec 18, 2012 11:37 AM by Victoria_Bampton Go to original post RSS
      • 1,080. Re: Lightroom 4 is slow
        BeerStalker Community Member

        davepinminn wrote:

          I have a completely separate spindle for the O/S and programs (Seagate 7200 rpm).  A separate spindle for the catalog and several other partitions not related to image processing (Hitachi 7200 rpm).  A separate spindle for images (a 1TB HItachi 7200 rpm that has about 350GB available).  And, TWO spindles for scratch files (each a Hitachi 7200 rpm with at least 50% available - these are internal backup drives, so they're just sitting there except when backing up).

         

        From a I/O perspective LR no longer uses the ACR cache extensively. In develop it's reading the RAW file directly each time and that may make things a bit slower than before (but the read blocksize is quite large so a SSD isn't necessarily the answer). Also SQLite is a prodigious user of TEMP space so if your going to put in a SSD place catalog + previews + TEMP on it.

         

        From what I see on my system the slowness seems to be more of a CPU than I/O issue. Users with the problems seem to have decent spec systems (Core i7 most commonly) so it could be the new 2012 process some locking/threading issues.

        • 1,081. Re: Lightroom 4 is slow
          ButterFingers Community Member

          For my data-point.

          I am running a modest system compared to many described here:

          dualcore 2.6GHz, 16gb Ram. OS one one disk, images and Cat on another.

          This was all fine on LR 3.x and 4.0.

          Most importantly, the user interface experience was consistent - there were no major swings in response time.

          Latest version of LR, on a completely rebuilt system (fresh OS) shows a significantly more inconsistent experience.

           

          My biggest issue is when I stack up even a small number of correction activities ( up to 5) - e.g. brush, grad density, spot, the overall responsivness takes a major dive. The cursor is sluggish, sliders start to behave as if they are on an elastic band etc.

          I am not seeing spikes in disk or memory activity, but spikes in CPU every time I 'touch' the image after a couple of say, spot corrections.

           

          I could speculate on the cause (like many in this forum, I've been in IT for a long time), but I'll rely on Adobe knowing it's stuff and hopefully another data-point might help.

          I hope that Adobe has not gotten itself into a fix with an overly complex image processing pipeline and UI/rendering threading issues .. damn! I said I wouln't speculate!

           

          Hans

          • 1,082. Re: Lightroom 4 is slow
            bob frost Community Member

            From: "1234ewqrd

            My biggest issue is when I stack up even a small number of correction

            activities ( up to 5) - e.g. brush, grad density, spot, the overall

            responsivness takes a major dive. The cursor is sluggish, sliders start to

            behave as if they are on an elastic band etc.

             

            Did you see the post recently where someone with the same sort of problems

            solved it completely by updating his Wacom driver? You don't use a Wacom by

            any chance?

             

            Bob Frost

            • 1,083. Re: Lightroom 4 is slow
              ButterFingers Community Member

              thanks for the respose Bob.

              I had actually experienced the problem before I had the tablet (wacom bamboo).

              I installed the tablet and ensured I had the latest drivers and alas, no change.

              To me, the slowdown starts when I have added some edits.

              hans

              • 1,084. Re: Lightroom 4 is slow
                Keith_Reeder Community Member
                I have over 20 years of application, operating system and storage system support and engineering experience for some of the biggest names in the industry I can assure you all this "I'm not seeing it so it's your system at fault" talk is very wide of the mark.

                 

                 

                We can all swap stories about our experience in IT - it sometimes seems that there are more current and ex IT professionals on here than there are "just" photographers (yep, me too) and I'm afraid that we're going to have to agree to differ about your "assurance".

                 

                A simple counter to your argument is why only LR sees the problem. I have many other apps and the all work well except LR.

                 

                The simple answer to this is that Lr is widely acknowledged to be software that really stresses hardware, and it shows up bottlenecks in software/OS configurations too.

                 

                And they're local issues all...

                • 1,085. Re: Lightroom 4 is slow
                  DavePinMinn Community Member

                  Keith, I suspect you're right about IT people in here...  I THINK it's because digital photography has such an appeal to our geek nature!  I too have many years as a software engineer, database designer, and so on.  My wife has always said that digital photography came along at the perfect time for me.  It allows me to combine my love of computers and computing with my enjoyment of capturing moments...

                   

                  UNFORTUNATELY, for those of us who do or did make our careers designing and building mission-critical systems, I suspect it also makes us far less tolerant of software that degrades from version to version.  Yes, we sometimes made mistakes and put out softwarse the crashed and burned spectacularly, but I can also remember the company I worked for recalling software and TELLING clients NOT to upgrade because of some problem that had been discovered.  And communicating to them that we were DEFINITELY and ABSOLUTELY working our collective fannies off to find and correct the problems.  I think the communication part was what clients appreciated most.

                   

                  BUT, anyhow, back to the problem at hand...  In the middle of the night, I woke up with a thought (yes, I know, I desperately need to get a life)...  When I was testing yesterday, it APPEARED TO ME that the .dng files responded more slowly (slightly) than did the same files in .nef format.  But, that doesn't make sense.  The .dng files are smaller, there's no sidecar file to fiddle with, and the .dng is a proprietary (public) format created by Adobe rather than some reverse engineered thing...  Shouldn't they have been significantly FASTER to process/display than the .nef files?  What am I missing?

                  • 1,086. Re: Lightroom 4 is slow
                    fliplip1 Community Member

                    One of the things i tried when i had my old system was to convert a batch of Canon raw files to DNG. Other than the extra time it took (not long really) it made no difference to LR's speed.

                    I really dont think the file, or file size has any bering on this problem.

                    • 1,087. Re: Lightroom 4 is slow
                      bob frost Community Member

                      From: "fliplip1

                      I really dont think the file, or file size has any bering on this problem.

                       

                      Depends which bit of the 'LR is slow' problem you are talking about!! A 10MB

                      nef takes about 1 sec to render on my PC, a 20MB takes 2 secs, and a 40MB

                      takes 4 secs. Directly proportional to file size, but of course you a

                      probably right when talking about slowness in develop steps, sliders, etc.

                       

                      Bob Frost

                      • 1,088. Re: Lightroom 4 is slow
                        fliplip1 Community Member

                        Yeah, im talking about overall slowness rather than rendering or anything that is obviously going to tax the CPU.

                        Even opening a new catalogue would give me not responding errors while it did its thing.

                        • 1,089. Re: Lightroom 4 is slow
                          Another Photographer Community Member

                          Did anyone notice that

                           

                          scrolling with the mouse in the library gives a very different user experience than scrolling with the arrow keys?  One is unbearable no matter how fast the system.  Guess which one.

                           

                          (ii) switching from Library to Develop mode (the modality of it all) takes a long time even if the photo has been loaded into memory several times on a 32GB system?

                           

                          (iii) upgrading from circa 2008 quadcore with 8GB and 1 hard drive to latest i7 with 32GB, SSD and HDD makes every other program faster, but various aspects of Lightroom are still slow?  (see above)

                           

                          (iv) we keep getting advice to export the catalogue before importing (even though that results in some data fields being lost) and deleting preferences and presets.  We're just photographers not software engineers.  Shouldn't the advice be directed to the Lightroom engineers to kindly fix their, shall we say "outdated' database system so that it's as robust as can be?  They've had 4 shots at it, people, and it's stil a$$-backward.

                          • 1,091. Re: Lightroom 4 is slow
                            Victoria_Bampton CommunityMVP

                            I've got one new addition to the list of suspects.  Color Noise Reduction slider set to 25 is faster to free up the sliders than any other setting, including 0.

                            • 1,092. Re: Lightroom 4 is slow
                              SistersCountry Community Member

                              Well I'll be... From what I see so far it makes a significant difference on my machine. The folder I am working on and tested your suggestion with has lens corrections and CA corrections across the board too. (i7 16G Win64).

                               

                              Thanks!

                              • 1,093. Re: Lightroom 4 is slow
                                rpavich1234 Community Member

                                Sadly not on my machine but I'm glad it's helping others.

                                • 1,094. Re: Lightroom 4 is slow
                                  Ashvin Ghisyawan Community Member

                                  I discoverd that lr is a lot faster, working on library mode in stead of develop mode. Also faster when I import the pictures without a preset.

                                  kr,
                                  Ashvin

                                  www.totaalfotografie.nl

                                  • 1,095. Re: Lightroom 4 is slow
                                    DavePinMinn Community Member

                                    Unfortunately, Color noise reduction slider has always been at the default, which appears to be 25, on my systems.  If this is "significantly faster" I shudder to think what it must be like when it's NOT in this "significantly faster" setting. 

                                     

                                    As time goes on, and I actually try to WORK on things on LR4.1, the appalling slowness becomes more and more apparent in many areas.  Yes, working in develop is just plain SLOW, no matter how many images you load or how many times you load them.  The library module is MARGINALLY faster, but it's sure no speed demon.  Cetainly significantly slower than V3...

                                     

                                    And, it appears that ANOTHER month has gone by, and STILL no information from Adobe that they're AWARE there's a problem, WHAT they're doing, and/or WHEN we're likely to see a version that makes significant improvements.  800 pound gorilla syndrome?

                                    • 1,096. Re: Lightroom 4 is slow
                                      bcw99 Community Member

                                      I have just been using LR4.1 and happened to be printingfrom my Firefox browser as well. It locked up LR for several seconds. I mention this as it might be a clue as to what is going on. Memory leak maybe, with the printer driver over-writing some memory address LR was trying to use? The developers need all the info they can get I'd guess.

                                       

                                      Intel i5, 16Gb RAM, Win 7 64 on one SSD, another SSD for cache/catalog, Images on SATA mechanical.

                                      • 1,097. Re: Lightroom 4 is slow
                                        Sacha_ Community Member

                                        After weeks of absolutely nasty performance with LR4.1 I today tried the trick someone posted here a while ago. I started LR via a batch file:

                                         

                                        start "lightroom" /high /affinity 15 "c:\Program Files\Adobe\Adobe Photoshop Lightroom 4.1\lightroom.exe"

                                         

                                        And to my surprise it WAAAAAAAY faster! I know that developing multithreaded apps is quite demanding but what Adobe's dev delivered until now is just CRAP!

                                         

                                        My machine: i7-3930 hexacore, up-to-date chipset X79 and two fast SSDs and 16 GB RAM - more than fast enough you would think...

                                        • 1,098. Re: Lightroom 4 is slow
                                          RikkFlohr Community Member

                                          Sacha_ wrote:

                                           

                                          After weeks of absolutely nasty performance with LR4.1 I today tried the trick someone posted here a while ago. I started LR via a batch file:

                                           

                                          start "lightroom" /high /affinity 15 "c:\Program Files\Adobe\Adobe Photoshop Lightroom 4.1\lightroom.exe"

                                           

                                          And to my surprise it WAAAAAAAY faster! I know that developing multithreaded apps is quite demanding but what Adobe's dev delivered until now is just CRAP!

                                           

                                          My machine: i7-3930 hexacore, up-to-date chipset X79 and two fast SSDs and 16 GB RAM - more than fast enough you would think...

                                          Did you try setting affinity and priority for the LR application through the Task Manager first? I am just curious about that verses via a batch file?

                                          • 1,099. Re: Lightroom 4 is slow
                                            SavagePhoto Community Member

                                            It is the same resutls just the bat is easier since its a one click launch.

                                            • 1,100. Re: Lightroom 4 is slow
                                              RikkFlohr Community Member

                                              Thanks SavagePhoto. That was the piece I was looking for.

                                              • 1,101. Re: Lightroom 4 is slow
                                                Jonz Community Member

                                                You go tmy attention.  LR has been giving me fits!  I am reloading it daily and Adobe support has no clue what they are doing.  I was thinking I needed to completely remove LR and start over but would like to give this solution a try.

                                                 

                                                Could you explain how to create a batch from your code.

                                                 

                                                I tried pasting it into the apple script editor but it wont run.

                                                 

                                                Thanks for the adivce!

                                                 

                                                Troy

                                                • 1,102. Re: Lightroom 4 is slow
                                                  SavagePhoto Community Member

                                                  I wish I could help but I have no idea how to do this on a mac.

                                                  • 1,103. Re: Lightroom 4 is slow
                                                    areohbee Community Member

                                                    Sacha_'s script is Windows-only.

                                                     

                                                    Note: I start Lightroom at below-normal priority, so multiple simultaneous exports don't influence video watching etc, and it does not affect Lr performance.

                                                     

                                                    I recommend checking whether it's the priority or the affinity that is helping the most.

                                                     

                                                    If it's the former, then perhaps some other app or service is competing for CPU, if it's the latter, then you've been bit by a bug  that's keeping Lr from using all cores as it should - dunno what the origin of such a bug would be...

                                                     

                                                    Rob

                                                    • 1,104. Re: Lightroom 4 is slow
                                                      Jonz Community Member

                                                      Thanks for the reply.  I see in your signature now.  LOL  At least I now know its not a platform specific problem

                                                      • 1,105. Re: Lightroom 4 is slow
                                                        SavagePhoto Community Member

                                                        When I was developing/troubleshooting this bat I found that the affinity was most important. On my system I have 4 acutal cores and 4 hyperthread. If I use ANY hyperthread performance dies. If I use all 4 main cores performance slows. By setting it to use only 3 main core and then setting the priority to high windows does a nice job of leaving LR alone and running most everything else on the remaining main and Hyper cores. My results were undenyable that LR has issues with hyperthreading at least on my intel chip and asus motherboard.

                                                        • 1,106. Re: Lightroom 4 is slow
                                                          BigCPixelbender Community Member

                                                          Up to 74 pages on just this thread, and no real solutions from Adobe.  My biggest issue is the lag switching between modules after first starting LR4.1.  Specifically, it takes upwards of 25 seconds for the Book module to load the first time (this, on a 2010 MBP with a 7500 rpm drive and 8gigs of RAM). 

                                                           

                                                          When Mountain Lion comes out next week, LR4.1 will most likely be replace by Aperture.

                                                          • 1,107. Re: Lightroom 4 is slow
                                                            Bob_Peters Community Member

                                                            SavagePhoto wrote:

                                                             

                                                            When I was developing/troubleshooting this bat I found that the affinity was most important. On my system I have 4 acutal cores and 4 hyperthread. If I use ANY hyperthread performance dies. If I use all 4 main cores performance slows. By setting it to use only 3 main core and then setting the priority to high windows does a nice job of leaving LR alone and running most everything else on the remaining main and Hyper cores. My results were undenyable that LR has issues with hyperthreading at least on my intel chip and asus motherboard.

                                                             

                                                            I hope you have forwarded this information to the Lightroom team.  I'm on a MacBook Pro and haven't yet found the tools to disable specific cores or hyper-threading.

                                                            • 1,108. Re: Lightroom 4 is slow
                                                              SavagePhoto Community Member

                                                              Agree!!!!!

                                                               

                                                              Only think that KILLS me is that there is only one tool keeping me in LR over Capture One and that is the brush masking.... There are many other ways to do use this but I use this A LOT and no other process seems as seamless. Unfortunatly on PC there isnt another Raw app that does this as well. However the final results are better with the free Raw Therapy and Capture One.

                                                              • 1,109. Re: Lightroom 4 is slow
                                                                areohbee Community Member

                                                                SavagePhoto wrote:

                                                                 

                                                                My results were undenyable that LR has issues with hyperthreading at least on my intel chip and asus motherboard.

                                                                I hear ya. My ASUS+AMD board has no such problems (M4A89GTD): all cores shoot through the roof when doing something that warrants multiple cores. - mostly speedy too (some things are slow due to Lr s/w design...).

                                                                 

                                                                I've never heard of any other problems with AMD chips, but maybe that's because so few people seem to be running them.

                                                                 

                                                                My Advice: Get an AMD chip!!!

                                                                 

                                                                Rob

                                                                • 1,110. Re: Lightroom 4 is slow
                                                                  areohbee Community Member

                                                                  SavagePhoto wrote:

                                                                   

                                                                  ...there is only one tool keeping me in LR over Capture One and that is the brush masking....

                                                                  I rarely use the brush masking. The one thing that keeps me using Lr over C1 is the quality of results (ok 2 things: I depend heavily on Lr plugins).

                                                                  • 1,111. Re: Lightroom 4 is slow
                                                                    areohbee Community Member

                                                                    BigCPixelbender wrote:

                                                                     

                                                                    My biggest issue is the lag switching between modules after first starting LR4.1.

                                                                    Really? Lr only loads modules upon first use - it's a design thing. But 25 seconds sounds abnormally long. (I just checked, Book module takes several seconds to load (first time only), but not anywhere near 25). Anybody have any idea why it's taking "BigC"'s system so long to load Book module? - disk is healthy?

                                                                     

                                                                    Rob

                                                                    • 1,112. Re: Lightroom 4 is slow
                                                                      Another Photographer Community Member

                                                                      Rob Cole wrote:

                                                                       

                                                                      BigCPixelbender wrote:

                                                                       

                                                                      My biggest issue is the lag switching between modules after first starting LR4.1.

                                                                      Really? Lr only loads modules upon first use - it's a design thing. But 25 seconds sounds abnormally long. (I just checked, Book module takes several seconds to load (first time only), but not anywhere near 25). Anybody have any idea why it's taking "BigC"'s system so long to load Book module? - disk is healthy?

                                                                       

                                                                      Rob

                                                                       

                                                                      I know exactly why it's taking so long.  Comptetition.  There isn't any.  LR needs to have more comptetition. 

                                                                      • 1,113. Re: Lightroom 4 is slow
                                                                        BigCPixelbender Community Member

                                                                        The disk is fine.  It's a 500gig 7400rpm HD with about 20% of the space used.  2010 MBP with Intel i5 2.3GHz, 8gigs of RAM.  There's no real reason for the length of time it takes for the modules to load.  And yes, I've even tried doing a clean install of Lion.

                                                                        • 1,114. Re: Lightroom 4 is slow
                                                                          RikkFlohr Community Member

                                                                          I responded in his other thread. It is disk load time to bring the templates into memory from disk.

                                                                          • 1,115. Re: Lightroom 4 is slow
                                                                            areohbee Community Member

                                                                            I know you're miffed. But, seriously: why 25 seconds to load the Book module - that sounds abnormal to me.

                                                                             

                                                                            I mean, if Lr were performing abnormally for me, I'd be miffed too. - it's one thing to be disappointed with a normally functioning Lr, and another entirely if your perception of Lr is being influenced by abnormal performance issues.

                                                                             

                                                                            Believe me, I have my gripes too, but Lr is mostly fast in develop mode, once loaded, and mostly fast in library mode, once previews are available. So I am mostly happy with Lr performance. I have my complaints, but it's *far* from "unusable" or "molasses in winter"...

                                                                             

                                                                            Rob

                                                                            • 1,116. Re: Lightroom 4 is slow
                                                                              areohbee Community Member

                                                                              Rikk Flohr wrote:

                                                                               

                                                                              It is disk load time to bring the templates into memory from disk.

                                                                              Does 25 seconds for first load not sound abnormal to you?

                                                                               

                                                                              I can load gigabytes in 25 seconds.

                                                                              • 1,117. Re: Lightroom 4 is slow
                                                                                areohbee Community Member

                                                                                BigCPixelbender wrote:

                                                                                 

                                                                                There's no real reason for the length of time it takes for the modules to load.

                                                                                I wouldn't be so sure. I mean, it sounds like you're on the "Lr4 is pure yuck" track, but you may be seeing it through yuck colored glasses...

                                                                                 

                                                                                Book module took about 8 seconds to load (the very first time ever). But now after Lr restart it comes up in about 1 second, first time (subsequent times are instantaneous).

                                                                                • 1,118. Re: Lightroom 4 is slow
                                                                                  RikkFlohr Community Member

                                                                                  Just measuring bit-throughput, it is slow. But how many templates have to be loaded (many files take longer than one file) and what has to be done with them?  It is 300 mb of data read from disk in descrete chunks.

                                                                                   

                                                                                  In the other thread I reported 8 seconds for the first load of Book. 

                                                                                  After killing Lightroom and letting memory relax, Book takes 2 seconds to load on a subsequent load of LR

                                                                                  in the same session going to develop and back to book takes less than a second.

                                                                                   

                                                                                  8 Seconds VS 25  on similar RPM disks (yet different data buses) is a breeze. I would be cheesed at 25 seconds but I don't notice 8.

                                                                                  • 1,119. Re: Lightroom 4 is slow
                                                                                    seanmcfoto CommunityMVP

                                                                                    First time with Book on an old (2.5 Ghz Core 2 Duo) MBP took over 25 secs to load, but subsequent loads are 2-3 secs. Now I have run Book on this catalog before-it lives on a FW800 external, but not this machine. 25 secs everytime would be painful.

                                                                                    1 26 27 28 29 30 Previous Next