2 Replies Latest reply: Jul 8, 2012 9:11 AM by MrEMan2 RSS

    Error publishing LR 4.1 photos to Facebook

    MrEMan2

      I'm getting the following error message:

       

      Photo upload failed. Returned error from Facebook: (#240) Requires a valid user is specified (either via the session or via the API parameter for specifying the user.

       

      I'm currently using LR 4.1 on a Mac running OS X 10.7.4, and have published many albums to both my personal page and to another page I "own".  For the latter, I typically create the album in fb first, then publish my photos to that album.  I've made no changes to my LR settings, and have checked the LR settings in fb for things such as "posts on your behalf", etc. and nothing seems to be out of the ordinary.  The plugin indicates that I'm authorized to publish and I have tried publishing these albums several times over the last week without success.

       

      Any suggestions?

       

      Thanks,

      Emory

        • 1. Re: Error publishing LR 4.1 photos to Facebook
          gervank

          Hi

           

          I too have just started receiving the same error.  I have reauthorised the account, and also removed the app from my facebook settings to start a fresh auithentication, but this still fails. I have even reinstalled Lightroom, to no avail.  HELP!

           

           

          P.S.  I too am a Mac LR 4.1 user

           

          Thanks

          Gervan

           

           

          **UPDATE**

           

          Problems solved!  This was sourced from a comment on the interweb

           

          "Debug:1169: Error reply from Facebook: (#240) Requires a valid user is specified (either via the session or via the API parameter for specifying the user.

          I found out the fix.

          Access your facebook fanpage when you are logged into your personal account. There is a new “voice” section and make sure “You are posting, commenting, and liking as the fanpage” not as your main profile. This will stop the error #240.

          Hope that helps"

           

          Message was edited by: gervank

          • 2. Re: Error publishing LR 4.1 photos to Facebook
            MrEMan2 Community Member

            Odd as it may seem, that did the trick.  But I did have to the "voice" selection switch back and forth for the second album (although that might have something to do with both collections having already defined in LR). 

             

            Thanks for the help!

            ]Emory