5 Replies Latest reply: Jul 12, 2012 12:40 PM by TeuvoLee Finland RSS

    News Feed from upstate icon

    TeuvoLee Finland

      Following the instructions on

      http://help.adobe.com/en_US/digitalpubsuite/using/WS67cb9e293e2f1f60c5dd08612e5ea7d27f-7ff f.html#WS9293e1fb3b977c5c-7484875d12f13314751-800

       

      Followed the instructions for creating a feed. Created a simple web page to test. has a single link in the HTML on the page. Zipped it. One HTML. No CSS. No images.

       

      "Icon HTML Resources ZIP

      Specify a .zip file containing the assets to be used for the web view that appears when users tap the toolbar button. The .zip file should include a single HTML file and any required image and CSS files. The .zip file should not contain subfolders; all content should be on the same level."

      The file compiles fine an loads to my desktop.


      ThenI am using x-code Organizer to test the  app on an iPad and it will not load.  It gives me the following error.

      "The file ‘file://localhost/Users/xxxxxxxxx/Desktop/developer-viewer.ipa’ is not a valid archive. (Could not locate file within archive)"

      This problem goes away if I eliminate the icon the HTML file / Zip file is associated with and the app works fine (without my link to the website). 

      What am I doing wrong?

      Thanks
        • 1. Re: News Feed from upstate icon
          mobly Community Member

          Why are you testing this with X-code Organiser?

          If you have built a custom viewer app, just drop it into itunes and load it into the iPad.

           

          ...I dont suppose I have understood what you are trying to do, but it's not that clear what you are trying to do.

           

          Cheers

          Alistair

          • 2. Re: News Feed from upstate icon
            TeuvoLee Finland

            Hi Alistair,

             

            Just trying to put the viewer on an iPad.

             

            I used organizer just because I have lots of iPads to deal with and am used to it. I was simply dragging and dropping on to the correct iPad when the failure happens. Won't install on my iPad with the extra button. It installs fine if the zip file with HTML code is not there(no extra button) so I am assuming it has something to do with that.  I have tried changing the name of the file, eliminating all extra code, eliminating all images. It is now just direct empty code with one link from a clean Dreamweaver new file.

             

            I am a forced Woodwing convert. All I want to do is have a button in the tool bar that opens the company website. This used to be the newsfeed feature in woodwing. Now I somehow have to recreate or create a jump page in a static file that is zipped up and uploaded. Currently I can not load an app with this to a real iPad. It does compile, sign and download from the system. Just can't transfer to any of our development iPads. I need this because I need to put it on the development iPad of the customer for review.

             

            Thanks

             

            Steve

            • 3. Re: News Feed from upstate icon
              Bob Bringhurst - Adobe Adobe Employee

              You're using Viewer Builder to create the testing .ipa file, right? And if you create a custom nav bar button that links to a simple HTML file, you can't load the .ipa file on your iPad, but if you build the app without the custom icon, you can't load the app on your iPad. Is that correct?

              • 4. Re: News Feed from upstate icon
                TeuvoLee Finland

                Hi Bob,

                 

                Yes. That seems to be the problem.  Actually it is not only that it links to a simple HTML File.  It feels like it does not like the Zip file I am providing.  The zip file contains only a simple HTML that contains one link to the website. But in truth that is not what I really want. That was just the test. What I want is the button to link to the company home page opening a window in the app as the Woodwing newsfeed used to work.

                 

                Thanks,

                 

                Steve

                • 5. Re: News Feed from upstate icon
                  TeuvoLee Finland

                  Hi All, Woodwing has comeback with a solution but it has not worked for me. They have duplicated the problem. They say that I was using og (Open Graphics) codes in my HTML. For some reason this is not allowed with xCode but should work when transfering to iTunes.  I removed all the og code and it seems to have not fixed the problem with xCode.  But transfering to iTunes does work. I will just have to go back to that and wean myself off of xCode.

                   

                   

                  Cheers,

                   

                  Steve