5 Replies Latest reply: Jul 11, 2012 7:44 AM by Dean Utian RSS

    quicktime movie doesn't show up in shockwave

    elisabettaclarius Community Member

      Hi Guys,

       

      perhaps somebody can help me with this question that is really hard to figure out.

      I have a project made with director 11 that use some quick time videos(H264). Pubblishing the .app the project is ok. Instead if I export html and .dcr file, the .mov doesn't show up. I can hear audio, I can use interactive buttons, but the video is totally black.

       

      To figure out I tried to put the URL in the internet button under the filename of the member tab. Also I tried to preload the movie using the following script but nothing. 

       

      Have you any ideas?

       

       

      property pURLString -- the URL o  the asset to preload

      property pNetMember -- the cast member to assign the URL to

       

      --------------------------------------------------------------

      -- Attach this behavior to a frame script or sprite.

      --

      -- This behavior preloads a user-specified URL string and

      -- stores a reference to it in a global variable.

      -- The status of the global variable needs to be checked with

      -- netDone(_global.netID)to be sure the asset is loaded.

      --

      -- Ken Loge - http://dreamsteep.com

      --------------------------------------------------------------

       

      on getPropertyDescriptionList me

        list = [:]

        addProp list, #pURLString, [#comment: "URL of asset to preload:", #format: #string, #default: "http://dreamsteep.com/dreamedia/mov/Expand-Colors-1.mov"]

        addProp list, #pNetMember, [#comment: "Cast Member to assign the URL to:", #format: #member, #default: "Video1"]

        return list

      end

       

      on exitFrame me

        -- set the filename of the specified member to the specified URL

        member(pNetMember).fileName = pURLString

        _global.netID = preloadNetThing(pURLString)

      end

       

      ___________

       

       

      I am working on a IMac 3.4 Ghz Intel Core i7 8 GB RAM. Os X 10.6 snow leopard. Browser safari o google chrome.

       

       

      Thank you very much,

      Elisabetta