9 Replies Latest reply on Jul 16, 2012 9:57 AM by Limerick6053

    ColdFusion can't find ApplicationProxy.cfc in site root.


      I am running CF9 Standard on a Windows 2008 R2 server. I have an Application.cfc and ApplicationProxy.cfc in my root directory and


      I am trying to "extend" the ApplicationProxy.cfc in a sub directory that houses a login page. When I try to access my site login


      page, I receive a file not found error. Here is the basic file layout.


      mysite\Site1 (root)







      When I view the members/Application.cfc I have the following code:


      <cfcomponent name="Application" extends="site1.ApplicationProxy">


      But any attempt to hit the page results in a "404 - File not found" error in IE and Firefox.

      The problem is that CF cannot find the ApplicationProxy.cfc file on the production server. It works on my test (local) server

      and I can't figure out why it won't work on production. Tried all suggestions from Ben Nadel and Stack Overflow. Still no




      Here's the mapping for the directory in CF Administrator:

      /mysite  D:\inetpub\wwwroot\mysite\site1