5 Replies Latest reply: Jul 24, 2012 6:11 AM by MichaelKazlow RSS

    Adobe [Reader] 10 for Mac Powerbook G4 with OS X 10.5.8 and Safari 5.0.6

    Thakarash Community Member

      Is such possible?  CTUonline says I need Adobe [Reader] 10.  The 'get Adobe' tabs only takes me to an Adobe 9.5 although it would seem from the specs/requirements that I should be able to get version 10.


      [Edited for clarity by host]