2 Replies Latest reply: Jul 25, 2012 12:22 AM by MOMIR ZECEVIC RSS

    watermark does not work

    eleazarlara Community Member

      Hi

       

      I am working with dot net, creating an automation plugin for photoshop, I put a watermark in an image, so I'm using the action: eventFill, as follows:

       

      /***************************************************************************************** **********************/

      Error = sPSActionDescriptor->Make(&adDescriptor);

                if (Error != 0)

                {

                          ePlugInError = PlugInErrorActionMakeDescriptor;

                          goto returnError;

                }

       

      Error = sPSActionDescriptor->PutString(adDescriptor, keyFrom, "C:\\folder\prueba.jpg");

      if(Error != 0)

      goto returnError;

       

      Error = sPSActionDescriptor->PutEnumerated(adDescriptor, keyUsing, typeFillContents, enumPattern);

      if(Error != 0)

      goto returnError;

       

      Error = sPSActionDescriptor->PutEnumerated(adDescriptor, keyMode, typeBlendMode, enumNormal);

      if(Error != 0)

      goto returnError;

       

      Error = sPSActionDescriptor->PutFloat(adDescriptor, keyOpacity, 25.0);

      if(Error != 0)

      goto returnError;

       

      Error = sPSActionDescriptor->PutInteger(adDescriptor, keyTolerance, 25);

      if(Error != 0)

      goto returnError;

       

      Error = sPSActionControl->Play(&adResult, eventFill, adDescriptor, plugInDialogSilent);

       

      if (Error != 0)

      goto returnError;

       

      /***************************************************************************************** **********************/

       

      But marks error to execute el command "Play", Why??

       

      I need help you

       

      Regards

        • 1. Re: watermark does not work
          Tom Ruark Adobe Employee

          Did you get this dump from Listener? You can eventPlace an image or you can eventFill with a pattern. I don't see a way to repro the code you are showing. I could be missing something of course. Please let me know the steps you used to get the code above.

          • 2. Re: watermark does not work
            MOMIR ZECEVIC Community Member

            If you do not find a way to directly do it as you have tried (please post here if you do I am intersted), you may try this.I remember that we have used either text watermark, or something like open watermark file,  copy, close file,  paste, set transparency and mode, merge down, etc. Now we have settled with text watermark, (we use custom font).

             

             

            Regards,

            Momir Zecevic