4 Replies Latest reply: Aug 17, 2012 7:08 AM by Ether-x RSS

    Spark modules not supported ?


      I can't get the extension builder load modules within Flash Pro, is this related to spark modules ?


      For instance I noticed that <s:states> was not supported and I had to replace it with <csxs:states> to get it working. What about Flex modules ?


      It seems that the framework even in its version 2.0 is not yet ready, I got lot of bugs with Flash Builder 4.6, have to restart it every 20min, and the view design mode is working once in a blue moon. I know Adobe want to drop the support for the design view but all this contributes to very bad developper experience.


      Searched on the internet and through the forum, but could'nt find an answer, no body here is using modules ? Or is this just my configuration ?


      Thank you for your time,


      Sylvain Lecoy

        • 1. Re: Spark modules not supported ?
          Ether-x Community Member

          Does this tool has any serious support or will be abandoned ?


          Is a csxs:CSExtension can load spark modules ? It fails silently when I try to load modules in a Flash panel.

          • 2. Re: Spark modules not supported ?
            MSSDedalus Community Member

            Unfortunatelly I can't help you with the modules but I hope it will not be abandoned, it's a great tool that just needs to be refined in some aspects.


            Besides from the designer error with apedelta.swc ( I assume this is a common one) I get a crash when closing Flashbuilder, until now no other errors but I have noticed that working with large files ( more than 4.000 lines) becomes very slow.


            Also it's important to clean the project sometimes or you will start to get non expected errors.


            Many of the problems I had could be solved by creating a new simple testing extension and working only with this problem or feature I want to introduce.


            Good luck.

            • 3. Re: Spark modules not supported ?
              DBarranca Community Member

              Hi Sylvain,

              I would suggest you to drop Flash Builder 4.6 (which is a real pain in any delicate part of the body you'd like to pick) and stick to version 4.5 - there Design mode is not flawless but magnitude orders more stable. This of course if you don't need 4.6 features for other projects.


              As for the rest I'm not in the position to give you answers.




              • 4. Re: Spark modules not supported ?
                Ether-x Community Member

                Thank for your help.


                When I am working with spark modules which are not dynamically loaded, e.g. compiled with the app, it gets loaded. So it has to do with security ?


                Any adobe maintainers answer on this specific question would be greatly appreciated.


                Thanks !