8 Replies Latest reply on Aug 24, 2012 8:51 AM by RHuck84

    Flash Builder 4 Run Problem


      When I Run a project in FB4 sometimes I have this weird problem where the changes I have made do not show up in the project I have just ran.  I can do something as simple as changing a label or complex as changing some AS code and it still has this problem.  I am not sure if it is random or what the issue is.  Has anyone else encountered this or have an answer as to why it might be happening?  Thanks in advance!

        • 1. Re: Flash Builder 4 Run Problem

          I've seen this too occasionally, seems to be a bug in Flash Builder. Even a full Refresh / Clean & Build All doesn't always fix it. Have to exit, restart Flash Builder and do another Clean & Build All.

          • 2. Re: Flash Builder 4 Run Problem
            fxcomputers Level 1

            Even with a clean and I can see the files being replaced it still is not running the updated files for some weird reason.

            • 3. Re: Flash Builder 4 Run Problem
              TomBurgundy Level 1

              I had a similar problem, for which I post the link below, but I never found a solution, so please don't expect too much insight from reading the discussion.



              • 4. Re: Flash Builder 4 Run Problem
                John Wolfsteiner Level 1

                I occasionally run into this as well. Very frustrating.

                • 5. Re: Flash Builder 4 Run Problem
                  Anirudh Sasikumar Adobe Employee

                  Is the SWF hosted on a web server? It may be getting cached by the browser.


                  Can you post your Flash Builder log the minute after you run into this problem the next time? The log is at workspacedir/.metadata/.log


                  Usually when Flash Builder performs an incremental compilation and something goes wrong, "An internal build error occurred" will appear in the Problems view.

                  • 6. Re: Flash Builder 4 Run Problem
                    fxcomputers Level 1

                    I seemed to have figured this out.

                    1)  You must have 0 errors in the problems log when compiling

                    2)  You may need to press the refresh button on your browser

                    3)  If that doesn't work you can clean out your temp internet files.


                    The problem for me seemed to be that I needed to refresh the page.  Not sure why.  I hope this helps someone else too!

                    • 7. Re: Flash Builder 4 Run Problem
                      Brian Vaughn Level 1

                      I've recently been experiencing an abnormal number of occurrences of this error and Google directed me to this thread. In response to your question, here's the Error Log message that gets added when the "internal build error" occurs:



                      Mon Aug 06 13:11:03 EDT 2012

                      Uncaught exception in compiler



                                at com.adobe.flexbuilder.project.ui.utils.ANE.AppXMLFileANEExtensionHandler.addToAppXmlFile( AppXMLFileANEExtensionHandler.java:74)

                                at com.adobe.flexbuilder.project.ui.utils.ANE.AppXMLFileANEExtensionHandler.addToAppXmlFile( AppXMLFileANEExtensionHandler.java:46)

                                at com.adobe.flexbuilder.project.ui.utils.ANE.ANEController.applyWorkingCopy(ANEController.j ava:720)

                                at com.adobe.flexbuilder.project.ui.utils.ANE.ANEController.projectIsBuilt(ANEController.jav a:904)

                                at com.adobe.flexbuilder.project.compiler.internal.FlexProjectBuilder.informProjectBuildList ener(FlexProjectBuilder.java:156)

                                at com.adobe.flexbuilder.project.compiler.internal.FlexProjectBuilder.buildItem(FlexProjectB uilder.java:616)

                                at com.adobe.flexbuilder.project.compiler.internal.FlexProjectBuilder.build(FlexProjectBuild er.java:382)

                                at com.adobe.flexbuilder.project.compiler.internal.FlexIncrementalBuilder.build(FlexIncremen talBuilder.java:187)

                                at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:728)

                                at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)

                                at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:199)

                                at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:239)

                                at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:292)

                                at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)

                                at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:295)

                                at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:351)

                                at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:374)

                                at org.eclipse.core.internal.resources.Workspace.buildInternal(Workspace.java:513)

                                at org.eclipse.core.internal.resources.Workspace.build(Workspace.java:422)

                                at org.eclipse.ui.actions.GlobalBuildAction$1.run(GlobalBuildAction.java:180)

                                at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)


                      My particular project is a Flex Mobile project with a couple of ANEs. I have to restart Flash Builder every couple of times I launch my project though because of this type of error.


                      Any ideas? Could I provide you with any more information to help track down the problem?

                      • 8. Re: Flash Builder 4 Run Problem

                        I am experiencing the same exact error as Brian above. Does anyone have any clues as to what's wrong here? It's only happening when I try to compile an AIR application for mobile development, and I'm running FB 4.6. I've tried using different versions of the Flex/AIR SDK to no avail.