9 Replies Latest reply: Aug 7, 2012 7:51 AM by sssuuusssaaannn RSS

    How to create a TOC with FM?

    Crystal Chen Community Member

      I am a new user of FM.

      I am editing a datasheet with FM, which already have TOC. But after I translated the TOC into Chinese. The link to the page lost. How can I rebuild the link? Like in WORD, we can just choose update field, is there any similar function in FM?

        • 1. Re: How to create a TOC with FM?
          Reviewer1066 Community Member

          Select Special > Table of Contents

          • 2. Re: How to create a TOC with FM?
            Crystal Chen Community Member

            I already have a TOC. I just want to update the text and the numbering.....

            I don't want to revise the format at all...

            • 3. Re: How to create a TOC with FM?
              David Crowe Community Member

              Nevertheless, if the table of contents is not updating, making a new one is the way to go. There is a special link between the table of contents and the book; if the link’s been broken (by renaming one or both, or for other reasons) you can’t get it back.

               

              As Van says, make a new table of contents. If you want to simplify your task, make a copy of the old one, then import the formats from the old to the new. You need to import page formats, paragraph formats and reference pages, then regenerate for it all to be taken into account.

              • 4. Re: How to create a TOC with FM?
                David Crowe Community Member

                Or … further thought … you are updating the book, aren’t you? To regenerate the table of contents?

                • 5. Re: How to create a TOC with FM?
                  Crystal Chen Community Member

                  Yes, but I am trying to figure out how to import the formats.

                  Still, thanks very much.

                  • 6. Re: How to create a TOC with FM?
                    NakshatraB Adobe Employee

                    Hi Crystal,

                     

                    Did you update the TOC manually, without translating the actual content itself?

                    If that's the case, I guess you might have deleted the hypertext markers that establish the link between the TOC and the actual file with the content. You can validate it by opening the Marker pod and compare the two files.

                     

                    If it's only about importing the formats:

                    Open both the TOCs in FrameMaker. With focus on the TOC where you want to import formats into select menu File > Import > Formats and select the desired formats to import after selecting the source TOC in the file dropdown.

                     

                    Regards,

                    Nakshatra

                    • 7. Re: How to create a TOC with FM?
                      sssuuusssaaannn Community Member

                      Hi,

                      Newbie here who is also having vast problems with ToC and panicking a bit, since I have to deliver this document and can't get the ToC to match the one in the template.  I have FM 10, Windows 7.

                      When I saw the ideo of importing the formats I was thrilled, but I tried it and no go.

                      There are two problems:

                      1.  I have an unwanted chapter number in front of my page number.  The page numbers do progress in order from 1 to about 100, throughout the book and the ToC.  However, the chapter number—i.e., a number with a dash followed by the page number—is displayed in front of each page in the ToC, and not in the book!  I think I've tried every possible combination in 'Numbering' section but nothing gets rid of these chapter numbers; I'm beginning to think the template creator simply removed them manually after final generation of the ToC!

                       

                      2.  In the original document from which the template is imported, there is a preface that used small roman numerals starting at page v, and then Chapter 1 starts at page 1.  When I generate the
                      ToC I get a message saying the document numbering properties differ from the numbering properties of the book an the book numbering properties will be applied.  How can I use both formats and prevent htis message?

                       

                      PS  How do you format numbering properties for the BOOK instead of each document?  I've tried selecting the book title, then selecting all docs at once, but when I do these things the 'numbering' feature in the menu is dimmed.

                       

                      Thanks ever so much in advance to anyone who can help me out of this muddle!

                       

                      PSS  If the problem lies with how the template was imported for my document I don't know whether I can do anything about it since no one involved in that is available to me.  However I don't think this is the case, as the rest of the template has been working beautifully.

                      • 8. Re: How to create a TOC with FM?
                        Reviewer1066 Community Member

                        I have an unwanted chapter number in front of my page number.  The page numbers do progress in order from 1 to about 100, throughout the book and the ToC.  However, the chapter number—i.e., a number with a dash followed by the page number—is displayed in front of each page in the ToC, and not in the book!  I think I've tried every possible combination in 'Numbering' section but nothing gets rid of these chapter numbers; I'm beginning to think the template creator simply removed them manually after final generation of the ToC!

                        View the reference page for the TOC. The entries for the various levels likely END with something like <$chapnum>-<$pagenum>. Simply DELETE <$chapnum>-, save the file, and update the book. This is telling FrameMaker to include just the page number in the TOC entry, not the chapter number.

                         

                        In the original document from which the template is imported, there is a preface that used small roman numerals starting at page v, and then Chapter 1 starts at page 1.  When I generate the ToC I get a message saying the document numbering properties differ from the numbering properties of the book an the book numbering properties will be applied.  How can I use both formats and prevent htis message?

                        This is telling you that you have set the numbering IN the specified document itself and that numbering differs from that specified in the book. IF the resulting numbering in the TOC is the way you want it (lowercase roman in the preface and Arabic from there on), then everything is fine. You likely will never see the warning again.

                         

                        HOWEVER, if the TOC numbering is incorrect, then in the BOOK file, right-click the preface file and select Numbering. In the Page tab, select lowercase roman beginning at 1 (or maybe i). Then right-click chapter 1 and select Numbering. In the page tab select Arabic starting at 1. Then select all the remaining chapters in the book file, right-click > Numbering, and select Continue from previous in the Page tab. Update the book. Setting the numbering in the BOOK file is the standard way to set the numbering for a book, including chapters, pages, paragraphs, etc. Specifying the numbering in each document file is a waste of time because the settings in the book file take precedence.

                         

                        Van

                        • 9. Re: How to create a TOC with FM?
                          sssuuusssaaannn Community Member

                          Hi Van,

                           

                          YES!  IT WORKED!  I took out the chapnum tag and now I don't have chapter numbers!  (Funny thing is, in the template ToC where there are no chapter numbers, the chapnum tag IS in the ref page.)

                           

                          You would think FM would make this type of formatting easier, without having to resort to looking at reference pages, but oh well.

                           

                          I also managed to get back the roman numerals on the preface.  It's still called Chapter 1, but I'll just erase that and call the next chapter Chapter 1 as well, when the time comes.

                           

                          Thank you So Much!

                           

                          Susan