7 Replies Latest reply on Aug 8, 2012 2:09 PM by NewbieTechWriter

    FM 10 "Unusable Fonts"


      Hello again everyone.


      I have a book with multiple documents and the ToC needs updating. However, when I tried to update the ToC, it says that one of my documents uses "unusable fonts". Here's the thing, it's using Times New Roman. I have tried changing to another common font (Arial), changing back to Times New Roman, .mif washing, and creating a new book and importing the same documents. Nothing's worked. Any suggestions?  Thanks.



        • 1. Re: FM 10 "Unusable Fonts"
          Reviewer1066 Level 4

          Are you sure the message is "unusable fonts" not UNAVAILABLE fonts? If unavailable, the message should tell you which font is unavailable.

          • 2. Re: FM 10 "Unusable Fonts"
            NewbieTechWriter Level 1

            Sorry, my bad. It is saying "unavailable" but no it is not telling me which font is unavailable. Hoever, currently it's in Times New Roman. But it still says it no matter what font I change it too.


            EDIT - it was posting this in another window:


            The "TimesNewRomanPSMT" Font is not available.

              "Times New Roman" will be used in this session.

            The "TimesNewRomanPSMT" Font is not available.

              "Times New Roman" will be used in this session.


            But I'm not telling it to use PSMT. Alos, even though I save after it changes it to Times New Roman, it still says its PSMT next time I open it - even if I manually change it to "normal" Times New Roman"

            • 3. Re: FM 10 "Unusable Fonts"
              NewbieTechWriter Level 1



              Also have tried the following:


              Forced all tags/paragraphs/text to Times New Roman (standard) as not only the current font but default font.


              Have tried creating new document and copy/paste and repeating the step described above.


              Neither worked. More input would be aprreciated. Thanks.



              • 4. Re: FM 10 "Unusable Fonts"
                NewbieTechWriter Level 1

                Did some digging on my own, and found a way to fix it, I will post what I found here, but I still don't know how the problem arose in the first place.


                Times New Roman and "Times New RomanPSMT"  are basically the same with the PSMT being the "PostScript" (whatever that is) name of the same font. Looked in my font folder in Win 7 and discovered I had a font titled Times New Roman, but not one with the PSMT on the end of it. Did a google search for a download of "Times New RomanPSMT" and installed it in my font folder and the problem is solved. How on earth the document randomly changed (I had been editing it for over a month) to a font I didn't even have on my computer I don't know, as I am the only one authoring the content.


                Anyway, I will just leave this up in case anyone runs into the same problem they will know how to fix it. Any input on how this happened would be appreciated. Thanks for your time everyone.



                • 5. Re: FM 10 "Unusable Fonts"
                  Mike Wickham Level 4

                  Since you have FM10, it's easy to see which fonts are unavailable by opening the Fonts pod (View> Pods> Fonts). A little red "X" (actually, it's two crossed arrows) appears to the left of the font name. Then, you can click on the Replace Fonts icon to open the Replace Fonts dialogue, where you can easily change out the missing font.


                  Unavailable fonts also show in the Console window for all versions of FrameMaker.

                  • 6. Re: FM 10 "Unusable Fonts"
                    Reviewer1066 Level 4

                    Unavailable fonts can reside anywhere in the document, including reference and master pages. I have discovered cases in which a font instance is simply turning the font on and then off again with no content in between. This happened when our company switched from using font A to using font B. Even though the content on the body pages was all font B, FrameMaker still said font A was being used. I had to export the document as mif, then open the mif file in a text editor to find about two instances of a font A toggle on-off. Those were the days before font pods.


                    There is a possible explanation of how your font got changed to the PostScript version. You say you are the sole author, so this may not apply. But suppose the document was sent to a third party who did not have the non-PS version of the font. The third party opened the file and got a message that the non-PS font was not available. So, the third party turned OFF rememeber missing fonts, reopened the file, and FrameMaker replaced the non-PS version with the PS version. Then the third party saved the file. You get the file back, open it, no PS font available. To get it back to your non-PS version would be to turn OFF remember missing fonts in the preferences, open the file (the non-PS version replaces the PS version), then save the file. Then turn ON remember missing fonts. Turning ON remember missing fonts, allows you to edit a file that uses a font you do not have; when it is opened on a machine WITH the font, the document is happy. BUT you say you are the only author. So, this explanation may be a long shot.


                    By the way, PostScript is a language for describing pages. It is used primarily by digital printing houses and PostScript printers. PostScript fonts are fonts described in the PostScript language and are typically better quality than non-PostScript fonts.



                    1 person found this helpful
                    • 7. Re: FM 10 "Unusable Fonts"
                      NewbieTechWriter Level 1

                      Thanks for the explanation!


                      Some of the text I did copy paste from other documents in the company, so maybe that's how the PostScript font snuck in.