8 Replies Latest reply: Jul 19, 2013 9:01 AM by mcm_art RSS

    character palette in CS6 flaw!

    r_tist Community Member

      This is bad news. When I select a font onscreen and open the character palette, then click on the font drop down, it is not automatically bringing up the selected font...meaning, it just begins at the very top of the list with 'A'. So...if it is something in the Helvetica family that I want to change to, say, Helvetica Neue, or what have you, I need to scroll all the way down my enormous font list over & over again. God forbid it be a font under 'T'.


      Is there any way to correct this issue, or has CS6 just not up to it?!



        • 1. Re: character palette in CS6 flaw!
          BobLevine UGM

          CS6 displays recent fonts and the current font should be at the top of the list. Check your preferences if you don't see it:



          • 2. Re: character palette in CS6 flaw!
            Peter Spier ACP/MVPs

            As Bob says, totally new behavior, and there's nothing you can change other than the number of recent fonts.


            There was a similar thread a few weeks ago where I advocated for makeing the recent list longer, rather than shorter, if you use a realtively small number of fonts most of the time. Otherwise, if you type the first few characters of the font name in the field the list should move to that font, and the arrow keys will work to move up and down from that point if you don't want to open the list and use the mouse to move one or two spots.

            • 3. Re: character palette in CS6 flaw!

              Go to the preferences menu like on Bob Levine's pic and under "Number of Recent Fonts to Display", type in "0". That should fix it!

              • 4. Re: character palette in CS6 flaw!
                r_tist Community Member

                It is nothing to do with Number of Recent Fonts to Display set to '0'. As someone else mentioned, perhaps setting this to a very high number may help out a bit.

                The problem is when I select my font in the character palette, click the drop down to reveal my entire list of fonts - the list does not auto jump to the font I am currently using.

                It brings me up to the very top of the list at 'A', so I have to manually scroll down every time through the entire alphabet.


                As you know many font families have completely different fonts to display THIN, SEMIBOLD, or what have you, vs. the different attributes of that family come up in the field below the font name (in the character palette). This is really frustrating as even if I attempt to manually type in the name, many times it won't jump to that font in the list due to shortened / abbreviated name.


                It's a real headache and in Illustrator even more so as Illustrator doesn't seem to have the scroll option available. Meaning, you need to click the arrow icon and wait for it to scroll all the way down the list.


                Any other ideas or preferences that can be changed?



                • 5. Re: character palette in CS6 flaw!
                  BobLevine UGM

                  Have you tried typing the name of the font?





                  • 6. Re: character palette in CS6 flaw!
                    josh xxiv Community Member

                    I have to agree with r_tist - InDesign CS5.5 was much more efficient when switching fonts within the same family because the preview list would jump to the currently selected font. The new features of the font preview list have not made enough improvements in the user experience to warrant the removal of jumping to the current font. At least make it an option.

                    • 7. Re: character palette in CS6 flaw!

                      Has anyone come up with a work around for this "feature".


                      It's a huge hassel and extremely time consuming. This was the only post I could find. I can't believe no one else has talked about it. Everyone I know hates this.

                      • 8. Re: character palette in CS6 flaw!
                        mcm_art Community Member

                        Ok, after googling and realizing i am not the only one with this problem,

                        I fixed my jump to the top of the font list problem!!!!!! Finally! ...


                        1. Set [Number of recent Fonts To Display] to "0"


                        2.IMPORTANT (Makes no sense Adobe!!) ...... You have to check the box for [Sort Recent Fonts List Alphabetically]


                        3. BOOM!!!! Works!