10 Replies Latest reply: Aug 17, 2012 11:43 AM by uziiiiivateeeel RSS

    AR 9.1 for linux will not maximize correctly

    Community Member
      Using a computer with 2 displays (using an NVidia video card and TwinView configuration), we have found the window maximize function, as controlled by the gnome window manager, does not work properly on *one* monitor.

      One monitor shows expected behavior: the toolbars and document view are stretched to fill all the available space of the resized window.

      On the other monitor, maximizing Adobe Reader will maximize the outer border of the application window, but the toolbars and document view windows within that outer border are not scaled to fill all available space. The background is just filled in with gray.

      Other gnome-based applications (firefox, thunderbird, calculators, etc.) do not show this behavior, which make me think it is likely something specific to Adobe Reader.

      John Perkins
      john@cs.wisc.edu
        • 1. Re: AR 9.1 for linux will not maximize correctly
          (Alexander_R)
          I've this issue and in a same environment (xinerma mode) too.
          Opensuse 11.0 x86, AR 9.1 from adobe.com download page

          Videos:
          01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2) (1280x1024)
          02:0a.0 VGA compatible controller: S3 Inc. 86c325 [ViRGE] (rev 06) (800x600)

          link to screenshot: http://imageshost.ru/links/0e7a26fc80e63dd8565bb8df7eeb1dc9
          • 2. Re: AR 9.1 for linux will not maximize correctly
            Community Member
            Hello John/Alexander R,

            I could reproduce the problem with Extended mode(wherein additional desktop area is created on secondary desktop) but not with Clone/twin and xinerama/span modes as you have mentioned in your posts.

            Could you please confirm that you are using twinview and xinerama modes and mail me the dump of /etc/X11/xorg.conf at sanika at adobe dot com.

            John, could you also let me know the linux/solaris distribution you are using.

            Thanks for your help!
            Sincerely,
            Sanika
            • 3. Re: AR 9.1 for linux will not maximize correctly
              TechGuru Floyd

              I have the same problem. Adobe Reader will not maximize unless I drag the corner manually and slow enough to give it time to refresh. Once it's maximized, there is always at least a little bit of gap (on the bottom and on the right) between the acroread portion of the window and the window decorations. If I resize the window too quickly (eg make it smaller), then acroread does not get the message to repaint or something, and portion of it is "cut off". I have to resize the window slowly to get it to fill the space correctly again.

               

              I am using Acroread 9.2 on Gentoo Linux (Profile 10.0, kernel 2.6.31-gentoo-r6). I've tried, without success, in KDE-3.9, KDE-4.3, and in XFCE-4, so the window manager is not the problem.

               

              Another symptom is how the window insists on coming up in the middle of the two screens, vs one or the other. XFCE did a better job of getting the window in the right position, even if acroread still didn't maximize/resize correctly.

               

              Thanks,

              Jacob

               

              PS: My xorg.conf from /etc/X11/xorg.conf:

               

              #########################################################################

              # nvidia-settings: X configuration file generated by nvidia-settings

              # nvidia-settings:  version 1.0  (root@centaur)  Tue Mar 31 23:15:45 MDT 2009

               

               

              Section "ServerLayout"

                  Identifier     "X.org Configured"

                  Screen      0  "Screen0" 0 0

              #    InputDevice    "Mouse0" "CorePointer"

              #    InputDevice    "Keyboard0" "CoreKeyboard"

              EndSection

               

              Section "Files"

                  RgbPath         "/usr/share/X11/rgb"

                  ModulePath      "/usr/lib/xorg/modules"

                  FontPath "/usr/share/fonts/misc"

                  FontPath "/usr/share/fonts/Type1"

                  FontPath "/usr/share/fonts/100dpi"

                  FontPath "/usr/share/fonts/75dpi"

                  FontPath "/usr/local/share/fonts"

              EndSection

               

              Section "Module"

               

              #"dri" conflicts with nVidia provided "glx"

              # Load  "dri"

                  Load           "extmod"

                  Load           "record"

                  Load           "dbe"

                  Load           "xtrap"

                  Load           "glx"

                  Load           "wfb"

                  Load           "freetype"

                  Load           "type1"

              EndSection

               

              Section "ServerFlags"

                  Option         "Xinerama" "0"

              EndSection

               

              Section "Extensions"

                  Option         "Composite" "Enable"

              EndSection

               

              # InputDevices taken care of with HAL now

               

              #Section "InputDevice"

              #    Identifier     "Keyboard0"

              #    Driver         "kbd"

              #    Option         "XkbRules" "xorg"

              #    Option         "XkbModel" "pc104"

              #    Option         "XkbLayout" "us"

              #    Option         "XkbOptions" "altwin:menu"

              #EndSection

               

              #Section "InputDevice"

              #    Identifier     "Mouse0"

              #    Driver         "mouse"

              #    Option         "Protocol" "auto"

              #    Option         "Device" "/dev/input/mice"

              #    Option         "ZAxisMapping" "4 5 6 7"

              #EndSection

               

              Section "Monitor"

                  Identifier     "Monitor0"

                  VendorName     "Unknown"

                  ModelName      "HP PAVILION M50"

                  HorizSync       30.0 - 54.0

                  VertRefresh     50.0 - 100.0

              EndSection

               

              Section "Device"

                  Identifier     "Device0"

                  Driver         "nvidia"

                  VendorName     "NVIDIA Corporation"

                  BoardName      "GeForce FX 5200"

              EndSection

               

              Section "Screen"

                  Identifier     "Screen0"

                  Device         "Device0"

                  Monitor        "Monitor0"

                  DefaultDepth    24

                  Option         "TwinView" "1"

                  Option         "TwinViewXineramaInfoOrder" "DFP-0"

                  Option         "metamodes" "CRT: 1024x768_60 +0+256, DFP: nvidia-auto-select +1024+0"

                  SubSection     "Display"

                      Depth       24

                  EndSubSection

              EndSection

              #########################################################################

              • 4. Re: AR 9.1 for linux will not maximize correctly
                FedericoFe

                Hi,

                 

                I have exactly the same annoying problem with Adobe Reader 9.3 on my Ubuntu 9.10 (with Gnome).

                 

                I'm using an NVidia video card and TwinView configuration.

                On one monitor everything works fine, on the other one it maximizes only the outer border of the application window.

                Strangely enough, the problem occurs on the primary screen and AR always opens on the second screen, i.e. it doesn't remember on which screen it was opened the last time.

                 

                Here's my xorg.conf file:

                 

                # -------------------------------------------------------------------------

                 

                Section "ServerLayout"
                    Identifier     "Layout0"
                    Screen      0  "Screen0" 0 0
                    InputDevice    "Keyboard0" "CoreKeyboard"
                    InputDevice    "Mouse0" "CorePointer"
                EndSection

                 

                Section "Files"
                EndSection

                 

                Section "ServerFlags"
                    Option         "Xinerama" "0"
                EndSection

                 

                Section "InputDevice"

                 

                    # generated from default
                    Identifier     "Mouse0"
                    Driver         "mouse"
                    Option         "Protocol" "auto"
                    Option         "Device" "/dev/psaux"
                    Option         "Emulate3Buttons" "no"
                    Option         "ZAxisMapping" "4 5"
                EndSection

                 

                Section "InputDevice"

                 

                    # generated from default
                    Identifier     "Keyboard0"
                    Driver         "kbd"
                EndSection

                 

                Section "Monitor"
                    Identifier     "Monitor0"
                    VendorName     "Unknown"
                    ModelName      "Samsung SyncMaster"
                    HorizSync       30.0 - 81.0
                    VertRefresh     56.0 - 75.0
                    Option         "DPMS"
                EndSection

                 

                Section "Monitor"
                    Identifier     "Monitor1"
                    VendorName     "Unknown"
                    ModelName      "LEN"
                    HorizSync       46.3 - 55.7
                    VertRefresh     40.0 - 60.0
                EndSection

                 

                Section "Device"
                    Identifier     "Device0"
                    Driver         "nvidia"
                    VendorName     "NVIDIA Corporation"
                    BoardName      "Quadro NVS 140M"
                EndSection

                 

                Section "Device"
                    Identifier     "Device1"
                    Driver         "nvidia"
                    VendorName     "NVIDIA Corporation"
                    BoardName      "Quadro NVS 140M"
                    BusID          "PCI:1:0:0"
                    Screen          1
                EndSection

                 

                Section "Screen"
                    Identifier     "Screen0"
                    Device         "Device0"
                    Monitor        "Monitor0"
                    DefaultDepth    24
                    Option         "TwinView" "1"
                    Option         "TwinViewXineramaInfoOrder" "CRT-0"
                    Option         "metamodes" "CRT: nvidia-auto-select +1440+0, DFP: nvidia-auto-select +0+0"
                    SubSection     "Display"
                        Depth       24
                    EndSubSection
                EndSection

                 

                Section "Screen"
                    Identifier     "Screen1"
                    Device         "Device1"
                    Monitor        "Monitor1"
                    DefaultDepth    24
                    Option         "TwinView" "0"
                    Option         "metamodes" "DFP: nvidia-auto-select +0+0"
                    SubSection     "Display"
                        Depth       24
                    EndSubSection
                EndSection

                 

                # -------------------------------------------------------------------------

                 

                Federico

                • 5. Re: AR 9.1 for linux will not maximize correctly
                  elaxdal

                  I'm also encountering the same problem with my CentOS 5.4 box and a number of different AR 9.x.y versions, including the latest 9.3.1.  Adobe Reader 8 did not show this problem on the same system, and other apps are working correctly.

                   

                  Using the maximize button with either KDE or GNOME on one display results in the Adobe Reader resizing correctly.  The maximize button works flawlessly on the other display.  I can also resize the window by dragging the bottom corner of the window on either system without a problem.

                   

                  One difference between my system and the previous post is that it has an ATI Radeon 2400 video card, with the xorg.conf file supplied below.

                   

                  Thanks,

                  Erik

                   

                   

                   

                   

                  # Xorg configuration created by pyxf86config

                   

                  Section "ServerLayout"
                          Identifier     "Default Layout"
                          Screen      0  "aticonfig-Screen[0]-0" 0 0
                          InputDevice    "Keyboard0" "CoreKeyboard"
                  EndSection

                   

                  Section "Files"
                  EndSection

                   

                  Section "Module"
                  EndSection

                   

                  Section "InputDevice"
                          Identifier  "Keyboard0"
                          Driver      "kbd"
                          Option      "XkbModel" "pc105"
                          Option      "XkbLayout" "us"
                  EndSection

                   

                  Section "Monitor"
                          Identifier   "aticonfig-Monitor[0]-0"
                          Option      "VendorName" "ATI Proprietary Driver"
                          Option      "ModelName" "Generic Autodetecting Monitor"
                          Option      "DPMS" "true"
                  EndSection

                   

                  Section "Device"
                          Identifier  "Videocard0"
                          Driver      "radeon_tp"
                  EndSection

                   

                  Section "Device"
                          Identifier  "aticonfig-Device[0]-0"
                          Driver      "fglrx"
                          Option      "DesktopSetup" "horizontal"
                          Option      "OverlayOnCRTC2" "1"
                          BusID       "PCI:1:0:0"
                  EndSection

                   

                  Section "Screen"
                          Identifier "Screen0"
                          Device     "Videocard0"
                          DefaultDepth     24
                          SubSection "Display"
                                  Viewport   0 0
                                  Depth     24
                          EndSubSection
                  EndSection

                   

                  Section "Screen"
                          Identifier "aticonfig-Screen[0]-0"
                          Device     "aticonfig-Device[0]-0"
                          Monitor    "aticonfig-Monitor[0]-0"
                          DefaultDepth     24
                          SubSection "Display"
                                  Viewport   0 0
                                  Depth     24
                          EndSubSection
                  EndSection

                  • 6. Re: AR 9.1 for linux will not maximize correctly
                    Lucky7_500

                    Yup, I'm having the same problem in karmic

                     


                    Section "ServerLayout"
                        Identifier     "Layout0"
                        Screen      0  "Screen0" 0 0
                        InputDevice    "Keyboard0" "CoreKeyboard"
                        InputDevice    "Mouse0" "CorePointer"
                    EndSection

                    Section "Files"
                    EndSection

                    Section "ServerFlags"
                        Option         "Xinerama" "0"
                    EndSection

                    Section "InputDevice"

                        # generated from default
                        Identifier     "Mouse0"
                        Driver         "mouse"
                        Option         "Protocol" "auto"
                        Option         "Device" "/dev/psaux"
                        Option         "Emulate3Buttons" "no"
                        Option         "ZAxisMapping" "4 5"
                    EndSection

                    Section "InputDevice"

                        # generated from default
                        Identifier     "Keyboard0"
                        Driver         "kbd"
                    EndSection

                    Section "Monitor"
                        Identifier     "Monitor0"
                        VendorName     "Unknown"
                        ModelName      "Acer AL1916W"
                        HorizSync       30.0 - 80.0
                        VertRefresh     50.0 - 75.0
                        Option         "DPMS"
                    EndSection

                    Section "Device"
                        Identifier     "Device0"
                        Driver         "nvidia"
                        VendorName     "NVIDIA Corporation"
                        BoardName      "GeForce 7600 GT"
                    EndSection

                    Section "Screen"
                        Identifier     "Screen0"
                        Device         "Device0"
                        Monitor        "Monitor0"
                        DefaultDepth    24
                        Option         "TwinView" "1"
                        Option         "TwinViewXineramaInfoOrder" "DFP-0"
                        Option         "metamodes" "CRT: nvidia-auto-select +0+264, DFP: nvidia-auto-select +1440+0"
                        SubSection     "Display"
                            Depth       24
                        EndSubSection
                    EndSection

                    EndSection

                    • 7. Re: AR 9.1 for linux will not maximize correctly
                      Nikki1791

                      Am having the same issue here. Fedora 13, KDE 4.4.4, Adobe Reader 9.3.2 (04/01/2010) installed using the Adobe repo for Fedora early this month. I have a TwinView setup with nVidia. The problem shows on the laptop screen as well as on the other monitor, which has been set as primary. I can let the body fill the maximised window by pressing ctrl-r.

                       

                      Adobe, is there a solution yet (that does not involve turning off desktop effects)?

                       

                      Here's me:

                       

                      $uname -a
                      Linux localhost.localdomain 2.6.33.5-124.fc13.i686 #1 SMP Fri Jun 11 09:48:40 UTC 2010 i686 i686 i386 GNU/Linux

                      $ lspci | grep nVidia
                      01:00.0 VGA compatible controller: nVidia Corporation G98 [GeForce 9200M GS] (rev a1)

                      $cat /etc/X11/xorg.conf
                      # nvidia-settings: X configuration file generated by nvidia-settings
                      # nvidia-settings:  version 1.0  (mockbuild@builder.wilsonet.com)  Wed Apr 28 18:22:52 EDT 2010

                      # Xorg configuration created by livna-config-display

                      Section "ServerLayout"
                          Identifier     "Default Layout"
                          Screen      0  "Screen0" 0 0
                          InputDevice    "Keyboard0" "CoreKeyboard"
                          InputDevice    "Mouse0" "CorePointer"
                          Option         "Xinerama" "0"
                      EndSection

                      Section "Files"
                          ModulePath      "/usr/lib/xorg/modules/extensions/nvidia"
                          ModulePath      "/usr/lib/xorg/modules"
                      EndSection

                      Section "ServerFlags"
                          Option         "AIGLX" "on"
                      EndSection

                      Section "InputDevice"
                          # generated from data in "/etc/sysconfig/keyboard"
                          Identifier     "Keyboard0"
                          Driver         "kbd"
                          Option         "XkbLayout" "us"
                          Option         "XkbModel" "pc105"
                      EndSection

                      Section "InputDevice"
                          # generated from default
                          Identifier     "Mouse0"
                          Driver         "mouse"
                          Option         "Protocol" "auto"
                          Option         "Device" "/dev/input/mice"
                          Option         "Emulate3Buttons" "no"
                          Option         "ZAxisMapping" "4 5"
                      EndSection

                      Section "Monitor"
                          Identifier     "Monitor0"
                          VendorName     "Unknown"
                          ModelName      "Arnos Instruments F-17B"
                          HorizSync       30.0 - 80.0
                          VertRefresh     50.0 - 75.0
                      EndSection

                      Section "Device"
                          Identifier     "Videocard0"
                          Driver         "nvidia"
                          Option         "AddARGBGLXVisuals" "True"
                      EndSection

                      Section "Device"
                          Identifier     "Device0"
                          Driver         "nvidia"
                          VendorName     "NVIDIA Corporation"
                          BoardName      "GeForce 9200M GE"
                      EndSection

                      Section "Screen"
                          Identifier     "Default Screen"
                          Device         "Videocard0"
                      EndSection

                      Section "Screen"
                          Identifier     "Screen0"
                          Device         "Device0"
                          Monitor        "Monitor0"
                          DefaultDepth    24
                          Option         "TwinView" "1"
                          Option         "TwinViewXineramaInfoOrder" "CRT-0"
                          Option         "metamodes" "CRT: nvidia-auto-select +1366+0, DFP: nvidia-auto-select +0+0"
                          SubSection     "Display"
                              Depth       24
                          EndSubSection
                      EndSection

                      Section "Extensions"
                          Option         "Composite" "Enable"
                      EndSection

                      • 8. Re: AR 9.1 for linux will not maximize correctly
                        ninevoltz

                        This is still an issue, I discovered if you disable tabs, the problem goes away. I'm using Fedora 14 with three monitors, on nVidia. Adobe Reader 9.4-1.

                        • 9. Re: AR 9.1 for linux will not maximize correctly
                          cpt_mocha

                          Disable tabs and the problem goes away?  Not for me.  I assume you are going to Preferences - Documents - "Open documents in tabs...".  I uncheck this and restart and it's still the same problem.

                          • 10. Re: AR 9.1 for linux will not maximize correctly
                            uziiiiivateeeel

                            Hi,

                             

                            I've also noticed this issue still not being fixed.

                            Arch x86_64 GNU/Linux, on 3.4.8 kernel

                            Adobe Reader 9.5.1

                            xorg-server 1.12.3.901

                            Using OpenBox 3.5.0, with two screens (laptop  & monitor)

                            VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller]) - HP ProBook 6460b

                            starting dualscreen with: 'xrandr --output LVDS1 --mode 1366x768 --pos 1600x432 --rotate normal --output TV1 --off --output VGA1 --mode 1600x1200 --pos 0x0 --rotate normal'.

                             

                            AR is affected on both screens if maximized.