7 Replies Latest reply: Sep 13, 2012 8:15 AM by Steve Howard, ACP RSS

    Authorware course does not send "finish" command to LMS


      We have a course (named SAVE) created in Authorware several years ago.


      It had been published in our now-retired LMS (Pathlore).


      We want to publish this course to our current LMS (SkillPort).


      I have access to Authorware 7.01, but have never used the tool.


      We use Windows XP, SP3 and Internet Explorer 8.


      I can start the course upload in SkillSoft Publisher and everything works fine until I do the test launch.  The course opens and works fine throughout, however, when I try to exit the course, I get stuck on the white Authorware course player screen with the Done Progress Bar.  Even leaving it sit on this screen for hours does not change anything.  We must use the red X to close the player window.


      SAVE Course DONE Screen.png


      Then, back in the SkillSoft Publisher window, we see the runtime check failed.

      SkillSoft Publisher Error 01.png


      When we view the runtime error we see that the course did not send back a “finish” message to the LMS.  It reads, “There has been no communication between the player and the LMS, or the player did communicate but did not exit correctly (no finish command was sent by the player).”  Consequently, I cannot publish the course.

      SkillSoft Publisher Error 02.png



      Reading on the Adobe Authorware forums, I see discussions about issues within IE7 and IE8 that were not resolved in the Authorware Player after development on Authorware ended.  And I see a solution referenced as the iframe work around.  I do not know if this is the same issue.


      I am not an application engineer, nor programmer.  And, as I said, I have not used Authorware before.


      The SkillSoft tech support took my files and tried to upload the course.  They got the same result.  They have no solution at this time.


      I hope there is a solution which you can offer.


      Thank you in advance!