19 Replies Latest reply on Sep 24, 2015 4:51 AM by Willam van Weelden

    Cannot find Microsoft Word Installed on your system - RH10 - a solution

    thekofler Level 1

      I started receiving the error "Cannot find Microsoft Word Installed on your system" whenever I tried to generate printed documentation from RoboHelp 10. This occurred after I installed Open Office 3.4.1.

      Clicking the "Printed Documentation" option in the SSL pod generated the error. However, right-clicking on the "Printed Documentation" option, selecting "Properties", then clicking "Save and Generate" did work. Go figure.

      I am using Word 2007.

       

      All of these suggested solutions to resolve the problem didn't work, unfortunately.

       

      • Uninstalling and reinstalling Open Office with the correct option selected for file associations as suggested here:

      http://www.grainge.org/pages/authoring/printing/print_issues.htm#other_issues

       

      • Tried reinstalling the MPJ2DOC.DLL as suggested here:

      http://helpx.adobe.com/robohelp/kb/error-cannot-find-microsoft-word.html

       

      • Tried all the suggestions here:

      http://forums.adobe.com/message/4173839

       

      • Spent 2 hours with Adobe support (they were helpful but could not fix the problem) uninstalling and reinstalling RoboHelp, including reinstalling and registering the dll again.

       

      Finally I fixed the problem by following the simple solution here. I found that the problem was that the Word file associations were corrupt and you simply need to reregister word.

      http://www.word.mvps.org/FAQs/AppErr...gisterWord.htm

       

      Here's the solution in case the  link does not work:

       

      How to re-register Word when problems crop up opening files

      Article contributed by Cindy Meister Cindy's web site

      If you find that Word files do not open in the desired version of Word when you double-click them in Windows Explorer, or that when opening them from the Desktop or Explorer, a series of messages appear claiming that the file cannot be opened, such as:

      Cannot open C:\My
      Cannot open "Documents\The
      Cannot open "Test.doc"

      .. you need to re-register Word.  To fix the problem:

      Word 97 and above

      1. Click Start | Run (bottom- left corner of your screen).
      2. In the Open box, type:
      3. winword /r

        and press Enter. Note that there is a space before the forward slash

      Word 95

      1. Locate the file winword.reg on your system
      2. Double-click it to re-register Word

       

      Hope this helps anyone else who has struck this problem.

      Cheers Mark