10 Replies Latest reply: Aug 27, 2013 5:27 AM by Dpakch RSS

    Adobe Reader has stopped working

    doggatas

      After 6 months of solid use i.e no crashes etc... Adobe Reader (10.1.3) across all 20 XenApp 6.5 has stopped working. After opening for 10 seconds (either PDF file or application directly) reader crashes with the error in the title (the generic windows crash dialog box)

       

      There have been ZERO modifications (patches, updates etc..) to the XenApp servers in the past 4 weeks. It doesn't matter if it is opened directly off the server (RDP - Local admin) or a user inside a Citrix session. New profile doesnt help either. I could understand 1 server crapping out and having to uninstall/reinstall but 20 all at once?? Something more central has occured. Even the disaster recovery xenapp servers (of which no one logs onto) are not working.

       

      Anyone else expericing this issue?

        • 1. Re: Adobe Reader has stopped working
          Ashen.NZ Community Member

          We had a number of customers reporting Adobe Reader 10.1.X crashing 30 seconds after opening a PDF in Adobe Reader or Acrobat.

           

          The issue occurs when Adobe phones home to download:

           

          http://acroipm.adobe.com/10/rdr/ENU/win/nooem/none/message.zip

           

          Which look to be CERT updates.

           

          Block this using whatever filtering software or create a dummy DNS zone and the issue goes away.

          • 2. Re: Adobe Reader has stopped working
            doggatas

            Host file additional for acroipm.adobe.com will work yeh?? Just want to test on a few machines first.

             

            Do you know why all of a sudden this occurs?

             

            Host file solution works if you do not want to adjust DNS server (or dont have access to them).

             

            Oh yeh almost forgot, thanks heaps Ashen_NZ

             

            Cheers

            Doggatas

            • 3. Re: Adobe Reader has stopped working
              pwillener ACP/MVPs

              doggatas wrote:

               

              Adobe Reader (10.1.3) ....

              First thing I would try is to update Reader version, either to 10.1.7 or 11.0.3.

              • 4. Re: Adobe Reader has stopped working
                WollondillySC

                We were having the same issue here in AU (mainly ARv11.0.02, but also some with ARv11.0.03 after we tried updating today)

                 

                After the acroipm.adobe.com URL was blocked, we had no further issues.

                 

                Thanks Ashen.NZ for this workaround. Not sure how an incorrect data download can conceivably break Adobe Reader for all and sundry, but it certainly seems to have done so!

                 

                Also - re-enabling the URL breaks AR again, so that certainly seems to be it.

                 

                Regards.

                • 5. Re: Adobe Reader has stopped working
                  Ecat@Echo

                  How did you block the "acroipm.adobe.com" URL?

                  Is it per machine base or something on a more global scale?

                  Possible to give more descriptive instructions?

                  My business wants to find out the cause first rather than just installing the update 10.1.7 across hundreds of machines.


                  • 6. Re: Adobe Reader has stopped working
                    WollondillySC

                    Hi Ecat@Echo

                     

                    The easiest way for us was I blocked access to acroipm.adobe.com in the organisation's web filter for all users. In our case, I just had to classify the URL as a security risk, and that category was already blocked for user group.

                     

                    I'm just trialling setting up a dummy domain zone in our DNS server as well, (only bypassed users are affected anyway, but I'm trialling that).

                     

                    Will report back.

                     

                    EDIT - Creating an internal DNS zone works fine - the program looks at the internal DNS zone, can't find the file, and thus doesn't download the corrupted XML file.

                     

                    Regards.

                    • 7. Re: Adobe Reader has stopped working
                      doggatas

                      I blocked it by adding an entry into the "hosts" (C:\Windows\System32\Drivers\etc\) file of each of our Citrix servers, adding this entry resolves the issue instantly. Wasn't overly time consuming (amend one and copy and paste to the others using robocopy) as we don't have too many Citrix servers (20).

                       

                      If you're running a physical desktop solution updating the host file on each desktop might prove time cosuming and a lot of hit and miss. If you have an Internet Filtering service, block it there, that would be the one hit solution.

                       

                      DNS zone with a blank A record pointing to nowwhere as Ashen.NZ said.

                       

                      Plenty of ways to get around this one.

                      • 8. Re: Adobe Reader has stopped working
                        Udayabhanu Community Member

                        Thanks Ashen.NZ, this seems to be working for us. I have tried with Host file modification & it did the trick. Now we need to block this site!! But Adobe should be fixing this bug!!

                        • 9. Re: Adobe Reader has stopped working
                          doggatas

                          Good to hear DNS zone fixed it up.

                           

                          Seriously though, creating a DNS zone to prevent adobe reader from crashing. Is BS if you ask me.

                          • 10. Re: Adobe Reader has stopped working
                            Dpakch Adobe Employee

                            Hi Everyone,

                             

                            This was a temporary glitch with our servers that has now been resolved. Please re-launch Acrobat/ Reader and let us know if you still face this issue.

                             

                            Thanks for your patience.

                             

                            Regards,

                            Deepak