17 Replies Latest reply on Sep 12, 2013 2:28 AM by stekker

    ideoSpaceBehavior

    stekker Level 1

      hi,

       

      I'm using CS6 for a couple of weeks now.

       

      I'm used to prepare my text in a indesign 'work'file before putting it into the 'book'file.

       

      when I copy and paste the text from my workdocument into my bookfile, I get crosses next to my used styles, meaning something is changed there.

       

      when I look what the message is, indesign tells me that there is something different with my IdeoSpaceBehavior between my 2 documents, although I copy and paste the text.

       

      there is no way that I can find a IdeoSpaceBehavior-option in my styles where I can switch it 'off' or 'on'.

      and I can't do a 'find and replace' because I don't know where to find the IdeoSpaceBehavior. where is that hidden???

       

      can anyone please help me, because I'm working with files in wich the styles mention a mistake, althought nothing changes when I 'ALT-click' on the style again to make the cross disappear. but when I have to do this for all the styles, in all the books I'm making... it's going to be a frustrating CS6-experience!!

       

      I hope you can inderstand my problem...

       

      thanks!

       

      karien

        • 1. Re: ideoSpaceBehavior
          Peter Spier Most Valuable Participant (Moderator)

          Googling ideospace behvior didn't turn up a lot, but a Wikipedia entry on OpenType hints that it might be font related, and have something to do with positioning.

           

          Are you usingg the same paragrah composer in both files? Are your styles based on other styles?

          • 2. Re: ideoSpaceBehavior
            stekker Level 1

            hi peter,

             

            thanks for your reply.

             

            1) I checked the paragrpah composer and this is the same in both files.

            2) the styles are NOT based on another style. (no paragraph style)

             

            I have this for all the books I'm working in. in those books I used completely different fonts; post script, true type and open type fonts...

            in all the files, the same message appears...

             

            even when I reset my basic paragraph to 'standard', it doesn't solve the problem...

             

            I always import the paragraph and text styles from an existing book file, into my workfile to put another language in.

            our company buys book files from publishers abroad. I use their lay-out to put dutch text in it.

             

            does this giv you a clue?

             

            greets,

            karien

            • 3. Re: ideoSpaceBehavior
              Peter Spier Most Valuable Participant (Moderator)

              I'm afraid not really. Wy not save the working files as finished copies and just add them to the Book?

              • 4. Re: ideoSpaceBehavior
                stekker Level 1

                I'm afraid it doesn't work that way...

                 

                this is how I work:

                I get the finished (already published) book files as (let's say) an english indesignfile from a publisher who sold the rights to publish his book in dutch.

                I get the dutch translation from a dutch translator as a Wordfile.

                 

                I open the finished english book files and change the language for all the styles into dutch.

                 

                I open an empty workfile and import the wordtext into a blanc A4-file.

                then I import all the styles from the english book so I can do some typesetting in that workfile to make the dutch version look identical to the english version.

                 

                then I cut my dutch 'styled' text from my workfile and paste it into the english bookfile. and so, page after page, the english book becomes a dutch book.

                 

                Am I the only person who works this way???

                 

                greets,

                karien

                • 5. Re: ideoSpaceBehavior
                  Peter Spier Most Valuable Participant (Moderator)

                  I don't do translation work, so I can't comment on the workflow, but I understand what you are doing. I suspect the style override indicator is caused by a difference in the localization of the version used to create the original file and your version. You might see that in the file history for the original if you hold down the Cmd key on Mac or the Ctrl key on PC and choose About InDesign from the InDesign or Help menu, as appropriate.

                   

                  I don't think this is a serious error. You could try an export to .idml (see Remove minor corruption by exporting) but I don't think it's actually any sort of curruption. It would probably disappear if you run find/change for the style and reapply the same style.

                  • 6. Re: ideoSpaceBehavior
                    stekker Level 1

                    it's true isn't a serious problem. but it looks awfully unprofessional when all the styles "seem" to be wrong.

                     

                    when I do a find/replace and apply the same style again in the final version, they all disappear indeed.

                    but what a waste of time...

                    for all the books I have to make in these coming years...

                    my books contain loads of styles.

                     

                     

                     

                    the .idml-version doesn't solve the errors...

                    • 7. Re: ideoSpaceBehavior
                      Peter Spier Most Valuable Participant (Moderator)

                      As I said, I didn't think IDML would help. While I haven't seen this exact error/override, I have seen similar when working with files that originated in the Japanese or Middle East versions that are edited here on my US version.

                      • 8. Re: ideoSpaceBehavior
                        Joel Cherney Level 5

                        IdeoSpaceBehavior is obviously Ideographic Space Behavior. Peter is correct - something in your OpenType options that is not exposed in an English or Dutch UI for InDesign is set incorrectly and is causing the override.

                         

                        Am I the only person who works this way???

                         

                        Nooo, but I think that you might be better served letting some software do some of the work for you. My translation workflow, when I'm not letting something like SDL or memoQ do the heavy lifting, is to have "clear all overrides" be one of my steps. I chronically make sure that my translated documents have as many frames threaded as possible, and I've mapped Clear All Overrides to a keyboard combo. So I only have to control-A control-alt-shift-NumEnter for as many stories as there are in a given book.

                         

                        All that copying and pasting is a lot of work, and if your hands are already on the keyboard then after control-V then a subsequent control-A followed by whatever keyboard shortcut you assing for Clear All Overrides should resolve it... iff your content is perfectly styled.

                         

                        Another possibility is that you could write a script (or get someone to write a script?) that alters the setting that is being overridden. While those settings aren't exposed in your version of ID, they're accessible via Javascript.

                        • 9. Re: ideoSpaceBehavior
                          Joel Cherney Level 5

                          I forgot to mention reasons that you'd be better off using something like memoQ. If you want to spend a few hundred euros on real TM tools, let me know and I can give you a few pointers for using such tools with ID.

                          • 10. Re: ideoSpaceBehavior
                            stekker Level 1

                            thanks joel for your reply,

                             

                            I now know that there is something different with the Open Type options, although when I compare both documents, they show identical Open Typesettings in the styles.

                             

                            I don't know if I can change anywhere else the Open Type options? I don't see an option in the general settings, only in each style.

                             

                            when I copy my work-text entirely into my book (on the pasteboard), then I "clear overrides" there, and after that, I copy the entire text back into the workfile, the overrides are gone.

                            but! when I paste some text into the book again, the override appears AGAIN! grrrrr!

                             

                            the books I'm working in are not text books, but childrens books with loads of captions, sidetexts etc.

                            it means I would have to clear overrides for every frame on the page (sometimes that's between 10 and 30)...

                             

                            it's a pitty that I can't write a script to solve this for me. I don't know anything about Java. and I don't have a few hundreds euro to buy an extra program... I would like that indesign works properly, without giving me extra costs or extra shortcuts...

                             

                            • 11. Re: ideoSpaceBehavior
                              Joel Cherney Level 5

                              It's a pitty that I can't write a script to solve this for me. I don't know anything about Java. and I don't have a few hundreds euro to buy an extra program... I would like that indesign works properly, without giving me extra costs or extra shortcuts...

                              You're right; it's a pity. Even if you documented your case fully and presented a perfect bug report, you're using a version of InDesign for which Adobe will most likely not issue bugfixes. Bah humbug.

                              I don't know if I can change anywhere else the Open Type options? I don't see an option in the general settings, only in each style.

                              There is  - if you click the button for the flyout menu on the toolbar, or the button for the flyout menu on the Character panel:

                               

                              OT.png

                               

                              but that won't help you, because your OT options won't have the same options as the CJK version that has the controls for this behavior. (That's assuming it's even exposed in the CJK UI at all). And we still don't know if this is a bug in the versions of ID that are making the books you're translating, or - far more likely in my opinion - a bug in the Dutch localization of InDesign.

                               

                              I am a very slow & clumsy scripter, but if you send me a couple of sample files I will see if I can gin up a script to toggle the behavior that is causing your override. I think I can recycle other scripts I've written to toggle other complex script OT features for other languages. PM me with a download link to your files, and if possible provide a screenshot or writeup of the exact override. (Hopefully in English, but if it's only in Dutch, it's okay, the guy who I'd ask for scripting help is Dutch himself )

                              • 12. Re: ideoSpaceBehavior
                                David W. Goodrich Level 3

                                I'd guess this isn't an Opentype feature, but rather a separate feature of paragraph styles definable in CJK versions of InDesign, some of which go back at least as far as IDCS: the old TechArt/TransPacific templates use some, making them visible in western-language ID in the Style Settings window of the Paragraph Style Options' General tab (where they cannot be adjusted).  The boolean value "TreatIdeographicSpaceAsSpace" apparently first appeared in InDesign's Scripting DOM with CS5.  I don't read Japanese, but Googling the term led to what I take to be a list of the "No paragraph style" settings for Japanese ID; this gives this settings' default value as false, but more interesting is how many others there are; for example, there are seven settings just for Warichu.  A little Javascript to zap "TreatIdeographicSpaceAsSpace" might seem pretty simple to write, but is that the only one causing problems?

                                 

                                How can pasting from the pasteboard bring back to life paragraph-style features killed on the pasteboard?  The notion strikes me as far-fetched, but if pasting re-applies paragraph styles based on [No Paragraph Style], then perhaps the latter somehow preserves default settings from CJK ID.  It might be worth making your own "MyBasic" paragraph style, applying several styles based on that, and then seeing if that process puts a stake through the heart of any un-dead options.

                                 

                                You say passing through IDML doesn't work.  IDML files are really Zip archives under another name, so you might find a clue if you change a duplicate's filename from *.idml to *.zip, un-zip it, and then poke around the various component files.  Note, however, that re-Zipping the components is a pain because you must ensure the right one comes first to keep the altered Zip archive from being a dud once re-named *.IDML.  The older INX format is simpler, so if you have IDCS4 handy you can export a file to that format, and look at its contents directly with a text editor, which might yield some clues. (I've done that to zap XMP:mmHist metadata that IDCS4 can't touch.)  Of course, if you have IDCS4 it would be simpler to try "washing" a file through INX to see if that made any difference.

                                 

                                David

                                • 13. Re: ideoSpaceBehavior
                                  stekker Level 1

                                  hi joel,

                                   

                                   

                                  another chapter in the overrides. I started a new book and I got an extra message now. It's gettting from bad to worse...

                                  I'll send you some of my documents. but I want to give you this info first.... kDiacVPosOTFrom Baseline...

                                  it's not the first time I see this. I'm working in a DIN-font now which is a POSTSCRIPT-font, not a Open type.

                                   

                                  I did the same thing as ever... importing all the styles from the original bookfile into my workfile...

                                  when I compare, everything looks the same...

                                  also the options that you gave me in the screenshot above...

                                   

                                  hopeless hè?

                                   

                                   

                                   

                                   

                                  IMG_0670.jpg

                                  • 14. Re: ideoSpaceBehavior
                                    Joel Cherney Level 5

                                    I think you're right, David, on exactly what IdeoSpaceBehavior represents. Unfortunately, I can't find it (yet) in the handy John Hawkinston + Theun De Jong automagically generated JS reference at jongware.mit.edu.

                                     

                                    On the other hand: diacritic positioning refers to how far the diacritic marks are from characters in Arabic. This is left over in the source file from something related to Arabic. And I found it in the JS reference in seconds:

                                     

                                    http://jongware.mit.edu/idcs6js/pe_DiacriticPositionOptions.html

                                     

                                    So I am pretty sure that I could write the script that would fix this in a single sleepless night, bouncing the baby in one hand and writing javascript with the other.

                                     

                                    But switching hats from Javascript hobbyist to localization pro: The problem here is that you're going to be accepting book files for translation from a variety of sources, right? Each source is going to have its own funky bits that are going to mess up your workflow with some kind of override. So trying to fix this by fixing the individual overrides is insane. I'd do it for you - each time your publisher bought a new book from a new source, there would be the possibility of a new kind of override, which would mean a new minimum charge paid to me , or a new post in the Scripting forum asking for more help.

                                     

                                    If I understand your workflow correctly, you are one of us - people who like to deliver files with no overrides whatsoever, right? You don't have a single instance of manual formatting anywhere in your whole book? Then all you need is a script that clears all overrides everywhere with one double-click. If I'm right, then that is easy. If I'm wrong - if you want to remove the funky bits that refer to Arabic, but you need to leave your own leading or justification overrides in place - then it's much harder.

                                    • 15. Re: ideoSpaceBehavior
                                      David W. Goodrich Level 3

                                      Hi Joel,

                                       

                                      Googling <"treatIdeographicSpaceAsSpace" site:http://jongware.mit.edu> found bunches of locations, though in fact I just clicked down from the top to text and paragraph, and then searched for "ideo".  The site OS-X-10.7 InDesign-CS5 ScriptingBridge Support offers a search box, which turns up a score of places the term appears (including under Character, where I might not have looked).

                                       

                                      I remain intrigued by the idea of killed-off options coming back to life on passing through the clipboard.  I see over on the ID Secrets forum that David Blatner suggested exporting to Tagged Text and re-importing to a new file as another way to clean up oddities.  I see that in IDCS4 at least, placing ID Tagged Texts offers very few import options (though of course some other kinds of importing let you choose between existing and imported styles).

                                       

                                      David

                                       

                                      David

                                      • 16. Re: ideoSpaceBehavior
                                        Joel Cherney Level 5

                                        Gah. I just searched for IdeoSpaceBehavior. It is a bit of a leap from the wording of that override to the generic settings of No Paragraph Style, but I think your logic is sound, and that strekker ought to give your experiment a try.

                                         

                                        I suspect that export to Tagged Text and re-import would kill off this bug. It's still a workflow-killer, though. Significantly harder than simply clearing overrides.  I do wish that Adobe would announce its willingness to extend bug fixes to CS6.

                                        • 17. Re: ideoSpaceBehavior
                                          stekker Level 1

                                          hi all!

                                           

                                          I try to follow your technical advices, but as a Dutch girl, it's not always that simple for me.

                                           

                                          I want to add that I'm very thankfull for your help, but I don't have the money to let you write a script for me. I suspect that takes hours and hours, and the problem is indeed different for each new book I get...

                                           

                                          I do regret that I bought CS6, because I tried exactly the same thing, with the same files in CS5.5 and there is no problem AT ALL...

                                           

                                          it's the first time that I bought an CS-version in my own language. I always worked in the english version. I bought in on the Adobe-site and wasn't at that time aware that I ordered this in Dutch. stupid of me...

                                           

                                          now, my only question left is... is there a possibility to swop my version? I paid for the dutch CS6 - is there a possibility that Adobe gives me an English version instead??? I didn't want the dutch version in the first place. and now that I see that this a bug which won't get fixed (without extra costs), then I don't want to continue working in this dutch version anymore...

                                           

                                          can you advice me on this part? (now I think of downloading a trailversion in english, just to see if the same things happen there...)

                                           

                                          just for those who are interested: I put 2 examples files in my drop box (see link below):

                                          1) is the original bookfile in english (straight from the foreign publisher) I added a dutch layer and there you can see the text with the overrides

                                          2) is my workfile in which I imported the styles from the english book.

                                           

                                          I even didn't bother to change the language, just to exclude the fact that it has nothing to do with that.

                                           

                                          and Joel... to be honest... I also do some manual formatting... shame on me... it happens that I use a style for a title, for example, to use on the copyrightpage and bring down the fontsize... without making an extra style there...

                                           

                                          big sigh...

                                           

                                           

                                          file://localhost/Users/kariensticker/Dropbox/Public/override%20problems%20in%20CS6/