6 Replies Latest reply on Mar 14, 2014 7:42 AM by MichaelF

    After Effects CS4 crash on start-up: "Sweetpea failure"


      Hi folks,


      this is my first post here in this forum, so I send best wishes to you all.

      Here is the problem I am facing since today.


      I am running CS4 Master Collection with the latest updates on my 64Bit Windows 8.1 Pro machine which is also up to date.

      The hardware I am using is the following:

      • Intel Core i5-4670K @ 3.40 GHz
      • 16GB RAM
      • NVIDIA GeForce GTX660 running driver version 335.23
      • Realtek Audio Card (on mainboard)
      • 1x SSD for WIN and PROGs
      • 1x 10000RPM HDD for footage and data
      • 1x RAID 0 consisting of 2 HDD for working files and cache


      The setup worked great. Then I installed Mocha AE 3.2.1 which worked as well fine and did not interfere with the performance of CS4.

      But after installing the "mocha 3D track importer for AE 1.1.0" plugin from Imagineer Systems, After Effects did not start anymore, stopping with the statement:


      "After Effects can't continue: Sweetpea failure (48 § 58)"



      This is what I already tried:

      1. deleting the mocha 3D track importer Plugin
      2. restarting Windows
      3. stopping Kaspersky Anti Virus
      4. uninstalling After Effects followed by a reinstall
      5. uninstalling whole CS4 and running the Adobe Clean Script
      6. reinstalling CS4 in clean Windows boot
      7. uninstalling Mocha AE 3.2.1
      8. reinstalling Mocha AE 3.2.1
      9. performing an extended Google and Adobe Community Search, but:
        1. this problem seems to happen not quite often to others
        2. the solution in this thread is not available anymore and my audio drivers are setup fine
        3. solutions in further threads are for MAC-OS only


      I am actually running out of ideas as even reinstalling all relevant software - except OS - did not solve the problem.


      Does anyone in the community have an idea on that subject?

      Thanks a lot for any help and


      best regards,


        • 1. Re: After Effects CS4 crash on start-up: "Sweetpea failure"
          Todd_Kopriva Level 8

          How, exactly, did you uninstall the mocha plug-in? It is very likely that you did not successfully uninstall it, since the error message that you're getting indicates that the application is attempting to load an incompatible version of a plug-in.


          BTW, Windows 8.1 is not a supported operating system for After Effects CS4.

          • 2. Re: After Effects CS4 crash on start-up: "Sweetpea failure"
            MichaelF Level 1


            thanks for your reply.

            I deinstalled it by the opposite way to the installation process:

            I removed the Plugin file from the folder (C:\Program Files (x86)\Adobe\Adobe After Effects CS4\Support


            Well, now I copied the plugin file back into that folder: no help....


            I did not know about the not supported OS as Microsoft states that Win 8.1 shall be compatible with CS4 according to their website.

            • 3. Re: After Effects CS4 crash on start-up: "Sweetpea failure"
              MichaelF Level 1

              Is there a way to get a log from AE about the start-up so as to receive a hint what is actually going on?


              Best regards,


              • 5. Re: After Effects CS4 crash on start-up: "Sweetpea failure"
                MichaelF Level 1

                Thank you Todd for your effort.

                Well, I fully understand and respect that Adobe does not grant any liability for CS4 under Win8 as they made the effort to develop and introduce newer releases of their software (namely CS5, 5.5, 6 and now CC).

                As with that CS4 gets a little sign at the toe saying "deprecated" - which in fact is totally legitimate because their might be no capacity to thorougly test it.


                But: just by saying that it will definitely run under Vista and it is not tested for reliability on Win8, it does not mean that it won't run under Win8.

                In fact: Microsoft itself grants, that this specific software will be compatible with their OS and I may assume that my previous experience and that of those many other users running the combination happily, shows that CS4 is such a great product that it does its job stable on Win8 which is not the OS it was designed for.


                My practical experience on that, having used CS4 on Vista and Win 8.1 both, moreover showed that it was horribly unstable under Vista and ran absolutely stable on Win8.1 till - well, yesterday.


                Back to the topic: I do cast doubt on the theory that this specific issue, I explained above, is caused by incompatibility with Win8.1, that is because:

                • if it was related to Win8, many other users would have reported that issue
                • After Effects worked fine and stable under Win8 for quite a time till yesterday
                • all other Applications that I use from the bundle cause no trouble at all


                To find back to the starting position where all the applications worked fine, I would like to know if you might suggest any troubleshooting - except buying a new Software package.

                There might an option to turn on some kind of logging to see, what AE is doing until it halts, but I actually do not know how and where - so maybe you have more information on that.


                The only thing I could realize at the meanwhile is, that by the time AE throws the Exception it shows the progress message "Cleaning up... Tracker Controls" on the splash screen in the background. This might be a hint to the previously used plugin from Imagineer.

                Do you have suggestions how to savely remove a plugin like that?


                I thank you a lot and send

                best regards,



                • 6. Re: After Effects CS4 crash on start-up: "Sweetpea failure"
                  MichaelF Level 1

                  Ok, so a little update:


                  I realized that after reinstalling CS4 I did not install the After Effects 9.0.3 update.

                  So I did now and the error message on start-up changed to:


                  Could not load Plug-In 'c:\program files (x86)\Adobe\Adobe After Effects CS4\Support Files\Plug-ins\Effects\Tracker Palette.AEX'    (126)

                  (48 § 46)


                  Well, if I move the plugin file away from the Folder, AE starts and runs fine but I do not know what the matter is with "Tracker Palette.AEX".

                  After moving the file back into its folder, same error message appears on start-up.


                  Any suggestions?


                  Best regards,