6 Replies Latest reply on Aug 25, 2014 4:10 AM by PaulMcH33

    "Application has been blocked from accessing graphics hardware"

    PaulMcH33 Level 1

      Hi, Im trying to run After Effects CC on my laptop with Windows 8.1 (64 bit).

      I have been getting constant crashes while I am working on the project where the program will suddenly freeze and an error will

      show up in my toolbar saying "Application has been blocked from accessing graphics hardware". Once I close the program

      through task manager it goes to a BSOD and Im forced to restart.


      This is driving me nuts as I have tried many things and cannot seem to resolve this issue. I have been on the phone with technical

      support several times already and each time they seem to suggest 'easy' solutions to get me off the line as soon as possible that have not  helped so far.

      For example, the first time I called, they told me to move all project files to the local disk as I was working off a network (there are other pc's

      at my office working off the same network with same speed and I've worked over a network for many years on other pc's and never encountered this issue before).

      Another time they suggested that I check my BIOS settings to make sure that the dedicated GPU is being used primarily; I hade already explained to them it was.


      I have updated my Nvidia software to the latest Win certified drivers. I have also made sure that AE is using the dedicated GPU through setting it

      in the Nvidia control panel as well as when I right click and select the option each time I open the program.


      I have also read from a forum that this could be caused by something called TrDelay in the registry, which can cause the GPU drivers to restart if they dont respond

      for a few seconds, but I have tried extending and disabling this with no luck.


      I believe this issue has something to do with the fact that it is a laptop gpu and perhaps an issue with CUDA or Optimus.

      I also believe this is Windows 8.1 related. My work PC which has similar specs and exact same software, except running Windows 7 has never

      had this issue. I should also mention I have received the same error twice now while working in Photoshop (on the laptop).


      Please could you provide some advice or insight into this issue as it is preventing me from working and I have had no luck with Tech Support Call Center.

      Thanks in advance for your help.




      My Specs:


      Asus N56JR-EH71 Notebook

      CPU: 2.4GHz Intel Core i7-4700HQ (Haswell)

      RAM: 12GB DDR3

      STORAGE: 256GB Adata SSD

      GPU: Nvidia GTX 760M