21 Replies Latest reply on May 15, 2018 7:40 PM by crahol


    PolarPaul Level 1



      I downloaded an e-book from lulu.com yesterday.  It was an .acsm file, which forced me to install Adobe Digital Editions 2.0 in order to view.  I installed it without authorizing and browsed the book for a few minutes then turned off the program.  Later I returned to read it but there was a message about some licence key being broken or something, with E_AUTH_BAD_DEVICE_KEY_OR_PKCS12 in the error message.  I tried to authorize ADE to see if it would help, but it gave me a message saying "Digital Editions encountered an error on the activation server", with the familiar E_AUTH_BAD_DEVICE_KEY_OR_PKCS12 code.


      I tried removing the book from the library and reimporting it, but now it won't even do that without the same error message.  I've tried deleting the .acsm file and redownloading it, unistalling ADE and reinstalling it, made sure the firewall allows acces to the internet, and keep getting the same message.  I'm running on Vista.  It works with DRM-free .pdf's I have, but I can't download any of the sample books on Adobe's website to test further because the server doesn't respond.


      Any ideas?