5 Replies Latest reply on Apr 15, 2008 7:40 AM by hml398

    Old Pages Giving Errors

    hml398
      We recently redesigned a coldfusion website. We have a custom 404 page that works great but only for pages that never existed. If the page used to exist, the user gets an error messages (that isn't pretty like the error messages are for everything else) that says that the old include file for the header can't be found - which is can't because it doesn't exist but neither does the page that says the include doesn't exist. I am confused how the server is serving up pages to fail when the pages themselves don't exist. We are running IIS on Windows 2003 - CFMX7. Any ideas???
        • 1. Re: Old Pages Giving Errors
          kodemonki Level 1
          I'm a little confused about what you mean. The error page shows that a file that was included in a file (neither of which currently exist) does not exist?

          In what way are you finding that a page does not exist currently but it used to?
          • 2. Re: Old Pages Giving Errors
            Level 7
            hml398 wrote:
            > We recently redesigned a coldfusion website. We have a custom 404 page that
            > works great but only for pages that never existed. If the page used to exist,
            > the user gets an error messages (that isn't pretty like the error messages are
            > for everything else) that says that the old include file for the header can't
            > be found - which is can't because it doesn't exist but neither does the page
            > that says the include doesn't exist. I am confused how the server is serving
            > up pages to fail when the pages themselves don't exist. We are running IIS on
            > Windows 2003 - CFMX7. Any ideas???
            >

            Have you tried clearing the ColdFusion cache? There could be a compiled
            version of the CFML file that still exists in the cache depending on the
            CF Administrator settings.
            • 3. Re: Old Pages Giving Errors
              hml398 Level 1
              I have cleared both IIS cache and CF cache.

              I literally mean that a page that does not exist any longer - the file and the directory have been removed in the redesign - if you go the URL - CF returns an error message saying that the include file can't be found

              Could not find the included template /header.cfm which is correct but then neither does the page that it is reading from. It has been deleted - people are coming to those links from old Google search results.

              I look at the path under the CF_TEMPLATE_PATH variable and the file does not exist! It is maddening.
              • 4. Re: Old Pages Giving Errors
                Kling
                Have you had any luck in fixing this?
                We just renamed a directory and wrote the 404 page to redirect any bookmarks. But it's doing the same thing: going to the page that used to exist and throwing an error. How do I clear out the caches?
                • 5. Re: Old Pages Giving Errors
                  hml398 Level 1
                  Sorry - it is still doing it. We are moving to new servers this month so I am hopeful that will finally solve the problem. Let me know if you get an answer - it is VERY annoying...