2 Replies Latest reply on Apr 10, 2008 2:44 PM by prwirk

    Flash Remoting Error

      I am trying to get Flash Remoting working on my local machine and keep getting the following error when I run the compiled .swf file with the RemoteObject reference in it:

      faultString:'error' faultDetail:'NetConnection.Call.Failed: HTTP: Failed

      Can anyone help? I do get a blank page when I navigate to, not an 404 error. I'm completely stuck at this point and don't know what else to do!
        • 1. Re: Flash Remoting Error
          SujitG Level 2
          can you please make sure the end-point URLs in the services-config.xml/remoting-config.xml are proper.

          Hope this helps.
          • 2. Re: Flash Remoting Error
            prwirk Level 1

            Here is my services-config.xml file currently:

            <?xml version="1.0" encoding="UTF-8"?>

            <service id="coldfusion-flashremoting-service"

            <adapter-definition id="cf-object" class="coldfusion.flash.messaging.ColdFusionAdapter" default="true"/>

            <destination id="ColdFusion">
            <channel ref="my-cfamf"/>
            <!-- define the resolution rules and access level of the cfc being invoked -->
            <!-- Use the ColdFusion mappings to find CFCs, by default only CFC files under your webroot can be found. -->
            <!-- allow "public and remote" or just "remote" methods to be invoked -->

            <!-- cfc property names -->
            <!-- Query column names -->
            <!-- struct keys -->


            <channel-definition id="my-cfamf" class="mx.messaging.channels.AMFChannel">
            <endpoint uri=" http://{server.name}:{server.port}{context.root}/flex2gateway/" class="flex.messaging.endpoints.AMFEndpoint"/>

            <target class="flex.messaging.log.ConsoleTarget" level="Error">
            <prefix>[Flex] </prefix>



            I've also tried with the end-point defined this way:

            <endpoint uri=" http://localhost:8500/flex2gateway/" class="flex.messaging.endpoints.AMFEndpoint"/>

            and I get the same error. When I use IE, I get an 404 error rather than just the HTTP failed. A colleague of mine installed with the same configuration and hers works fine. Also, I'm using CFMX 7.0.2 with Flex 2. I also have Flex3 and used to have ColdFusion 8 on my computer as well. I have uninstalled CF 8 to and reinstalled CFMX 7.0.2 to see if that made a difference but it did not.

            Any help anyone can provide would be greatly appreciated!