3 Replies Latest reply on May 21, 2008 9:59 AM by Catfish Tales

    Cannot Exit RH6

    Catfish Tales Level 1
      ACTION: In RH6 HTML, in the menu bar, I click File then I slide down and click Exit.

      EXPECT: When I do that, I expect the application to exit (as it has done countless times).

      REALITY: Reality is that I get a pop-up message (The Microsoft JET Database Engine could not find the input table or query 'Image'. Make sure it exists and that its name is spelled correctly.) I acknowledge the message by clicking OK (there is nothing else to click). Then I attempt, once more, to exit. Each attempt produces the same results. I cannot exit.

      COMMENT: I searched microsoft.com and found two related articles.

      QUESTION: Does anybody understand the issue here and know how to resolve it?
        • 1. Re: Cannot Exit RH6
          RoboColum(n) Level 5
          RH using a MS access database. What is less sure is what exactly caused the problem. Is this related to one project? If so, what had you done to the project immediately prior to the problem. Had you renamed the project or anything like that.

          Anyway, it looks like you have some sort of access database corruption problem. You could start by deleting the project's .cpd file. If that doesn't solve the issue, open the project from it's .xpj file. You'll find instrauction on how to do this here.

          One final thing to check. Is the project on a network drive? If so, this is likely to be the cause of the database corruption and you ought to move all your source files to a local drive and leave them there.
          • 2. Re: Cannot Exit RH6
            Catfish Tales Level 1
            Thank you, Column, for tips and suggestions.

            I store all files locally. I didn't rename the project. During the past week, I updated 189 images. The system that I document uses a set of stylized buttons for user controls. Those buttons recently migrated to a new style. Despite the new style, the buttons remain the same size. Rather than redo all of my screen shots, I opened my screen shots one at a time and pasted copies of the new buttons over the old buttons.

            My editing procedure was rather simple. I configured RoboScreenCapture to be the image editor for RH. Then, I went to the Project tab, to the Images directory, and right-clicked an image for a contextual menu. In the menu, I clicked Edit. That launched the image in RoboScreenCapture. I would see which button needed to be replaced (e.g., Save). I had a copy of every button from production staff. I would open whichever button I needed in a separate instance of RoboScreenCapture. I would copy that button and paste into onto the original image and save. Image dimensions remained the same for each image.

            As far as I know, this is a valid means of updating images in RH. I have successfully done this in the past (though, only for 2 or 3 images at a time).

            I wonder if the name of the Images folder is the issue here. Perhaps, it became corrupted while editing all of these images? Even if that is the case, I cannot imagine how to fix it other than using Access. Even then, that sounds like a long shot. Unless another member of the forum has other ideas, I will probably follow your advice (first, delete CPD file; if no joy, open project from XPJ file).
            • 3. Re: Cannot Exit RH6
              Catfish Tales Level 1
              Well, I got lucky. I hadn't attempted anything in RH since I posted yesterday. After Column's message, I tried once more to exit RH. Within seconds, RH was consuming 50% of my CPU and showing as Unresponsive in Task Manager. After 30 minutes like this, I terminated RH. When I restarted RH, I successfully opened my project.

              There are no "lessons learned" here (e.g., what caused the problem, which solution solved it) but I am operational again.