12 Replies Latest reply on Oct 29, 2017 10:36 AM by xmission

    Cannot execute script


      I am trying to use ExtendScript for the first time (with FrameMaker 11, from TCS 4), but the script cannot be executed (very basic script example from the  Adobe "Introduction to Scripting" guide).

      The error message says "Cannot execute script. : Target Adobe FrameMaker 11 provides no engine for debugging"

      I tried it with other applications of the TC Suite: same error message

      Do I need to install another application/module? What can I do to make it work?

      Thank you


        • 1. Re: Cannot execute script
          Klaus Göbel Level 3

          Hi Geraldine,


          welcome to the forum.


          you have to install ESTK (ExtendScript Toolkit).

          It has to be installed additionally.


          Then your debugging should run.

          • 2. Re: Cannot execute script
            Russ Ward Level 4

            Hi Geraldine,


            You should not need to install anything extra. Can you provide details on how you are attempting to execute the script? Are you opening it within the ESTK script editor, then running it from there?


            I have not seen this error before. I would try this:


            - Close all Adobe applications except FM

            - Open the script editor (File > Script > New)

            - Open the script

            - In the toolbar, make sure the target application is Adobe FrameMaker 11 and there is a green chain (link) icon.

            - Click the Run button (green arrow)


            I don't know if this will get you any further, but it might ensure the proper linkage to FM11.



            • 3. Re: Cannot execute script
              Russ Ward Level 4

              Klaus, I just saw your reply. I don't remember installing the ESTK. Is it a component in the regular FM installation?



              • 4. Re: Cannot execute script
                géraldinek58676583 Level 1

                Hi Klaus, thank you for the prompt reply.

                Actually ESTK is already installed on my computer (included in the basic install of the TCS 4 in Program Files (x86)\Adobe\Adobe Utilities - CS6\ExtendScript Toolkit CS6).

                I can launch ExtendScript Toolkit.exe without any problem. It is when I want to run the script (F5) that I get the error message.

                • 5. Re: Cannot execute script
                  Klaus Göbel Level 3

                  Hi Russ,

                  the first time I've installed FrameMaker withh ESTK (FM12), I had to select, that I want to install ESTK (as far as I remember).


                  Maybe it is dependant on the setup routine.


                  • 6. Re: Cannot execute script
                    géraldinek58676583 Level 1

                    Hi Russ,


                    I followed your instructions and get the same error message, but the chain icon never turns green:

                    1. I select Adobe FrameMaker 11 as target application: the link icon is broken (red),

                    2. I click on the icon: it turns grey (and the button becomes unavailable, I cannot click on it anymore).

                    3. After approximately 1 minute doing nothing, the icon turns red again by itself.

                    I tried to select an other target application in the list: I am first prompted to launch the selected application, and when the application is open, the same scenario occurs.

                    The icon is green only if I select ExtendScript Toolkit as target application.


                    • If I run the script while the icon is grey, I immediately get the "Cannot execute script. : Target Adobe FrameMaker 11 provides no engine for debugging" error message.
                    • If I run the script while the icon is red, it displays "no errors" in the status bar and automatically switches the icon to grey (but does nothing).
                      If I click again on "run", the same error message appears.



                    • 7. Re: Cannot execute script
                      Russ Ward Level 4

                      Hi Geraldine,


                      It seems clear to me that the problem is with the link between the ESTK and the target applications. Unfortunately, I couldn't begin to speculate what the problem might be. For those of us without this problem, the link happens automatically. I see a green link icon as soon as I start the ESTK editor.


                      Do you have the option to do a reinstall?


                      If this is not working out of the box, I would suggest that this may be an installation issue. I think Adobe provides free support installation issues, which is a reasonable practice.


                      When launching a script outside of the FM scope, you can add the following at the beginning to associate it with FM. Somehow, though, I think your problem is further up the chain and this will not help:


                      #target framemaker


                      I hope you can get this to work. ExtendScript is very cool. I regret that I am unable to solve your problem.



                      • 8. Re: Cannot execute script
                        géraldinek58676583 Level 1

                        Thank you Russ.

                        I will soon change computer so I will be able to do a reinstall in a couple of weeks. Hope this will solve the problem, I will keep you updated.

                        Thanks again for the reply.


                        • 9. Re: Cannot execute script
                          K.Daube Level 2

                          Geraldine, I do not want to discourage You - but I had the same problem for more than one FM-version.

                          I had reported this as a bug even for FM-10 — but noone could reproduce the situation. I thought it was due to my nonstandard installation (FM not on C:\.., but on H:\Adobe\FrameMaker.11en\AdobeFrameMaker11). But that wasn't the reason. The problem did not exist when I installed FM on the system of my wife (also Win7, but x32).

                          After installing last october on my new hardware (the old was used for 6 years) the problem did not exist anymore. I have not the slightest clue about the reason for the problem.

                          So it would be worth to check the situation on a different hardware.

                          • 10. Re: Cannot execute script
                            frameexpert Level 4

                            Try putting this at the top of your script and see what happens:


                            #target framemaker



                            • 11. Re: Cannot execute script
                              géraldinek58676583 Level 1

                              (I tried #target framemaker and this did not solve the problem)

                              Since then, I installed TCS4 on my new hardware and the error message does not appear anymore ... don't ask me why...

                              Same situation as K.Daube, I guess the hardware was the problem

                              Thank you all for your help


                              • 12. Re: Cannot execute script

                                Disable firewall, or write rule for it to allow extendScript communicate with apps.

                                In my case this was source of problem.

                                Firewall was blocked ports that was used by extenScript app