3 Replies Latest reply on Sep 1, 2016 9:54 AM by Vikram_k1810

    Invalid command 'JkIPRestrictionFile'


      RedHat 7.2


      ColdFusion 11 (64-bit)


      After installing hotfix 8, apache is not starting:

      Aug 30 16:08:27 web5vm httpd[2843]: AH00526: Syntax error on line 6 of /etc/httpd/conf/mod_jk.conf:

      Aug 30 16:08:27 web5vm httpd[2843]: Invalid command 'JKIPRestrictionFile', perhaps misspelled or defined by a module not included in the server configuration


      Anyone experiencing this issue?

        • 1. Re: Invalid command 'JkIPRestrictionFile'
          Vikram_k1810 Adobe Employee

          Hi Su,


          Have you tried recreating the connectors after installing the update? We have removed the IPRestrictions file in CF11 Update 3 and above. It must be defined in the Apache Web Server end in case your environment requires its use, but not on the ColdFusion end. I would suggest you to try recreating the connectors and see if this helps.




          1 person found this helpful
          • 2. Re: Invalid command 'JkIPRestrictionFile'

            That worked great, Thank you.


            This is how I recreated apache connection, let me know if there's anything I missed?


            1. Backup mod_jk.conf file and /opt/coldfusion11/config/wsconfig/ directory

            2. Remove mod_jk.conf file and /opt/coldfusion11/config/wsconfig/ directory

            3. Run wsconfig, here is the specific command I used:

            /opt/coldfusion11/cfusion/runtime/bin/wsconfig -ws Apache -dir /etc/httpd/conf/ -cfide /opt/coldfusion11/cfusion/wwwroot/CFIDE/ -bin /usr/sbin/httpd -script /usr/sbin/apachectl

            4. Additionally, had to change the file context for mod_jk.log file for selinux to allow access

            chcon -v --reference=/var/log/httpd/access_log /opt/coldfusion11/config/wsconfig/1/mod_jk.log

            • 3. Re: Invalid command 'JkIPRestrictionFile'
              Vikram_k1810 Adobe Employee

              Hi Su,


              It looks good to me.