3 Replies Latest reply on Feb 9, 2017 7:24 AM by texasslingers

    Adobe Digital Editions not responding


      When I try to download books now, I will get the acsm file downloaded as before, but when I try to open it in ADE, ADE will freeze and I will get a message that it is not responding.  I have checked to make sure it is not a firewall problem, (and I can download without problems), and I have made sure that the device is authorized etc...  Is anyone else having this problem, and if so can it be fixed?

      Thanks a lot

        • 1. Re: Adobe Digital Editions not responding

          I am also having the problem that ADE freezes and then shuts down. I have tried to uninstall and reinstall, unauthorize and reauthorize, download an older version, install a different browser ie Firefox and still no luck.

          • 2. Re: Adobe Digital Editions not responding
            janessaNM Level 1

            For a year I had 3.0 on my desktop, and then it stopped opening, so I had to use 2.0. On my new computer, 4.5 worked for 6 months, and now it doesn't. I've uninstalled and re-installed every version, and only 1.7 opens, but it won't read the acsm's that my library lends me.

            I'm down to one book on my Kobo, and it's not a good one!

            • 3. Re: Adobe Digital Editions not responding
              texasslingers Level 1

              Janessa, I have solved it with the help of my Library who forwarded my problem to Overdrive. Here is their response:

              Thanks for contacting OverDrive Support Services. I'm sorry you're having trouble with this. Please take the following steps to see if it corrects the issue:

              1. Delete the eBook from Adobe Digital Editions (ADE) and close the app.
              2. Search your computer for all eBooks and delete each copy you find.                
                eBooks are usually found in [My] Documents > [My] Digital Editions.
              3. Delete the contents of the tasks and failed folders in [My] Documents > [My] Digital Editions > restore.
              4. Delete your temporary internet files. This step is extremely important.
              5. Close and reopen your web browser.
              6. Try downloading the eBook again.

              Let me know if this works for you!