14 Replies Latest reply on Mar 14, 2017 9:48 AM by xmana

    Puppet Pin tool Error


      Hello! I have a problem with Afterr Effects CC 2017, especially with "Puppet Pin Tool". Everything is OK when I set 1st point. But when I set 2nd point I get Error: "After Effects - error: crash occurred while invoking effect plug-in puppet pin tool". It doesn't matter what format of picture I use. I get this error anytime I set 2nd point. My system is: AMD A8-7410 APU 2.2 GHz with AMD Radeon R5 M320 2GB, RAM 8GB. Windows 7, but I also have the same problem on Windows 10. There is no answers in the whole Internet. I think somebody can help me here.

        • 1. Re: Puppet Pin tool Error
          Dave LaRonde Level 7

          The puppet tool can be the ONLY effect applied to a layer -- and it has to be a bitmap layer, not vector.  Are these two conditions met?

          • 2. Re: Puppet Pin tool Error
            Mylenium Most Valuable Participant

            Without more details about your comp settings and the kind of footage you use nobody can tell you much. Often these crashes relate to "illogical" areas, meaning footage e.g. with many small holes that bring the algorithm that is supposed to calculate the deformations of the mesh down.



            • 3. Re: Puppet Pin tool Error
              xmana Level 1

              What more details about my comp settings you need? I use Windows 7 Home Premium with SP1 x64. For example I use this picture. I import it as a footage (I don't have any variants) and make a layer from it.Then I choose "Puppet Pin Tool" and set 1st point on wrist. Program do it's work and then i can see triangles covering my picture. Then I set 2nd point on elbow and the program at the moment crashes without any errors. If i choose random points even not on the picture, program crashes with error. It's the same with any other different formats and forms of pictures.Woody.png

              • 4. Re: Puppet Pin tool Error
                Roei Tzoref Adobe Community Professional

                1. make sure your software and GPU driver is up to date. you should be using 14.1, and for GPU driver see in the manufacturer (AMD) site

                2. try to reset your preferences - here's how: Reset After Effects Preferences


                if this still occurs there's something in your specific setup and I would waste no time and contact costumer service directly and have an agent run through the issues directly through remote desktop.

                • 5. Re: Puppet Pin tool Error
                  xmana Level 1

                  All my GPU and other drivers are updated. All drivers were got from official websites (AMD and Asus). I use 14.1 version of AE. Everything is updated, setup, reseted, prayed etc. Also I can say that I met this problem at first on Windows 10. Then I setup Windows 7 and, of course, at once setup AE CC 2017 14.1. So it is the cleanest program that my newest and cleanest Windows 7 had ever seen in it's short life. It was like a virgin. So, you understand, I think. But, as you recommended, I reseted preferences, updated ALL drivers, reinstalled AE. I can again reinstall Windows, if you want. But it is still giving me "ACHTUNG"-message. What can be wrong in my "specific setup"? Maybe I rebooted my notebbok several times, tried to match files as a puzzle or anything else. But, unfortunately, your "contsct costumer service" doesn't say nothing except "Go to the forum, nut." because there is no any point to contact with a magician who can something.

                  • 6. Re: Puppet Pin tool Error
                    Roei Tzoref Adobe Community Professional

                    In the contact costumer service link, when you exhaust the different options, you can see at the bottom "still need help? Contact us". You will be referred to a link with phone numbers and chat service. I have done this a few times myself.


                    Don't forget to update us on what fixed it (hopefully you will get sorted)

                    • 7. Re: Puppet Pin tool Error
                      xmana Level 1

                      As I said before I can't do it. In the contact costumer service it says to me: "Goooo too the foooruuum. Only forum can help youuu". So, if you don't trust me, I have a screenshot.Снимок.PNG

                      • 8. Re: Puppet Pin tool Error
                        Roei Tzoref Adobe Community Professional

                        the screenshot is very helpful, don't get mad or anything - I am just trying to help.


                        first time I am seeing this kind of message. are you using a paid version of CC? you should be signed in with your user and this option should be available to you. I wonder why it's not.


                        here is the number:

                        • 9. Re: Puppet Pin tool Error
                          xmana Level 1

                          Sorry, I'm not getting mad. Just trying to make this situation more funny than sad. I know that you are trying your best and I'm grateful. But also I have a one little problem. It will be quite difficult for me to speak with alive English person. I mean that my English is not so perfect and it will be VERY VERY VERY difficult for me and magician from support to understand each other(I write this letter with the help of translater and the poorest knowledges of grammar etc.). Also it will cost a lot because of roaming. I thought I can speak with a magician from live chat, but I can't:(  Maybe this option is not available because I'm from not-English-speaking country? Looks like I have to live with that problem or wait any other user who will find an answer in nearest future.

                          • 10. Re: Puppet Pin tool Error
                            Roei Tzoref Adobe Community Professional

                            I am from a foreign country too (Israel). are you on regular paid subscription? you should get the support you need, this is part of what you pay for.

                            • 11. Re: Puppet Pin tool Error
                              xmana Level 1

                              I should, I think. But even if it is a part of what I paid for I can't get it.(You saw the screen). I don't have any ways except forum(to make a call will take a tons of money). If the contact costumer service is the only way, so, I'm trapped.

                              • 12. Re: Puppet Pin tool Error
                                Roei Tzoref Adobe Community Professional

                                I will try to see if I can get someone to get to you, in the meantime:

                                1. try running the software as administrator (right click on the after effects icon and choose start as administrator)

                                2. try using previous version like 2015.3 Download/Install FAQ: How do I install previous versions of Creative Cloud Apps?

                                • 13. Re: Puppet Pin tool Error
                                  Marek Vosahlik Level 1

                                  Hi !

                                  I was dealing with the same issue lately and i have found this WORKING SOLUTION on reddit.com

                                  Enjoy, Marek Vosahlik



                                  by TimKurkoski Adobe Employee


                                  Does your computer use an AMD processor?

                                  We believe that this problem may be due to an incompatibility with certain AMD processors and the Intel math library used by the Puppet effect.

                                  What specific model of processor is in your computer? If possible, could you send me a .nfo file saved from the System Information application? (Press the Windows Start key, then type “msinfo32” and press Enter.)

                                  Does the problem still occur if you follow the steps below to set an environment variable? We believe this may work around the AMD-Intel compatibility issue. Please try this and let us know if it works.

                                  1. From the Desktop, right-click the Computer icon and select Properties. If you don't have a Computer icon on your desktop, click the Start button, right-click the Computer option in the Start menu, and select Properties.
                                  2. Click the Advanced System Settings link in the left column. In the System Properties window, click on the Advanced tab, then click the Environment Variables button near the bottom of that tab.
                                  3. Click the New button in the System Variables section.
                                  4. In the Variable Name field, enter: MKL_DEBUG_CPU_TYPE
                                  5. In the Variable Value field, enter: 4
                                  6. Click OK in the Environment Variables dialog.
                                  7. Click OK in the System Properties dialog.
                                  8. Restart your computer.

                                  This change may have an effect on other applications.


                                  • 14. Re: Puppet Pin tool Error
                                    xmana Level 1

                                    Oh, thanks! Yes, I have AMD. I have done everything you said and now it works!