5 Replies Latest reply on Jun 10, 2017 9:19 AM by Per Berntsen

    Lightroom crashes when sorting by filters (flag, star, colour, etc.) in develop mode!

    Buck_Stick Level 1

      I have been struggling with this for some time now and it makes editing nearly impossible for me to do.

       

      The strangest part is that I have had no issues up until now (it's been nearly a year), and now the issues are kind of on and off, it doesn't happen the same way every time.

       

      I normally import my photos in Library, then go through, picture by picture, flagging the ones I want to edit and ignoring the ones I don't, until I get through them all. Then, I click Develop mode and all works fine... Until I turn on filters and click sort by flagged. Then it all freezes up and says Lightroom has stopped working. Same thing happens if I turn on filters in library, and then click Develop. In fact, as I am writing this, I can't even enter Develop mode anymore.

       

      I read a bit about GPU acceleration being an issue for some people, but I would prefer not to disable GPU acceleration because then my photos come out slightly discolored blue, which is a problem in itself.

       

      I'd love to get this solved so I can get back to image editing, thanks!

        • 1. Re: Lightroom crashes when sorting by filters (flag, star, colour, etc.) in develop mode!
          Per Berntsen Adobe Community Professional

          Does everything work properly when you disable the GPU?

          Are you saying that your photos display differently inside Lightroom when you disable the GPU?

          Although I've never heard about that happening, I guess it could be caused by a bad monitor profile.

          Are you on Windows 10 by any chance?

          • 2. Re: Lightroom crashes when sorting by filters (flag, star, colour, etc.) in develop mode!
            Buck_Stick Level 1

            When I tried it towards the beginning of the issue it fixed the crashing in develop mode with filter enabled... However, I can't be sure if that was fixed by me disabling it or if it just was one of those off-times it worked.

             

            Currently, my whites display as blueish in the library tab, and correct in the develop tab. Disabling GPU acceleration causes the whites to stay tinted blue when I carry images over into develop.

             

            I would say you're on to something with the monitor profile because I've had a lot of struggles with monitor profile turning the whites blue in photoshop as well (I've finally gotten it to work normally now but that took a long time to figure out).

             

            I am indeed on Windows 10.

            • 3. Re: Lightroom crashes when sorting by filters (flag, star, colour, etc.) in develop mode!
              Per Berntsen Adobe Community Professional

              When Library and Develop display differently, it's always caused by a bad/defective/corrupted/incompatible monitor profile.

              And Windows 10 is known to install low quality profiles when doing updates. These profiles (that are supplied by monitor manufacterers) are suprisingly often defective out of the box.

               

              To fix the problem, at least temporarily, set the monitor profile to sRGB, or if you have wide gamut monitor, to Adobe RGB.

              Then you should ideally calibrate your monitor with a hardware calibrator, which will create a profile that accurately describes your monitor. Depending on your requirements (and your monitor), using a standard profile like sRGB or Adobe RGB may be good enough.

               

              Press the Windows key+R, type colorcpl in the box, and hit Enter.

              Add the sRGB (or Adobe RGB) profile, then set it as Default profile. See screenshot (from Windows 7) below.

               

               

              You should now have the same colors in Library and Develop.

              Updating your graphics driver may allow you to work with the GPU enabled.

              If not, it's no big deal, unless you have a 4 or 5k monitor.

              Most people see no performance increase with the GPU enabled, quite a few actually report worse performance with the GPU enabled.

              • 4. Re: Lightroom crashes when sorting by filters (flag, star, colour, etc.) in develop mode!
                Buck_Stick Level 1

                Okay, so I tried that but I couldn't add a profile, the button was greyed out. Anyways, I re-calibrated and now the colours are the same, however they appear to be slightly off still, just the same. It works for me temporarily. I guess I'll wait it out until they release an update for lightroom that may change something.

                • 5. Re: Lightroom crashes when sorting by filters (flag, star, colour, etc.) in develop mode!
                  Per Berntsen Adobe Community Professional

                  If the Add button was greyed out, Use my settings for this device was not checked.

                  Can you go back into the Color management dialog, and check that the profile you just created now is set as Default?

                  A Lightroom update will not fix your color problem, this is a Windows problem, although it might fix the GPU problem.

                  Did you make sure that your grahics driver is up to date?