3 Replies Latest reply on Nov 8, 2017 12:22 PM by rasterdan

    Robohelp topics have been removed from version control

    hedin1970

      We are using RH 2017 version control with three users. This morning one of the users noticed that all the topics he has created have been removed from version control. The folders are still there but they are empty (except for a .css file) and it is the same for the project on our local machines (all three). Has anyone else experience this? What would cause the files to be deleted w/o any of us specifically deleting them? We are currently working with IT to retrieve the files from our daily backup and hopefully that will be successful, but knowing the cause would be extremely useful.

        • 1. Re: Robohelp topics have been removed from version control
          Jeff_Coatsworth Adobe Community Professional & MVP

          Don't think that's a RH problem - sounds like an issue with your source control...

          • 2. Re: Robohelp topics have been removed from version control
            Captiv8r Adobe Community Professional & MVP

            Hmmm, seems odd that they would have been removed.

             

            Knowing how version control works, the actual content is typically in the Source Control database on the server. And there are copies on the local PC. And the copies are generally manipulated by using the read only flag.

             

            Have you tried using the "Get Latest Version"? I think that's what it's called. I may be remembering Microsoft Visual Source Safe. But I would think RoboSource Control would offer an identical feature but maybe named slightly different.

             

            The Get Latest Version should copy things from the Server database to the local machine. Assuming, of course, that the topics haven't been actually deleted.

             

            Cheers... Rick

            • 3. Re: Robohelp topics have been removed from version control
              rasterdan Level 1

              Not only do I have the same problem, I am having problems where a project is pulled from the Robo Source Control server and opened fine.  Close, reboot the printer and reopen the same exact project and it says it has been removed from source control, do you want to discontinue looking for the project.  So far, it seems to be happening mostly with one project in particular but we are getting quite frustrated.