4 Replies Latest reply on Sep 4, 2017 8:55 AM by RAM-Studio

    AE CC2017 not seeing any GPU in system ?

    RAM-Studio Level 1

      Hi. I recently upgraded After Effects to latest 2017 upgrade and now i can't even start it properly. It starts 1/10 times and when it starts it's not seeing any of GPUs installed in my system.


      I have Dual Xeon E5-2698v4, win10 64bit + 5 GPUs installed in system (1xTitan X (Maxwell), 2*GTX 1080 and 2* GTX1080Ti) with latest Nvidia driver 382.53. AE just reports NO GPUs at all ?


      Other programs (I use this machine for GPU rendering in Octane) work fine with all 5 GPUs and yet AE says i have none ???.


      I tried to reset AE prefs (holding on Alt+Shift+Ctrl) but not helped either. Most of time even starting AE leads to "not responding" splash screen and then i can't even kill AE.exe from Task manager (says Acess denied) so i need to restart machine to try again.


      Please help.




      P.S. Photoshop, Premiere, and Media encoder work fine on same workstation.




        • 1. Re: AE CC2017 not seeing any GPU in system ?
          Mylenium Most Valuable Participant

          It's simple: Your wild mix of cards only ever works with specifically adapted code and drivers via CUDA or OpenCL. AE being a dumb nut in this department it simply locks on to the primary GPU in the system and in your case that may simply not be compatible. Ergo the answer would have to be to fiddel with your driver settings. Not that it should matter much - even the GPU accelerated effects are severely limited in AE and you probably won't see much difference between CPU vs. GPU.



          1 person found this helpful
          • 2. Re: AE CC2017 not seeing any GPU in system ?
            RAM-Studio Level 1

            HI Mylenium, thanks for answer.


            Hmm, but it worked fine with 2*TitanX+2*GTX 1080 since CC2014, CC2015 and early CC2017, now with latest update on CC2017 and now when i removed one TitanX and added 2*1080ti and it got confused to the level that it won't even start properly.  Not sure what i can do to fix it now.


            That ASpeed GPU is on chip/motherboard GPU on this Asus Z10 MB i can't remove it 'coz MB is dumb to go to BIOS only with that GPU (D-sub connector) so evne if i disable it in BIOS i'd have problem go into BIOS next time and i'd need to reset BIOS battery to get it back to default.


            BUT that Aspeed was fine when i had 2*TitanX+2*1080 in system. Only thing i can think of now is to move TitanX from Slot 7 to slot 1 and hope AE will pickup somehow when PCI number changes ?


            I don't really need GPU acceleration much in AE but i can't even start it 9/10 times 'coz GPU sniffer is never finishing it's job so it's stalled on splash screen. Is there way to kill GPU sniffer somehow to prevent that loong booting time ?



            • 3. Re: AE CC2017 not seeing any GPU in system ?
              Kevin-Monahan Adobe Employee

              Hi RAM-Studio,

              Are you still facing this problem with your GPU? If not, let us know how you solved it. If so, please let us know so we can assist you further.




              • 4. Re: AE CC2017 not seeing any GPU in system ?
                RAM-Studio Level 1

                Hi Kevin,


                I'm able to start AE last month every time but to do that i had to remove all settings/confings and i've removed 2 GPUs from system and then started AE and then cleaned all configs.
                After that I've put back GPUs and currently it's still working. Boot time (from SSD) is still slow but at least it's not stalling at splash screen anymore.