19 Replies Latest reply on Jul 13, 2013 11:05 AM by Mark Mapes

    CS6 Doesn't See My Alphas Correctly

    Toomany3 Level 1

      When opening my CS5 projects in CS6, my video layers that have alphas now show black where it should be transparent. This is happening with several codecs and image sequences.

       

      What's up?

        • 1. Re: CS6 Doesn't See My Alphas Correctly
          Jim_Simon Level 8

          What happens if you bring the same footage into a new CS6 project?

           

          Have you tried playing with the Alpha settings under Modify>Interpret Footage...?

          • 2. Re: CS6 Doesn't See My Alphas Correctly
            Toomany3 Level 1

            I cannot find the solution to this and I can't understand how no one else is having this problem (at least I haven't seen any other posts on this).

             

            I render most all of my alphas out as DNxHDs. The alpha channel is showing as black in Premiere instead of transparent.  I have played with the Modyfy>Interpret Footage to no avail. I have tried it on 4 different computers.

             

            My alpha clips worked perfectly fine in CS5, but in CS6 the exact same project can't handle the alphas.

             

            I need some help with this. I'm stuck even worse now since I can't go back to CS5 with my project since I've already worked in CS6. (Or is there a way to downgrade my project back to CS5?)

             

            Any help would be greately appreciated. I'm supposed to render this out for a client today.

            • 3. Re: CS6 Doesn't See My Alphas Correctly
              Toomany3 Level 1

              I just discovered that it DOES work using the Quicktime/Animation preset for rendering form AE, but it does NOT work with DNxHD.  Hopefully this is the clue that one of you needs to piece it together for me. ???

               

              I do NOT want to use animation since I already have hundreds of clips already done in DNxHD with alphas. It would be a nightmare to redo all those.

               

              I have the latest DNxHD codecs I believe.  2.3.7.

              • 4. Re: CS6 Doesn't See My Alphas Correctly
                Wil Renczes Adobe Employee

                Do you have a sample clip you could share?  I'm curious why it worked in previous versions but not now...  are these QT wrapped mov files, btw?

                 

                Cheers

                • 5. Re: CS6 Doesn't See My Alphas Correctly
                  SteveHoeg Adobe Employee

                  This is a known bug that we were unfortunately not able to address before shipping. For now if you would like a temporary workaround please open up:

                   

                  C:\Users\{USER}\AppData\Roaming\Adobe\Common\MediaCoreQTCodecRulesCS6.xml
                  /Users/{USER}/Library/Application Support/Adobe/Common/MediaCoreQTCodecRulesCS6.xml 

                   

                  Then find the four lines containing ’AVdn’ that say decode. Change the decodefourcc at the end of the line from ’2vuy’ to ’argb’.

                  • 6. Re: CS6 Doesn't See My Alphas Correctly
                    Jim_Simon Level 8

                    Change the decodefourcc at the end...

                     

                    Now that's a solution that really shows the benefit of having Adobe personnel invest time on these forums.  None of us users are likely to ever have suggested this.

                    • 7. Re: CS6 Doesn't See My Alphas Correctly
                      Toomany3 Level 1

                      You're right about that, Jim!

                       

                      This is the kind of solution I was looking for!

                       

                      Adobe, surely this could be incorporated into a quick patch update?  I don't mind doing the work--it looks easy--but a 1kb update would be nice for everyone else who has been scratching their heads wondering what to do.   Either way, THANK YOU!

                      • 8. Re: CS6 Doesn't See My Alphas Correctly
                        Toomany3 Level 1

                        SteveHoeg wrote:

                         

                        This is a known bug that we were unfortunately not able to address before shipping. For now if you would like a temporary workaround please open up:

                         

                        C:\Users\{USER}\AppData\Roaming\Adobe\Common\MediaCoreQTCodecRulesCS6. xml
                        /Users/{USER}/Library/Application Support/Adobe/Common/MediaCoreQTCodecRulesCS6.xml 

                         

                        Then find the four lines containing ’AVdn’ that say decode. Change the decodefourcc at the end of the line from ’2vuy’ to ’argb’.

                        Well, I just got to trying this out and unfortunately it doesn't do anything. It's doign the same thing. 

                         

                        Here's the before and after pics of my XML file. I assuem I did it right. 

                         

                        The other two pics are of the exact same AE render with the alpha.  The first one is using the QT/animation codec, the second is with the QT/DNxHD codec.  Both work on CS5, but only the animation codec works in CS6.

                         

                        Any other suggestions?

                         

                        XML BEFORE:

                        xml before.PNG

                         

                        XML AFTER

                        xml fixed.PNG

                         

                        ANIMATION CODEC

                        x animation.PNG

                         

                        DNXHD CODEC

                        x dnxhd.PNG

                        • 9. Re: CS6 Doesn't See My Alphas Correctly
                          Toomany3 Level 1

                          Well, this works... sometimes. It's very strange that I change the XML file and things work for a while, but the next day when I start up the computer the XML file is changed back to the original settings. This happened after an update, which makes sense. But now it's happening without any updates, just on a computer restart.

                           

                          Any ideas?

                          • 10. Re: CS6 Doesn't See My Alphas Correctly
                            Toomany3 Level 1

                            Any news on this? I can't belive I'm the only one out there with this problem. I have installed CS6 on 3 computers to test out this problem and it happens on all 3.

                             

                            When I apply the "fix" above, the problem goes away until after a computer restart.    

                            • 11. Re: CS6 Doesn't See My Alphas Correctly
                              Jim_Simon Level 8

                              Any other suggestions?

                               

                              Don't use QuickTime.  Create AVI files using Lagarith or UT codecs.  They're both free, lossless, and both support RGBA.

                              • 12. Re: CS6 Doesn't See My Alphas Correctly
                                josephs51576386 Level 3

                                I had to just encode around 100 animations over again. Luckily I'm really good about keeping AE project files.

                                • 13. Re: CS6 Doesn't See My Alphas Correctly
                                  Toomany3 Level 1

                                  ComputerNovice25 wrote:

                                   

                                  I had to just encode around 100 animations over again. Luckily I'm really good about keeping AE project files.

                                  That's a terribile solution! Hopefully Adobe can chime in here and get this fixed. Encoding 100 animations over again is miserable.

                                  • 14. Re: CS6 Doesn't See My Alphas Correctly
                                    J Schoens Level 1

                                    I used the above fix in CS6 and it fixed the problem but the problem has resurfaced in PPCC. I went into the file mentioned above and the lines had already been altered to 'argb'. Any new fixes available for Premiere CC?

                                    • 15. Re: CS6 Doesn't See My Alphas Correctly
                                      Amit5000

                                      Any soluction to this?  I am usinf AECC and it will not import the alpha of DNxHD files (that are recognized in older versions and in Quicktime).  VERY annoying, as we do most things around here in DNxHD

                                      • 16. Re: CS6 Doesn't See My Alphas Correctly
                                        Mark Mapes Adobe Employee

                                        AECC? Are you also having this problem in PPro CC? If not, then you might have more success posting on the After Effects forum. Regardless, what graphics card and driver do you have?

                                        • 17. Re: CS6 Doesn't See My Alphas Correctly
                                          Amit5000 Level 1

                                          It's the same in both programs.  I've discussed it with tech support and they/you were able to confirm the bug.

                                           

                                          Only posted here because this seems to be the only place it was discussed.  I will take it to the AE forum.  Thanks

                                          • 18. Re: CS6 Doesn't See My Alphas Correctly
                                            Amit5000 Level 1

                                            Also, I'm using a quadro K4000 with the latest drivers

                                            • 19. Re: CS6 Doesn't See My Alphas Correctly
                                              Mark Mapes Adobe Employee

                                              The graphics driver may be causing problems. Numerous customers have reported issues with 320.xx drivers. We have been recommending that users roll back to 311.50. Yesterday, user RjL190365 reported that 320.49 is solid: "To make the 320.49 driver work properly again, one must completely uninstall the buggy 320.18 driver and then use Driver Fusion to wipe out all traces of that buggy driver version. Then, install the previous WHQL driver set (314.22) using a clean installation, then update from 314.22 to 320.49."