4 Replies Latest reply on May 11, 2012 12:22 PM by h4ym4n derp

    Laggy Menus in Premiere Elements 10?

    h4ym4n derp

      I've been using Premiere Elements 10 for a while now, and the menus and response times are very, very slow. Maybe this is a graphics card issue? I run AMD A8 with an Nvidia GeForce GTX 560 Ti graphics card.

      Help is very, very appreciated!

        • 1. Re: Laggy Menus in Premiere Elements 10?
          Steve Grisetti Adobe Community Professional

          So many factors can affect your performance.

           

          What operating system are you using?

           

          How fast is your processor, how much RAM do you have and how much free, clean, defragmented space is on your C or main drive?

           

          What model of camcorder is your video coming from and what format and resolution is it?

           

          When you started your Premiere Elements project, which project settings did you select? If you've selected the correct project settings for your video, you will see NO red lines above your clips when you add them to your timeline. Is that the case in your project?

          1 person found this helpful
          • 2. Re: Laggy Menus in Premiere Elements 10?
            h4ym4n derp Level 1

            OS: Windows 7

            AMD A8 3.4 GHz Quad Core with 8 Gigs of RAM

            651 Gigs are free of 919 available in the C drive

            I'm not using a camcorder, I am recording gameplay footage from a pc game, the format is .avi and is 1920x1080

            I selected the settings that are correct for my clips.

             

            It's not really the clips that are having problems, its the menus in general. The fact that the clips directly from the game that are in .avi format DO slow down the speed, but after I put them together then render them and open up my real project and place the pre-rendered clips that are .mpeg, the process speeds up much, much more. This may be one of the problems, but I don't think this can be the only one. For example, even without clips in the project the menus are still a little unresponsive and scrolling speed is sluggish.

            • 3. Re: Laggy Menus in Premiere Elements 10?
              Steve Grisetti Adobe Community Professional

              Most likely the issue is your source footage. If you're getting hi-def AVIs from a screen recording program (like FRAPS), the video is using a codec that is probably not compatible with Premiere Elements and that is dragging the whole program down.

               

              Open a sample of your video in the free download Media Info and post the video specs.

               

              You may need to convert the video or  use another program to edit this format of video. Premiere Elements works great with camcorder video -- but not so much with non-camcorder sources.