4 Replies Latest reply on May 30, 2012 11:33 AM by flashprotweaker1

    what in the world is with flash pro 6 !


      okay - as soon as i loaded my code into the new version

      (i actually tried to re-download FLASH5.5 from last week

      because the FONT embedding was not working - i believe

      someone left out the **** module that Font attempts to

      access and that fonts dont work at all with flash 55? i

      tried every method on every site and have had fonts

      working before in flash5/as3 and trust me it was not

      going to work without loading something in FLEX even

      though i am not using flex, and apparently it was not



      sooo i tried to re-download to see if i accidentally did

      not install it as an option though all i remember as an

      option was unchecking the AIR items


      and i was forced to download PRO 6




      now when i compile i can tell you are doing more ecmia

      compliance and that you are actually doing reverse tracebacks

      (if not three nested layers of reverse tracebacks)


      but here's the thing - my code will not function in any way and

      will not give me any kind of sane error reporting in any way at

      all to have any idea whatsoever what is going on




      i am pretty sure i hit an actual bug in your stack and that it

      fails in the engine and does not actually get caught because

      it is an actual bug


      as far as i know you MIGHT be able to recreate the problem

      by attempting to use a dynamic type class with a static structure

      inside of it then create a static instance of that class within

      the class definition - it is a basic paradigm i am not going to

      get into naming it but it is very casual and very easy and allows

      you to do an engine driver without putting too much cruft in


      so when you define the class, let's say a simple class

      (this is psuedo-code)


      public class actionizer {

           public static var myAction = new actionizer("lemmings");

           public function actionizer () {





      then depending if you are hitting the static part (hey static

      is there for a reason!) - you go in and out of referencing the

      static parts or the actual instance, if you want to refer to

      one or the other in terms of a dictionarized type of rosterizer


      this is convenient for multi-screen systems where you want

      one engine on one screen and the other engine on the other

      screen and want to access static methods and stores for

      both of them without having to be too long winded about it

      if you need to deploy it for a client in 2 months for a comdex

      convention and absolutely need the same "engine" and at

      a minimum two screens to display what you are not going

      to repeat throughout twenty actionscript files while not

      contaminating the graphic designers and other interface



      now back in the main artillery loader you call up a bunch

      of your routines like so (also psuedo-code);


      import actionizer;

      import tokenizer;

      import lemmingizer;

      import interfacers;


      now this works because you add everything into the library

      include directions in the actionscript3 properties so that it

      will seek / hunt into the sub-directories so you can keep

      sane workgroup control


      so that gives you "global" (i am also hesitant to use that

      word) access to everything you imported, though that does

      NOT work with flash internals, because of the basic engine

      design --- which is probably what i am getting at


      in my actionizer i am not able to hit the includes my libraries





      i have eighteen years of coding experience and i know how

      the errors work and i tried a few other renders and compiles

      and things so i am prettttty sure i actually hit an uncaught-error

      in your stack due to static subclassing a static type


      now this is because all of the usages of include and library files

      are teccchnically visa vis static


      so if you mess around a bit (there is no way i can send you

      my code, i work in gaming and i have an NDA and am not

      allowed to pass it on and i might be toting this code around

      for the next eight to twelve years and i'd basically have to

      send you the engine to get it to you


      but i am prettttty sure since my code only has about two

      hundred lines at the moment that you can easily recreate it


      and what you get is a reverse traceback where all of the

      errors are sorted in opposite order from the last error

      to the first error with the first error displayed as a different

      run and i think its at least two or three sets of errors,

      but the last set is DEFINITELY printing out the line

      numbers in reverse meaning its hitting a hardcore reverse

      lookup and i am doubting that is a "new" feature of flash pro 6



      so i am pretty sure there is nothing i can possibly do to fix

      my code and i will be sitting here staring at it because i cant

      download flash pro 55 - because trust me i can not change a

      line nor add lines nor do anything whatsoever to get the

      architecture behavior to change - and its not throwing errors

      in any of the other classes and to be completely honest!!

      if i cancel out every single reference to importing the "affected

      file" -- it still hits it!!!!! lol. i mean i commented out every reference

      to it - its not a lot of code - and its still going into the library and

      include directory and nailing the **** thing





      let me know if you need any help or further comments i am

      pretty sure you can recognize the way the error is printing out

      in reverse as a technical administration engine core stack problem

      so i can give you more parts of the sembelence of the code to

      re-create it so you can trip the error in your main compiler



      thanks and i'll be in touch - right now im like doh coz there aint

      a thing i can do to this code to get over the hurdle , and im not

      even being obstinant about that lofl

        • 1. Re: what in the world is with flash pro 6 !
          flashprotweaker1 Level 1

          that's a bit of a long explanation - let me sum that up for coherence


          static subclassing a static type --


          package { class mine() { static var myScreen = new mine(); function mine() { trace("lemmings!"); } static function blank() { trace("screens off!"); } } }


          errors returned in THREE parts - last ones first


          a one item line error - a list of the main errors in reverse numeral order - and a shorter list of errors in normal order


          all errors are of type "type was not found" and "call to possibly undefined" and "access of undefined property"


          i am pretty sure it is in the area of the access of undefined property where your engine catch-faults prior to hitting the include folder


          basically if i change the package or the includes or move folders around it is still pisssssss broke dofl.

          • 2. Re: what in the world is with flash pro 6 !
            flashprotweaker1 Level 1

            oh also - to show (for coherence) what happens if i try to

            modify it


            i can add "import ,,, ack let me add something else here





            static function blank() { trace("screens off!"); screensaver.blank("SCREEN_1"); }



            okay THAT is where , aside from hitting a catch - that it gives errors (getting about 50 errors, every single reference in the file)

            now note - the other class/actionscript file right next to it doesnt throw any errors at all - very very similar - nothing wrong with it


            now if i put "import screensaver;" directly above that line


            it lists the exact same errors + one more error, in the same way


            if i put that line upwards more, same thing

            it can not find the include componentry or whatever it is called

            i can import 20 things there and it wont go anywhere, no way, no how


            now if i put the "import screensaver" alllllll the way at the top prior to the package { } declaration

            then! i get a different error, cant put the import statement there


            otherwise it's boffing on every single thing in the file - and note - not any of the other three files that are very similar



            so basically to further elucidate - i am getting the actual import statement to fail

            • 3. Re: what in the world is with flash pro 6 !
              flashprotweaker1 Level 1

              ah hell wth is with onmsdwn posting to a speed cache and running timers blowing it away

              it posts the object or mouse position in advance, gets a partial read and moves the object to a backlog of

              mouse movements or just exhibits unexplained behavior

              • 4. Re: what in the world is with flash pro 6 !
                flashprotweaker1 Level 1

                i editted this -- very very odd