26 Replies Latest reply on Aug 20, 2013 10:54 AM by RMS956

    Set Photoshop CS6 as default

    Beech04

      I have lots of JPG files that are"sort of one-of. All I need to do is open, crop, and print. I am trying to set Photoshop CS6 as the default for opening JPG files. I got through the "Open with" process to specify C:/Program Files/Adobe/Adobe Photoshop CS6 (64) bit/Photoshop.exe but it doesn't show up on the Open with list.

       

      I have also been through the Control Pane > Default Programs > Set Acccociations which takes to the Open with window. I select there and get the same result; i.e., Photoshop CS6 never shows up on the list of programs.

        • 1. Re: Set Photoshop CS6 as default
          Trevor.Dennis Adobe Community Professional (Moderator)

          Just use Bridge.  You could add the folder to Bridge as a favourite to make it more easy to access.

          • 2. Re: Set Photoshop CS6 as default
            Photojay88

            open with,browse, adobe, look for CS6 ,clik on it and thenuse as default program

            • 3. Re: Set Photoshop CS6 as default
              Beech04 Level 1

              Tried this repeatedly, failed miserable.

              • 4. Re: Set Photoshop CS6 as default
                Beech04 Level 1

                Finally got it to work. Went to Bridge > Edit > Preferences > File Type Associations. Bridge showed everything as expected: i.e., Adobe Photoshop CS6 was the default for JPG files. When I had looked earlier, I said OK, that looks good. This time, just for kicks, I reset all the Dault Associations in Bridge.

                 

                Surprise! Surprise! Surprise!, Photoshop CS6 now shows up in the Control Panel > All Control Panel Items > Default Programs > Set Associations for all the file types listed in Bridge.

                 

                The Tech service guy insisted that my Computer was the problem (I own 7 computers). Installed CS6 on two others (same problem, same fix).

                 

                Only thing that I can think of is something is not quite right with the installation program on the CD that Adobe sent me.

                1 person found this helpful
                • 5. Re: Set Photoshop CS6 as default
                  Photojay88 Level 1

                  You probably have a32 and a 64 bit  CS6 in your computer.This is  fairly

                  normal. Are you running 32 or 64 bits? You may be trying to open in 32  bits,

                  but if your running 64 that MIGHT be the problem. If you open up MY 

                  Computer and go into Adobe, see if you have both.

                   

                                                      That's about the only thing I can tell

                  you other then calling Adobe and they  will give you free help.

                   

                                                                    Photojay

                  • 6. Re: Set Photoshop CS6 as default
                    Curt Y Level 7

                    Beech04 wrote:

                     

                    Finally got it to work. Went to Bridge > Edit > Preferences > File Type Associations

                     

                    Only thing that I can think of is something is not quite right with the installation program on the CD that Adobe sent me.

                    Perhaps, but it is all too common a problem with new installations. Many users have to revise their file associations.

                    • 7. Re: Set Photoshop CS6 as default
                      marcus_baysinger

                      I've been having this same problem, but no amount of Reseting File Associations seems to help. I've also tried associating the files with both the 32 and 64 bit versions of the applications. You can browse to it when trying to "Open With" in Windows 7, but when you click on it, it does not get added to the list.

                      • 8. Re: Set Photoshop CS6 as default
                        elizabethsimcock

                        I'm having all the same problems. Setting the file associations through windows control panel > default programs lets me browse to Photoshop 6, but won't use it. Resetting default file associations in Bridge Edit > Preferences > File Type Associations does nothing. Manually using that panel to set individual filetypes to use "Adobe Photoshop CS6" looks promising, and if I open a jpg through Bridge it opens in Photoshop, but still no go if I click a file from windows explorer. Oddly, one of the suggested programs for jpgs is Illustrator.

                         

                        Possibly related wackiness: that preferences dialog in Bridge opens partly off the top of my screen and can't be rescued. Just enough is visible to use it.

                         

                        Win 7, 64bit Photoshop CS6 installed.

                        • 9. Re: Set Photoshop CS6 as default
                          TinusHDCA Level 1

                          I installed Photoshop CS6, then found CS5 was still there. I thought, hey, I don't need CS5 anymore, so I uninstalled CS5. then I found out that Photoshop was no longer available in 'Open with' when right-clicking an image...

                           

                          So I went into the Registry, HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open\command, and changed the (Default) from "C:\Program Files\Adobe\Adobe Photoshop CS5 (64 Bit)\Photoshop.exe" "%1" to "C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Photoshop.exe" "%1" (so changed CS5 to CS6) - and now I see 'Adobe Photoshop CS6' in my 'Open with' list when right-clicking an image...

                          1 person found this helpful
                          • 10. Re: Set Photoshop CS6 as default
                            captifr

                            Thank you TinusHDCA. Your solution solved my problem which was the same as a few others above. It was definetely related to uninstalling CS5.

                            • 11. Re: Set Photoshop CS6 as default
                              deesgee

                              Another big thank you to TinusHDCA.  I had exactly the same problem and doubt that I would ever have found this resolution without your guidance.  Your post is greatly appreciated - it simply sorted my problem.  If you have a few minutes please visit www.duncangrove.com .  It mainly shows a lot of overpaid celebrity tennis players thwacking balls at Wimbledon but there a a couple of other genres.  Not everyone's cup of tea though some seem to like them.  Inevitably there will be 2012 updates towards the end of this month! 

                               

                              Thanks again - in all honestly I found obvious work-arounds o the isue but the need for this irritated me and I was determined to find a proper resolution.  People like you taking the trouble to share restores my faith in the internet community!

                              • 12. Re: Set Photoshop CS6 as default
                                jorgeq

                                The regedit has not work for me. I edit it exactly as you intructed. I change Photoshop 7.0 for Adobe Photoshop CS6 (64 Bit)\ etc but CS6 did not show on explorer. I also enter (32 Bit) without results. I tried no (32 or 64 Bit) and again it won't show. BTW photshop 7.0 dissapear but it was not replaced as expected

                                Do I need to reboot for changes to take effect? Any other suggestions?

                                • 13. Re: Set Photoshop CS6 as default
                                  Noel Carboni Level 8

                                  I didn't read the whole thread above, but did you try opening Bridge CS6, going into the Preferences - File Type Associations dialog, and clicking the [ Reset to Default Associations ] button?

                                   

                                  -Noel

                                  • 14. Re: Set Photoshop CS6 as default
                                    jorgeq Level 1

                                    Sorry, never mind. I had PS CS6 open. Once I close it the regedit work fine. Many thansk TinusHDCA!!!

                                    • 15. Re: Set Photoshop CS6 as default
                                      dytb2012 Level 1

                                      For mine, the HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\edt\command was correctly set, however, the HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open\command was set as

                                      "C:\Program Files\Adobe\Adobe Photoshop CS5.1 (64 Bit)\Photoshop.exe" "%1". Surely there are some bugs in the installation program.

                                       

                                      Thanks TinusHDCA.

                                      • 16. Re: Set Photoshop CS6 as default
                                        TinusHDCA Level 1

                                        @dytb2012: I did mention shell/open...

                                        • 17. Re: Set Photoshop CS6 as default
                                          dytb2012 Level 1

                                          yah, yah. I know, just to hightlight the edit part.

                                          • 18. Re: Set Photoshop CS6 as default
                                            bjf5242635 Level 1

                                            Thank you, thank you.  This has been driving me nuts!  Finally using dytb2012's explanation of what to change in the registry, I have gotten it to work.  When is Adobe going to address this problem and fix it.  What a pain it has been.  Thank you all again.  All good ideas but this little hidden change really worked. 

                                            • 19. Re: Set Photoshop CS6 as default
                                              NorCalFox Level 1

                                              Thanks @TinusHDCA! Even my IT department was having trouble figuring this one out.

                                               

                                              Just a note to others, this registry location/method above works for all the CS6 programs, except Fireworks. For Fireworks you must edit the value located at HKEY_CLASSES_ROOT\.png or
                                              HKEY_CLASSES_ROOT\.pngfile


                                              Also, Flash shows up as "FlashPlayer.exe" under the Registry, HKEY_CLASSES_ROOT\Applications but changing the value to "C:\Program Files (x86)\Adobe\Adobe Flash CS6 \Flash.exe" "%1" fixes the .fla file associations to Flash CS6 too.

                                              • 20. Re: Set Photoshop CS6 as default
                                                mraw7919

                                                I'm sorry, but I am technically challenged. I was able to find HKEY_CLASSES_ROOT, but that's it. It doesn't lead to the other drilldowns listed in the fix that's been posted. Where do I go from there? I'm pretty surprised that this issue hasn't been fixed being that this thread was started in May. Thanks!!

                                                • 21. Re: Set Photoshop CS6 as default
                                                  TinusHDCA Level 1

                                                  From there you can further drill down to HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open\command?

                                                  Untitled.gif

                                                  • 22. Re: Set Photoshop CS6 as default
                                                    Curt Y Level 7

                                                    If you have uninstalled a previous version of photoshop some users find the file associations fouled up.  Changing the file association in Bridge will not solve problem.  You either have to uninstall CS6, run the Adobe Script cleaner, or change a registry entry.

                                                     

                                                    Here is entry from a previous post on problem.

                                                     

                                                    So I went into the Registry, HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open\command, and changed the (Default) from "C:\Program Files\Adobe\Adobe Photoshop CS5 (64 Bit)\Photoshop.exe" "%1" to "C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Photoshop.exe" "%1" (so changed CS5 to CS6) - and now I see 'Adobe Photoshop CS6' in my 'Open with' list when right-clicking an image...

                                                    • 23. Re: Set Photoshop CS6 as default
                                                      PmPhotographic Level 2

                                                      Yes, a thanks from me too.  I had uninstalled previous versions, and then found photoshop CS5. was not available in the lists of default programmes, which was true for most of the CS5.5 suite, although strangely, Illustrator was listed

                                                      • 24. Re: Set Photoshop CS6 as default
                                                        RMS956

                                                        Thanks for solution TinusHDCA. It worked for me.

                                                         

                                                        Now what I would like to do is keep both my CS5(Extended) and CS6 versions running on the same PC, but due to this fix, I can't bring up the CS5 exe as an option to "Open with" anymore. Is there a registry edit to make both apps availble in the "Open with" menu?

                                                         

                                                        Thanks again, RMS

                                                        • 25. Re: Set Photoshop CS6 as default
                                                          TinusHDCA Level 1

                                                          Hi RMS,

                                                           

                                                          I have not tried keeping both CS5 and CS6 next to each other. You could try and add an additional key - maybe

                                                          HKEY_CLASSES_ROOT\Applications\Photoshop2.exe\shell\open\command, and point that to CS5? I don't know whether that works...

                                                           

                                                          TinusHDCA

                                                          • 26. Re: Set Photoshop CS6 as default
                                                            RMS956 Level 1

                                                            Thank you again TinusHDCA.

                                                             

                                                            Your idea worked. Now I have the option to open most image files using the "Open with" dialog(right click on mouse pointed at file) and be able to choose CS5 or CS6. I've been using CS5 Extended for a while and created 3D images that won't open in CS6 Standard. I purchased the Design Standard CS6 suite for it's Illustrator program but now I see I need to keep Photoshop CS5 on my PC for the 3D.

                                                             

                                                            Many thanks, RMS