2 Replies Latest reply on May 16, 2012 2:17 PM by Noel Carboni

    What Are The Condions that Make OpenCL Unavailable?

    Noel Carboni Level 7

      Up to 2 days ago I had ATI Catalyst 12.2 installed.  I was able to check all the boxes in the Advanced Graphics Processor Settings dialog and they stayed set.  Specifically, I had [  ] Use OpenCL set and Photoshop CS6 worked very well.

       

      Because I need to know about the quality of newer drivers for my own product development, I upgraded my ATI driver suite to the current version - Catalyst 12.4.

       

      Unfortunately, this caused new problems I hadn't had before - specifically a number of GPU-accelerated features didn't work, such as Oil Paint, which would try to start then just exit.  And with Catalyst 12.4 the [  ] Use OpenCL box became grayed-out.

       

      With my own testing done, I decided to completely uninstall the ATI Catalyst 12.4 suite, and drop back to Catalyst 12.2, which worked well.  This was a simple matter of uninstalling everything AMD then rebooting (with the Windows driver), then installing Catalyst 12.2.  That went smoothly.

       

      However, now I still do not find the [  ] Use OpenCL box has become available again - it's grayed out:

       

      OpenCLUnavailable.jpg

       

      I'm pretty sure there are no remnants from the 12.4 drivers left anywhere on my system, and everything from the 12.2 set installed successfully, so the question is this:  Did Photoshop sense something about the 12.4 driver set, then set some kind of permanent "No OpenCL" flag in its own configuration settings?

       

      Here's my system info with the 12.2 drivers installed.  Note the "OpenCL: Unavailable" entry.

       

      http://Noel.ProDigitalSoftware.com/ForumPosts/SystemInfo.txt

       

      -Noel