8 Replies Latest reply on Oct 3, 2012 10:19 PM by anjananil

    Flex application compiled with SDK 4.5.1 cannot run with the application compiled with SDK 4.1?

    FMahesh

      Hi,

       

      I have main application which loads the custom application created by me.

      Main application is being compiled using Flex SDK 4.1 version, and my custom application is compiled using Flex SDK 4.5.1 version.

       

      I am getting following error while loading the custom application:

       

      VerifyError: Error #1053: Illegal override of virtualLayoutSupported in spark.layouts.BasicLayout.

       

          at flash.display::MovieClip/nextFrame()
          at mx.core::FlexModuleFactory/deferredNextFrame()
          at mx.core::FlexModuleFactory/update()
          at mx.core::FlexModuleFactory/moduleCompleteHandler()

       

      How do I resolve this error?

      Does all the .swf files or application should be compiled using the same version Flex SDK?