10 Replies Latest reply on Oct 17, 2012 2:01 AM by Duberry_Wotsit

    SCUP Installation of 11.2

    Duberry_Wotsit

      Hi,

       

      I am using SCUP to update a v10 deployment to v11.2.  The installation appears to work, with the updates agent showing installed status for all four updates which get applied to an x64 system:

       

      Adobe Flash Player 32-bit ActiveX 11.2.202.235

      Adobe Flash Player 64-bit ActiveX 11.2.202.235

      Adobe Flash Player 64-bit Plugin 11.2.202.235

      Adobe Flash Player 32-bit Plugin 11.2.202.235

       

      That said the WindowsUpdate.log file shows a failure as follows:

       

      Windows failed to install the following update with error 0x80070643: Adobe Flash Player 32-bit ActiveX 11.2.202.235

       

      Now Flash Player is working in all browsers but the ActiveX Flash Player does not show in Add/Remove Programs.  IE shows that it is using the ActiveX player.

       

      The FlashInstall.log in SysWow64\Macromedia\Flash shows:

       

      2012-5-18+10-39-54.631 [error] 1226 1062

      =O====== M/11.2.202.235 2012-05-18+10-39-52.900 ========

      0000 [I] 00000010 "C:\Windows\TEMP\{8F50881C-1A05-45FE-AF56-D34F4C74F081}\InstallFlashPlayer.exe" -install -skipARPEntry -iv 2 -au 4294967295

      0001 [W] 00001036 Software\Macromedia\FlashPlayer\SafeVersions/11.0 2

      0002 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

      0003 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2

      0004 [I] 00000020 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

      0005 [W] 00001037 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX/ 2

      0006 [W] 00001015 C:\Windows\SysWOW64\Macromed\Flash\Flash10m.ocx 5

      0007 [I] 00000018

      0008 [W] 00001015 C:\Windows\SysWOW64\Macromed\Flash\Flash10m.ocx 5

      0009 [I] 00000013 C:\Windows\SysWOW64\Macromed\Flash\Flash32_11_2_202_235.ocx

      0010 [I] 00000015 C:\Windows\SysWOW64\Macromed\Flash\FlashUtil32_11_2_202_235_ActiveX.exe

      0011 [I] 00000016 C:\Windows\SysWOW64\Macromed\Flash\FlashUtil32_11_2_202_235_ActiveX.dll

      0012 [I] 00000019 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

      0013 [W] 00001024 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl 183

      0014 [W] 00001024 C:\Windows\SysWOW64\FlashPlayerApp.exe 183

      0015 [I] 00000021 C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerUpdateService.exe

      0016 [W] 00001106

      0017 [W] 00001106

      0018 [W] 00001024 C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerUpdateService.exe 183

      =X====== M/11.2.202.235 2012-05-18+10-39-56.709 ========

       

      and

       

      2012-5-18+10-40-6.910 [error] 1226 1062

      =O====== M/11.2.202.235 2012-05-18+10-40-05.769 ========

      0000 [I] 00000010 "C:\Windows\TEMP\{181D6F14-892A-40BB-A39F-10E973E139E7}\InstallFlashPlayer.exe" -install -skipARPEntry -iv 2 -au 4294967295

      0001 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/Version 2

      0002 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/PlayerPath 2

      0003 [I] 00000020 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

      0004 [W] 00001037 SOFTWARE\MozillaPlugins\@adobe.com/FlashPlayer/ 2

      0005 [W] 00001037 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player Plugin/ 2

      0006 [W] 00001036 Software\Opera Software/Last CommandLine 2

      0007 [W] 00001036 Software\Opera Software/Last CommandLine 2

      0008 [W] 00001036 Software\Opera Software/Plugin Path 2

      0009 [W] 00001036 Software\Opera Software/Plugin Path 2

      0010 [I] 00000014 C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_2_202_235.dll

      0011 [I] 00000015 C:\Windows\SysWOW64\Macromed\Flash\FlashUtil32_11_2_202_235_Plugin.exe

      0012 [I] 00000017 C:\Windows\SysWOW64\Macromed\Flash

      0013 [I] 00000019 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl

      0014 [W] 00001024 C:\Windows\SysWOW64\FlashPlayerCPLApp.cpl 183

      0015 [W] 00001024 C:\Windows\SysWOW64\FlashPlayerApp.exe 183

      0016 [I] 00000021 C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerUpdateService.exe

      0017 [W] 00001106

      0018 [W] 00001106

      0019 [W] 00001024 C:\Windows\SysWOW64\Macromed\Flash\FlashPlayerUpdateService.exe 183

      =X====== M/11.2.202.235 2012-05-18+10-40-08.594 ========

       

      So it clearly thinks there is some kind of failure.

       

      I need to be confident of this update before rolling to 000's of machines so any input appreciated...

       

      EDIT - OK I now know this only happens if intenet explorer it loaded at the time the updates are applied.  There is no way to control this when deploying via SCUP so should the installers be able to handle IE being loaded at installation time?

        • 1. Re: SCUP Installation of 11.2
          chris.campbell Adobe Employee

          You should only have to run the 64 bit updates as they contain both the 32 and 64 bit components.

           

          There is no install switch that will ignore an opened browser.  However, with the release of 11.2 this issue should only occur for re-installs of the same version.  You should not see this occurring when updating to new versions.

          1 person found this helpful
          • 2. Re: SCUP Installation of 11.2
            Duberry_Wotsit Level 1

            That is interesting, SCUP decides that all 4 installers are requiredusing the prerequisites from the adobe catalog. Question is, does it matter? Still functions just doesn't show as an installed program in the control panel.

            • 3. Re: SCUP Installation of 11.2
              Duberry_Wotsit Level 1

              OK back this morning and had a look at the installable rules for the installer.  Basically the x64 installer has a rule which contains the following...

               

              Processor architecture is x64

               

              However the 32 bit version does not have a rule related to architecture.

               

              Therefore on a 64-bit machine it will attempt to install both the 64bit versions and the 32bit version, which is where the problem exists.

               

              The machines currently have 32-bit flash 10, if we install only version 11.2 64-bit am I right in thinking it will remove the 32-bit 10 and leave only the correct 64-bit version installed?

              • 4. Re: SCUP Installation of 11.2
                chris.campbell Adobe Employee

                Duberry_Wotsit wrote:

                 

                OK back this morning and had a look at the installable rules for the installer.  Basically the x64 installer has a rule which contains the following...

                 

                Processor architecture is x64

                 

                However the 32 bit version does not have a rule related to architecture.

                 

                Therefore on a 64-bit machine it will attempt to install both the 64bit versions and the 32bit version, which is where the problem exists.

                 

                The machines currently have 32-bit flash 10, if we install only version 11.2 64-bit am I right in thinking it will remove the 32-bit 10 and leave only the correct 64-bit version installed?

                 

                Yes, I believe that is a correct assumption.  Sorry if I wasn't clear in my previous post, your observation of the 64 bit installer's prerequisite and functionality are both correct.

                • 5. Re: SCUP Installation of 11.2
                  Duberry_Wotsit Level 1

                  I have copied and edited the updates with SCUP so that the 32-bit versions will only install on an x86 system.  This has fixed the issue for 64-bit systems, they now only get the two 64-bit updates pushed at them.  All working fine on the 64-bit front.  Getting a number of 32-bit systems where they fail but actually it isn't a SCUP issue, on those machines if I log in and try to install manually it fails removing version 10 with the Error 2753. The file 'FP_AX_MSI_INSTALLER.exe' is not marked for installation.

                   

                  I am not sure why this happens, could possibly be down to the methods used to install v10 in the first place.  The Adobe flash uninstaller does not fix this, I had to manually remove registry keys to get v11.2 to install.  We don't have too many 32 bit systems left but if it becomes a major problem I will look to deploy a script to remove the keys so the 11.2 install can function.

                  • 6. Re: SCUP Installation of 11.2
                    chris.campbell Adobe Employee

                    Could we get the following info from you?

                     

                    1. What are the exact registry paths which still exist in the registry after running the uninstaller?

                    2. The FlashInstall.log from the following locations on a system that exhibits this issue?

                    C:\Windows\System32\Macromed\Flash\

                    C:\Windows\SysWOW64\Macromed\Flash\

                     

                    Thanks,

                    Chris

                    • 7. Re: SCUP Installation of 11.2
                      Ben2011

                      Hi Chris,

                       

                      Is there any plans to change the Installable rules for the x86 Flash updates in future versions published through the official catalogue to limit applicability to only 32bit machines. Just so we don’t need add this additional rule manaully before publishing to SCCM. Ideally we want to be able to have all Flash updates in a single SCCM SU  deployment and let the update Installable rules determine correct applicability.

                       

                      Thanks

                       

                      Ben

                      • 8. Re: SCUP Installation of 11.2
                        chris.campbell Adobe Employee

                        Hi Ben,

                        Starting with 11.3 (which is in beta right now), we have a universal installer for both 32 and 64 bit systems.  AFAIK, this will carry over to msi's too.

                         

                        Chris

                        • 9. Re: SCUP Installation of 11.2
                          dudeness44 Level 1

                          Hi, I'm using SCCM/SCUP to deploy flash to 32-bit Windows 7 and Vista. Now using the universal installer 32/64. Installing fine for the vast majority of computers, but some are still giving the "Error 2753. The file 'FP_AX_MSI_INSTALLER.exe' is not marked for installation. " error message in Event Viewer Application Log. The same problem is persisting and I just cant see why some machines have it. Currently now pushing out 11.4.402.287, and have same issues.

                           

                          The Sytem Log says: Installation Failure: Windows failed to install the following update with error 0x80070643: Adobe Flash Player 32-bit/64-bit ActiveX 11.4.402.287.

                           

                          The SCCM log file c:\windows\system32\ccm\logs\WUAHandler.log says: Installation job encountered some failures. Error = 0x80240022

                          • 10. Re: SCUP Installation of 11.2
                            Duberry_Wotsit Level 1

                            This link may help you...

                             

                            http://www.gregorystrike.com/2011/08/16/adobe-flash-player-%E2%80%98fp_ax_msi_installer%E2 %80%99-installer-error-script/

                             

                            If you edit this script to make it completely silent you can push it out to all your machines where you are getting the error.  Then push out your Flash updates again and you should be okay.  I don't know exactly why the error comes up but I think it must be related to the method used to install flash in the original instance.