6 Replies Latest reply on May 21, 2012 12:26 AM by HazardSports

    nesting problem

    HazardSports Level 1

      In After Effects CS6:  I have a "main" comp that I have imported ("nested") other smaller AAE CS6 comps into.   When I double click on one of my smaller comps it opens so that I can make / save adjustments.  When I return to the "main" comp all of the adjustments are reflected. However, when I open that smaller comp by its self, (OUTSIDE of the "main" comp) none of my saved changes are updated.  Is there a setting or something I need to change ?  The same is in reverse.  If I update a smaller comp it will not reflect the saved changes in the "main" comp it is also nested in unless I delete it from the main comp and re-import it.   It says "UPDATE IN ONE STEP" however I can't seem to figure out how. Please help !

        • 1. Re: nesting problem
          Mylenium Most Valuable Participant

          I don't quite follow. Doesn't matter from where a comp is opened. The parent comp will/ should always reflect the changes made to nested comps. Does it update when you scrub the main comp timeline? Could simply be an issue with this new-fangled cache system not working properly. Likewise, this could be graphics card issues where the hardware buffers aren't flushed and updated properly, so update your graphics driver just to be sure. Everything else will require further explanations and screenshots.

           

          Mylenium

          • 2. Re: nesting problem
            HazardSports Level 1

            I Am using CS6 and working on a MacBook Pro (early 2009) with 8gb Ram and 480gb SSD (only 200gb used).  All software and drivers are up tomdate. Scrubbing, playing, or restarting application makes no updates to changes.  If I make the change in the nested comp from within the Parent comp - it will not reflect the changes when I open the nested comp from outside the parent comp, (and vice versa).  This is frustrating !  Do you have any other suggestions ?  I did check all preference settings and found nothing to address this issue !  Thank you for your efforts to help me resolve this matter !

            • 3. Re: nesting problem
              Mylenium Most Valuable Participant

              This sounds highly irregular. Can you provide a screenshot of your timeline and the project window?

               

              Mylenium

              • 4. Re: nesting problem
                HazardSports Level 1

                In the below pic you can see that "EasyEase IN" to the "25MPH" layer is indicated at about 35sec.  You can see by the tabs that I am in the Parent Comp, but making adjustments to the nested comp.

                Screen shot 2012-05-20 at 5.57.31 PM.png

                In the below pic you can see that "EasyEase IN" to the "25MPH" layer is NOT indicated (at 35sec) and all of my layer color preferences are different.  Here is the nested comp by itself, outside of the parent comp.

                Screen shot 2012-05-20 at 5.58.38 PM.png

                I had another comp in which I added multiple layers and did some intricate work; but when I realized they weren't updating I had no choice but to just drop them in the parent comp to speed up my workflow, (I cant keep updating the same comp in two places, (double the workload).

                 

                 

                 

                If you woud like me to zoom in on something specific let me know.

                • 5. Re: nesting problem
                  Mylenium Most Valuable Participant

                  I don't quite follow. All your layers in your images are locked, so you won't be able to do anything with them, no matter from where they are opened. And if you are seeing different colors, you are opening a different comp. Really, you have messed up somewhere and create duplicates and are working on teh wrong versions.

                   

                  Mylenium

                  • 6. Re: nesting problem
                    HazardSports Level 1

                    All the layers were locked only AFTER I gave up on the "Update in one step" concept and decided to continue to work !  I understand how to lock and unlock.  I am certain that I do not have duplicates as I always keep a very neat file system and am meticulous on file naming and locations. Even if it were true, I would've eliminated that theory in my original post when I mentioned that it only updates when I delete re-nested comp and re-import that nested comp into the parent comp.  Then again, further updates don't continue to update.  I will have to call Adobe today and post the resolution when (if) we discover it because it appears as if there is no logical solution !  Thank you for your efforts but appears as if the solution is beyond both of our skill levels !