2 Replies Latest reply on Jul 18, 2012 3:18 PM by AMLlys002

    Debugging in Flash Pro CS6 is outright broken for me

    Eggerslolol

      I started a project in 5.5 and downloaded the trial of 6 to try it out, but I'm having really big troubles debugging in 6. It's an AIR for Android project.

       

      Basically, when I start debugging, most of the time the app will just close immediately. If it doesn't, I can tinker around for a couple of minutes, 3 or 4 at most, and then it closes. It doesn't say why, just the usual [UnloadSWF] and Debug session terminated. I have found nothing that consistently makes it terminate, makes it work upon starting, or anything in between. All seems totally random, and didn't happen AT ALL in 5.5.

       

      I can't be the only one having this problem but I can't find any posts about it. Any help would be greatly appreciated.

        • 1. Re: Debugging in Flash Pro CS6 is outright broken for me
          Sudeshnasarkar27 Adobe Employee

          Hi ,

           

          Can you share the Android project so that we can investigate the issue and get back to you?

           

          Thanks and regards,

          Sudeshna Sarkar

          Adobe Flash Professional Team.

          • 2. Re: Debugging in Flash Pro CS6 is outright broken for me
            AMLlys002

            I'm having a similar problem (although I know this post is a few months old, I can't seem to find an answer)

             

            When I run out of CS6 in debug mode to test my project (working in AIR for iOS), the project gets up and running, but more than half the time it will then simply close and all I get is:

            Unload[SWF] blahblahblah.swf

            Debug session terminated

            Debug session terminated

             

            (yes, it says it twice)

             

            this can happen within ten seconds or two or three minutes later.  There seems to be no pattern to what causes it (simply leaving the project up and not interacting with it will cause it to eventually happen, or I can click around in the project for a few minutes and then it will randomly happen).  This is really killing my production schedule as the project is already very large and simply running the debugger takes a few minutes to load up just to have it crash and then have to run the debugger again and wait for it to load again.  I ran the same project in 5.5 a while back before switching to 6.0 and never encountered this problem.

             

            anyone figure this out yet?