1 Reply Latest reply on Mar 31, 2008 11:56 AM by cxf02

    Flex Builder module compile issues.

    Johnny Richardson
      Hello,

      I am currently trying to compile an application in Flex Builder 2.0.155577 that uses several modules for the majority of content. The vast majority of the code has not changed in months, however several days ago, when I re-enabled a feature of one module (a simple checkbox), I noticed that none of the modules were loading locally, and when I uploaded our newly compiled SWF, I received a bunch of vague errors. Please note that these occur on runtime, NOT during compile:

      quote:

      VerifyError: Error #1053: Illegal override of subtopic in mx.messaging.Producer.

      ReferenceError: Error #1065: Variable _DividedBoxStyle__embed_css_Assets_swf_mx_skins_cursor_HBoxDivider_350143000 is not defined.

      ReferenceError: Error #1065: Variable _DragManagerStyle__embed_css_Assets_swf_mx_skins_cursor_DragCopy_2001250203 is not defined.

      ReferenceError: Error #1065: Variable _VDividedBoxStyle__embed_css_Assets_swf_mx_skins_cursor_HBoxDivider_350143000 is not defined.

      ReferenceError: Error #1065: Variable _DragManagerStyle__embed_css_Assets_swf_mx_skins_cursor_DragMove_2001525311 is not defined.

      ReferenceError: Error #1065: Variable _TreeStyle__embed_css_Assets_swf_TreeDisclosureOpen_520804948 is not defined.

      ReferenceError: Error #1065: Variable _TreeStyle__embed_css_Assets_swf_TreeFolderClosed_750444693 is not defined.

      ReferenceError: Error #1065: Variable _TreeStyle__embed_css_Assets_swf_TreeNodeIcon_802707448 is not defined.

      ReferenceError: Error #1065: Variable _DividedBoxStyle__embed_css_Assets_swf_mx_skins_BoxDividerSkin_707114747 is not defined.

      ReferenceError: Error #1065: Variable _VDividedBoxStyle__embed_css_Assets_swf_mx_skins_BoxDividerSkin_707114747 is not defined.

      ReferenceError: Error #1065: Variable _DragManagerStyle__embed_css_Assets_swf_mx_skins_cursor_DragLink_2001511970 is not defined.

      ReferenceError: Error #1065: Variable _VDividedBoxStyle__embed_css_Assets_swf_mx_skins_cursor_VBoxDivider_1195587798 is not defined.

      ReferenceError: Error #1065: Variable _CursorManagerStyle__embed_css_Assets_swf_mx_skins_cursor_BusyCursor_1681370625 is not defined.

      ReferenceError: Error #1065: Variable _TreeStyle__embed_css_Assets_swf_TreeDisclosureClosed_919320378 is not defined.

      ReferenceError: Error #1065: Variable _DragManagerStyle__embed_css_Assets_swf_mx_skins_cursor_DragReject_1360606643 is not defined.

      ReferenceError: Error #1065: Variable _SWFLoaderStyle__embed_css_Assets_swf___brokenImage_1350161637 is not defined.

      ReferenceError: Error #1065: Variable _TreeStyle__embed_css_Assets_swf_TreeFolderOpen_893185877 is not defined.


      These errors obviously stem from the inability to load a module using ModuleLoader, but the question is, why? All settings seem to be correct, as we compiled the same project on a different development box (running Leopard 10.5.2, whereas I am on XP SP2) with identical compiler setup, and everything comes up dandy.

      Has this happened to anyone else? Is there something else I can do to diagnose the cause? What other information might I be able to provide?

      Thanks in advance for any advice!