7 Replies Latest reply on May 27, 2012 10:08 AM by Frustrated in AZ

    Can't download Ebook from my local library

    blackie 56

      When I download an ebook from my local library using ADE it won't download it into my ADE library only unto my computer (the book doesn't appear in my ADE libarary) so I can't transfer it to my Kobo.  Both my Kobo and my Mac computer are activated with ADE.  This function worked perfectly until last week so I tried uninstalling and reinstalling but with no success.  Help!

        • 1. Re: Can't download Ebook from my local library
          Frustrated in AZ Level 4

          Reinstalling the software normally will not fix this kind of issue.

           

          I'm not sure what 'feedback' you got from ADE when you did the

          download.   You should not have to go through this process.  IF you have

          registered with Adobe and obtained an Adobe ID, and then downloaded and

          installed ADE, it will carry the registration information with it.

          Libraries generally use Overdrive software, which checks for registered

          copies of ADE or other ebook software on your computer during their

          download process.  When Overdrive finds that information, it will activate

          ADE during the download process.

           

          The normal process is:

           

          Find the ebook on the library site and go through whatever process they

          have to download it to your computer.

           

          When the download starts, you should have an option as to whether to OPEN

          or SAVE the ebook, and where to store it.  Usually, when ADE is installed,

          the location will be where the ADE library is located (My Digital Editions

          folder).

           

          Choose SAVE.  The library will continue with the download process, open

          ADE, and the ebook should appear in your ADE library.

           

          Of course things can go wrong.  For starters, if you did not register with

          Adobe before you downloaded and installed ADE, then ADE might not open at

          all, and the library will download the pointer file (ebooktitle.ascm) to

          your computer.  If this occurs, then you can 'grab' the ebook by finding

          the file, then right-clicking on it and choosing 'Open With' from the

          drop-down menu.  ADE should show up in the list of programs that appear.

          Choose ADE, and ADE should start to open the file.

           

          ADE might open the ebook in Reading mode.  If it does, then close the

          ebook.  Then, go to Library mode, and click on the small arrow next to the

          word 'Library'.  A drop-down menu will appear.  Select 'Add Item To

          Library', and ADE will open another window asking you to tell it what ebook

          and where that ebook is.  Fill in the information and ADE will add the

          ebook to your library.

           

           

          ==============

          • 2. Re: Can't download Ebook from my local library
            blackie 56 Level 1

            Thanks for your email.  I am registered with ADE (when I checked on ADE it says my computer is authorized).  Do I also have to be authorized with the Overdrive program?

            I tried your suggestion with choosing save instead of open and an error came up saying:

            Error on local file open #2038

            Path:/users/janeicesalvail/Downloads/LastStorytellerANovel.9780679644224-3.acsm. 

             

            Also when I chose Save I checked the box to say always Save on this computer and I probably shouldn't have cause now I don't have the option to save or open.

            When I originally installed ADE and and the Overdrive software it worked fine.  I had a problem with my Mac last week and had to uninstall and reinstall both ADE & Overdrive and consequently suffered this current download problem.  Now I'm a little lost as to what to do next.  If you could offer any further suggestions I would really appreciate it.

            Thanks.

            Janeice SAlvail

            • 3. Re: Can't download Ebook from my local library
              Frustrated in AZ Level 4

              I have some limitations on offering suggestions.  I'm a Windows XP guy -

              and you're on a Mac.  Also, you mention that you have both ADE and

              Overdrive installed on your computer, so I'm not sure whether you think

              both work together on your computer or which one you used at which point in

              time.  Let me leave the Windows-Mac thing alone for a moment and work on

              the other stuff.

               

              The library uses Overdrive.  You do not need to have Overdrive installed on

              your Mac just because the library uses it on their computers.  The normal

              process is for the library's Overdrive system to hand off a small file to

              your computer, and then, the library's Overdrive system will start ADE to

              process that file.  This is the =====.ascm file you mention.

               

              I think we might be able to work out something here.  You know where the

              .ascm file is.  So, you can click on it and choose whatever Mac's

              equivalent to 'open with xxx program' is.  When that dialogue starts,

              choose to use ADE for the program.  ADE then should decode the .ascm file,

              go out to the location of the ebook on the internet, download it to your

              Mac and place it in ADE's My Digital Editions library.  ADE should record

              the ebook's title in its Library.

               

              The 'small problem' you mention may be at the heart of your issues.  There

              have been some upgrades to Mac OS as well as Overdrive software.  And as

              you know, any changes to software like that can cause operational

              problems....

               

              Hope this helps!

              ===============

              • 4. Re: Can't download Ebook from my local library
                blackie 56 Level 1

                Thanks for your suggestion but I still get the same error message when I tried it.

                The only reason I have Overdrive installed on my computer is because my library suggested it.  I don't really think I need it as when downloading all I use is ADE to transfer ebooks.

                I had just done a Mac OS update prior to all the trouble so I think that is responsible for all this trouble.

                Any other suggestions?  Thanks.

                Janeice Salvail

                • 5. Re: Can't download Ebook from my local library
                  Frustrated in AZ Level 4

                  Lion is not compatible with ADE.  If that was your upgrade....

                   

                  Alternative ideas: download the .ascm file to your Mac and use iTunes to

                  open it - that 'should' work.

                   

                  Another idea: ditch Overdrive if iTunes works for you...

                   

                  =========================

                  • 6. Re: Can't download Ebook from my local library
                    blackie 56 Level 1

                    Hi,

                    I tried to use iTunes but because I clicked the box to always use ADE to open the downloaded ebook, that window doesn't come up now so I can't choose to use iTunes instead.  Do you now how I can undo the click??

                    I have Mac OS X 10.6.8 version.  Do you know if this is compatible with ADE?  If it isn't which versions are compatible and how do I go about ditching the incompatible version and downloading the compatible one??  Thanks.

                    Janeice Salvail

                    • 7. Re: Can't download Ebook from my local library
                      Frustrated in AZ Level 4

                      I can't tell you much about your Mac OS or how to undo the 'click'. On a

                      Windows computer, you have an option that lets you change the program

                      assigned to your files, and I 'assume' that a Mac would have the same

                      option - I just don't know how to do that....  Sorry!

                       

                      =============