7 Replies Latest reply: Jun 5, 2012 10:57 AM by BlebNevus RSS

    Firefox plug-in doesn't work

    BlebNevus Community Member

      I’ve just installed the latest version of Adobe Reader X but can’t get it to work with Firefox 12. Whenever I click on a PDF in my browser, I get an error message saying that the file “could not be opened, because the associated helper application does not exist. Change the association in your preferences.”

       

      Here’s what I’ve already done:

      1 - In Adobe preferences, confirmed that “Display PDF in browser” is checked.

      2 - In Firefox’s add-ons manager / plugins:  confirmed that Adobe Acrobat is there, and not disabled.

      3 - In Firefox tools / options / applications:  found 3 Adobe items, each of which offers a choice in drop-down menu between “Use Adobe Reader (default)” and “Use Adobe Acrobat in Firefox.”  I’ve tried both.  Neither works.

       

      What am I missing?

        • 1. Re: Firefox plug-in doesn't work
          LoriAUC CommunityMVP

          You'll need to manually try adding the Acrobat button to the toolbar in Firefox in version 12. Choose Customize, and drag in the button titled "Convert" with the Acrobat icon.

          • 2. Re: Firefox plug-in doesn't work
            BlebNevus Community Member

            Thanks for your reply.  I'm familiar with customizing the Firefox toolbars, but where do I find the "Convert"/Acrobat button to drag in?  It doesn't show up in the box of other icons when I click on "customize."

            • 3. Re: Firefox plug-in doesn't work
              BlebNevus Community Member

              As I reread your advice, I'm more confused.  Even if I find the button you mean, which of Firefox's toolbars am I supposed to drag it to?  And why would that have any effect, since the point of a plug-in is to automatically load the program in the background (in this case, so Acrobat will open PDFs when I click on links on-line)?  It's not as if I'm going to be taking the extra step of clicking on a button in a toolbar during that process, right?

              • 4. Re: Firefox plug-in doesn't work
                LoriAUC CommunityMVP

                Sorry for the confusion, I thought you had the PDFMaker installed (for Acrobat not Reader). Just to confirm, you don't have both Reader 8 and Acrobat X Pro installed do you? In Firefox under Tools > Options > Applications you should have  “Use Adobe Reader (default)” selected since you have Reader installed on your system.

                Have you tried doing a Repair of your Reader installation from under the Help menu in Reader to see if it corrects the problem?

                • 5. Re: Firefox plug-in doesn't work
                  BlebNevus Community Member

                  1.  No, I don't have Reader 8 installed.

                  2.  Yes, I've selected “Use Adobe Reader (default)” under applications.  (I tried the other Adobe option, too, as I mentioned.)

                  3.  I tried repairing the Reader installation, which had no effect.

                  4.  The plug-in listed in Firefox is Adobe Acrobat, rather than Reader, but I assume that's what's supposed to happen since it installed it automatically when I installed Reader X.

                   

                  It's hard to believe I'm the only Firefox user who's experiencing this problem . . .

                  • 6. Re: Firefox plug-in doesn't work
                    LoriAUC CommunityMVP

                    Are you able to save one of these PDFs you're trying to view locally (on your hard drive) and then open it up in your browser?

                    • 7. Re: Firefox plug-in doesn't work
                      BlebNevus Community Member

                      Well, I can save PDFs from the web on my hard drive and then open them with Acrobat.  I'm not sure about how I would then open them in my browser (or why I'd want to).

                       

                      Since Acrobat can open local PDFs, and Firefox can (sometimes) open PDFs on-line with other software, it seems clear that the problem lies in the interface between the reader and the browser -- presumably meaning the plug-in.